none
Windows 2012 R2 printers showing twice (and unable to set default printer)

    Question

  • Hello,

    I have a problem that will not just go away. I have two Windows 2012 R2 servers: one with RDS installed for 30 users with an appointment application and one "back-end" server were print queues and database are running.

    So basically, users can connect to network printers by clicking on a link that points to the "back-end" server. In Windows 2008 R2, this is so simple but in Windows 2012 R2, I am experiencing tons of issues (with both V3 and V4 drivers). By the way, printer redirection in RDS (remote desktop) is disabled and forbidden by GPOs. I am listing the issues here to see if someone experienced them before:

    1. After a disconnection between the printer and the RDP session (the servers are in a remote site as the printers are local and printing through a site-to-site VPN tunnel as they are all IP printers). Example: a power failure will set a particular printer at "offline", which is normal and eventually, it comes back online. But then, the problem starts: the printer "loses" it "default printer" status and none of the printers for a specific user are showing as default printer in his printer list. If I try to set again the desired printer to default, it is already "set as default" but the green "tick" is not showing on the printer icon and printing fails.

    2.  When the above happens, I usually try to delete the printer from the user session and reconnect to it. But then, it is even worse: the specified printer is now showing "twice" in the list of "device and printers" for a specific user while working OK for another (when you right click the printer, you see two instances of it). This is interfering with our main application and a specific user session is non functional. A printer will also show in the "unspecified section"

    3. Even a bigger problem: if I delete a particular printer from a specific RDS user session, the same printer disappears for all other users using that printer. So each time I try to fix a printer in one user session, I can expect a myriad of issues with the other users.

    4. The only way I found to fix this issue (so far) is by rebooting both servers at the end of the day and after power recycling the printer exhibiting the issue. The only other thing I could try (never tried it yet) would be to delete the affected user profile and recreate it on the RDS server. But I do not know yet the consequences of that action (will everyone else lose the defective printer mapping as well???).

    5. This issue doesn't seem to be driver or brand related as I had the issue with many printers of different brand. Both servers are virtual under Hyper-v (physical hosts are also Windows 2012 R2) and are running the latest integration version.

    If anyone has experienced this issue, please let me know what you have to have done to resolve it. My next step is escalating this to Microsoft.

    Thanks.

    Benji.

    Benjilafouine

    Thursday, July 24, 2014 6:53 PM

Answers

All replies

  • Hi Benji,

    What’s your printer model? Please see that you have updated driver installed.

    Whether it happened with any particular user account? I suggest you to check by creating new user account and check if you can set default printer for user.
    How do you set default printer for your user, by login script?

    You can check the registry setting whether default profile on printer is not corrupted. You can check on following reg keys.
    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    To resolve this issue:
    1. Log the user off the terminal server.
    2. Copy the %SYSTEMDRIVE%\Documents and Settings\Default User folder from a working Windows Server computer running the same Service Pack to %SYSTEMDRIVE%\Documents and Settings\Default User on the terminal server, overwriting all files.
    3. Delete the problem user profile on the terminal server.

    After this try to allow the user to logon.

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    Sunday, July 27, 2014 11:35 AM
    Moderator
  • Printers affected are all brands of printers.

    If I delete the printer from one user session, the printer is also deleted for all other users using this printer in their session. To fix the issue, if a printer is deleted, they have to reconnect to the printer (by using \\servername and double clicking on the printer).

    Also, if a VPN tunnel gets disconnected, this is where the other starts: the default printer gets unselected for one user (never the same it seems) and I can't select it back again. If I try to delete the printer, it gets deleted for everyone and when I try to reconnect it (\\servername), then it appears in double and I am still unable to set the printer to default.

    Finally, after I deleted the printer from a malfunctioning session, reconnected everyone else and still having this problem with one user, a simple server reboot will fix the issue. This is why I have never attempted to delete a user profile yet and recreate it (and especially that the problem seems to be happening at random independently of the user session).

    Benji.


    Benjilafouine

    Wednesday, July 30, 2014 4:37 PM
  • This issue is still there and someone else on Expert Exchange confirmed the same issue. Are we the only two IT persons operating a RDS environment on Windows 2012? P.S.: this is not a printer redirection issue but a print server issue (print server and RDS server both on Windows 2012 R2).

    Benjilafouine

    Monday, September 15, 2014 12:56 AM
  • Hi,

    Please install the hotfix below on your RDSH servers and see if it resolves some of the issues you are seeing:

    A network printer is deleted unexpectedly in Windows

    http://support.microsoft.com/kb/2967077

    Thanks.

    -TP

    Monday, September 15, 2014 1:43 AM
    Moderator
  • Wow! Definitely part of my problem. Definitely worth to try it. Hope it will fix the rest as well (unable to set default printer, etc.).

    Benjilafouine

    Monday, September 15, 2014 1:50 AM
  • Wow! Definitely part of my problem. Definitely worth to try it. Hope it will fix the rest as well (unable to set default printer, etc.).

    Benjilafouine

    Hey Benji,

    your error solved?! We have the same error, with the Default Printer (green tik was not showed) and printing was not possible (bsp. Acrobat Reader PDF).

    When the user disconnect and reconnect to the session, sometimes its possible to print and the green "tik" was back on the Default Printer. Thats an hardcore error, and the death for productiv working on this System.



    • Edited by pay2k3 Wednesday, October 29, 2014 7:48 PM
    Wednesday, October 29, 2014 7:32 PM
  • So far so good. I haven't had a complain since I installed the update last month. And one of my sites was down for three hours this morning and printing resumed correctly when the Internet came back (usually after such long time, printing would have crashed).

    I cannot say if it is fixed forever but this update had no negative effect on our environment. I guess you could try it without risks.


    Benjilafouine

    Wednesday, October 29, 2014 7:59 PM
  • Problem not completely fixed. Seems like within the older sessions that had the bug, it is still partly present.

    Benjilafouine

    Tuesday, November 4, 2014 7:54 PM
  • Same problem here. Some times the default printers "tick" disappear. Removing and re-adding helps, but only for some days...
    Thursday, November 6, 2014 10:18 AM
  • I have the same issue.  Hotfix as mentioned above was part of a rollup already applied.  Issue will not go away. 8 user system with 3 printers manually have to reinstall printers during the day.  Client mentions how great windows 2003 was in comparison.  Now written off 22 hours ($2500 in billing) on the issue.  Would recommend everyone stay clear of RDS on Windows 2012 R2.  All of 11/11/14 updates applied

    Best work around for me (other than use Windows 2003): 

    Generic or universal drivers used

    Easy print disabled

    Lots of 513 errors in logs yet I can browse to print spooler.  Firewall off. Sharing and network discovery on.

    Not AV related as there is not AV software as we removed it. Fiji, Brother, HP printers all effected.

    The solution of rebuild server as mentioned by MS in another thread is unacceptable.

    Wednesday, November 12, 2014 11:03 PM
  • Very sad reading... I have same issue here.

    14 users RDSH 3 different printer brands, all new installation, new print server, dc and rds server

    Printers showing twice and printjobs dissapears, often I can solve by deleting the printer for the user calling

    Server is all updated before launch late december 2014.

    please any help!! users are killing me

    Lars

    Tuesday, January 6, 2015 2:51 AM
  • We currently have 3 2012R2 RDSH servers running a pilot system all patched and up to date.

    Some users can't select a default printer, some have printers appearing twice, only way to fix is to reboot the servers or delete user profiles, neither of which are viable workarounds long term.

    Same printers on 2008R2 RDSH production system work absolutely fine (and have done for the past 3 years).

    Need some help with this ASAP to get the system out of pilot - Microsoft, are you looking into this??

    Thanks


    Wednesday, January 28, 2015 9:14 AM
  • We also have been experiencing a similar problem. One thing worth trying is to check these two keys in the registry 

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers

    and see if your backend server is showing up multiple times with different names, for example: printsrv, PRINTsrv, printsrv.company.local, 192.168.1.1... you get the idea

    Keep only one server entry and delete the rest then restart the spooler. Then try to be consistent when adding new printers, always using the very same server name. Also be careful of capital letters.

    You will probably also need to remove and remap all the printers defined with the "wrong" server names for each user. If not I presume the deleted server names would eventually reappear.

    As always, proceed with caution deleting stuff in the registry in production environments...

    Hope this helps

    Luca

    • Proposed as answer by Gael Raynaud Tuesday, May 29, 2018 7:50 PM
    Wednesday, February 11, 2015 10:37 PM
  • Hi Luca,

    thanks for the suggestion, it's taken me a while to get round to testing it again properly but unfortunately has not worked for us (we didn't have multiple variations of the same server name in the reg keys you mentioned).


    Wednesday, March 18, 2015 10:21 AM
  • Same problem here. 300 users on 20 RDS servers. The hotfix did not solve this problem.

    Anyone suggestions?

    Thursday, May 28, 2015 7:00 AM
  • EDIT - Disabling the firewall did not fix it. Still the same problem.

    Thursday, May 28, 2015 7:10 AM
  • Hello, Is this problem solved already ? Dit you escalated to Microsoft ? We are having the exact same problem at one of our custommers . Please let me know. Kind regards Jeffrey
    Thursday, June 18, 2015 9:19 PM
  • We are still experiencing this problem, I've reinstalled all RDS servers and the problem went away for about a month, this week it came back with a vengeance, so I'm back to square one on this one.

    The weird part is that this is just happening to this particular customer. Also, installing the hotfix did not fix this.


    Friday, July 10, 2015 6:49 AM
  • We are still having same problems with setting the default printer in a RDS Session 2012. All MS Updates do not fix this issue.

    Meanwhile any other solutions?

    Tuesday, July 14, 2015 4:12 PM
  • I have exactly the same problem.
    2 x Server 2012 R2 RDS servers
    1 x server 2012 R2 PS
    All printers are deployed to users through GPO
    Client Printer redirection is disabled
    Users report that they cannot print and when you check the is no green tick showing for their default printer.  I have tried deleting printers out of the profile, deleting profiles themselves. Running gpupdate /force brings the printers back and will also show the "deleted printer".  I have just read an article which says to untick "render print jobs on client computers" on all printers on your print server.  Then to stop the print spooler on your rds server and rename Client Side Rendering print provider key in the registry to .old and then create this key again.
    Has anyone done this? Does it solve the problem?
    Presume that Microsoft have not come up with a solution yet.  My customer has only been live on these RDS servers since 11/07/15 and printing has been an absolute nightmare.


    Tuesday, July 28, 2015 9:09 PM
  • I find a way to "real" delete a user printer in Windows 2012 R2.

    From Internet Explorer print menu you'll see all your installed printer and from there if you going to delete one it will going to be really removed  !! Crazy.

    After that check on power shell with the Get-Printer command and the printer is gone ! Now you can add a new one .

    Hope this can help someone in a troubleshooting..

    Luca

    Thursday, July 30, 2015 8:32 AM
  • I have exactly the same problem on multiple RDS Servers.

    The issue is not resolved by the hotfix.

    All Microsoft updates are installed on RDS and PS server.

    As work around i installed all printers on RDS server.

    Are there any updates from Microsoft?

    Monday, August 10, 2015 7:51 AM
  • Hi there all 

    Are there any update regarding this issue?

    I have exactly the same problem and none of the above "solutions" work form me as well.

     

    Tuesday, October 13, 2015 1:23 PM
  • Exactly the same problem here.

    Did anyone find a solution or workarround  for this issue?

    Did anyone open a ticket at Microsoft?

    Tuesday, October 27, 2015 7:24 PM
  • Hi, We have the exact same issue on multiple 2012 R2 RDS servers. We cannot narrow down why it happens although it's chiefly in Adobe Reader. Adding the printers locally seems to reduce issues but obviously this is against best practice because then we cannot secure which users have which printers. Please, please, please can Microsoft come up with a fix? We have already tried the hotfix to no avail. Lewis
    Wednesday, November 4, 2015 7:30 AM
  • We also have this problem at two different companys.

    We have one 2012R2 printserver, three 2012R2 terminal servers.
    The printers are installed on the printserver.  Printdrivers on printserver and terminal servers are identical.

    No matter how I publish the printers to the users (GPO, batch file loginscript, or simply letting the users choose in Devices and printers -> find in active directory)  the problem is exactly the same, makes no difference.

    Every day the printer switches back to XPS Writer or Send to OneNote.
    Sometimes when you look at the printer list, there is no green checkmark (your default printer). This issue causes Adobe Reader to stop printing. Once you get the green checkmark visible again somehow, Adobe can print again.    The other issue: some users suddenly have the same printer like 6 times, meaning that Printer07 show up 6 times with exactly the same name witch should not be possible..

    We have tried all sort of drivers, other than that we have tried everything..  We have no idea how to fix this..

    Monday, November 23, 2015 3:44 PM
  • Just found this, seems to be a fix or workaround. I haven't been able to test this yet

    http://puters.net/windows-server-2012-r2-2/printing-in-remote-desktop-2012-r2/

    Can anyone try this?


    Monday, November 23, 2015 4:08 PM
  • I'm going to try this out today, will keep you updated.

    Edit: 

    http://puters.net/windows-server-2012-r2-2/printing-in-remote-desktop-2012-r2/ 

    Did not help. 

    • Edited by Asbjorn H Thursday, December 3, 2015 2:53 PM
    Wednesday, November 25, 2015 12:42 PM
  • Can the hotfix mentioned in kb2967077 help with this issue as wel?
    Friday, December 4, 2015 9:22 AM
  • Imagine this scenario: You have 2 servers, 1 is a Domain Controller and File & Print Server (Server01), the other is a Remote Desktop Server for all users to log into (Server02). Both are using Windows Server 2012 Standard R2.

    You have deployed printers through Print Management from Server01 to the OU of Server02 with a Loopback Policy set to Merge or Replace.

    Your users log on and off of the server and pull through their printers each time. Users complain that:

    1. They cannot print
    2. They cannot set Default Printers (No Green Tick Appears)
    3. There are multiple instances of the same printer

    After spending days, and I mean days, on the phone to Microsoft we managed to make a breakthrough.

    The reason that this seems to fail is because:

    1. When users are logging off or even *disconnecting* (clicking the X in RDP) and logging back on regularly, it is constantly pulling through and removing the printers, making printer corruption likely.
    2. Also, when "Client Side Rendering" is enabled, it will render all print jobs on the Terminal Server which can increase the overhead of printing and likelihood of a print job failing - requiring spooler restarts and subsequently, corrupting the printer.

    To resolve this, I have found that the following steps have worked for me:

    (NOTE: You will need to organise around 1 hour's downtime)

    1. Log all users off of the Terminal Server and ensure they are informed not to log back in (or disable TS and use Console view)
    2. Stop the Printer Spooler on both Server01 and Server02
    3. Delete all items "C:\Windows\System32\spool\Printers" on Server01 and Server02
    4. On Server01, go through all printers and untick "Render print jobs on client computers" under the Sharing tab
    5. On Server02, open GPEDIT.msc and navigate to:
      1. Computer Configuration > Administrative Templates > Printers > "Always render print jobs on the server"
      2. Set this to "Enabled" - this will ensure all print jobs get sent to Server01 and reduce the overhead on Server02
    6. On Server02, open Regedit and rename the following key to _old
      1. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider
    7. Start the Print Spooler on Server01 and Server02
    8. Open Regedit on Server02 and a new key should have been created for "Client Side Rendering Print Provider"
    9. Add the following REG_DWORD Value to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider
      1. RemovePrintersAtLogoff
        1. VALUE: 0
      2. This will basically prevent the printers being removed each time the users log off/disconnect which will subsequently prevent the corruptions.
    10. Log on a user to test

    We have now carried out this fix on two Customers with the same set up - 2 x 2012 Servers, one DC and one RDP and so far, after three weeks, the problems have not returned.

    HUGE sigh of relief.

    • Proposed as answer by Frank C2 Friday, December 4, 2015 3:33 PM
    Friday, December 4, 2015 1:52 PM
  • Finaly ! this works for me!
    Tuesday, December 15, 2015 3:44 PM
  • Hi, I've just tried your solution. Seems to work so far. Will have to see if it holds out in the long run. I will keep you updated cause this problem has been going on for months. Fingers crossed.
    Wednesday, January 6, 2016 8:45 PM
  • Once Render Print Jobs On Client Computers has been disabled on a printer,   should we still see any entries within the Client Side Rendering Print Provider key?

    I disabled on both server and RDS, but the keys still populate within the RDS server registry, see below.

    Tuesday, January 12, 2016 10:18 AM
  • Have you turned off printer redirection?

    I have found that removing the connection bar from users RDP clients under the display tab forces the user to log off correctly meaning no disconnected sessions.

    Saturday, January 16, 2016 9:51 AM
  • Yes, this is normal apparently. The Microsoft engineer wasn't sure really...

    However, I found that if the printer's reg key does not appear under the user's SID, it will not allow you to set that printer as a default.

    Friday, January 22, 2016 11:44 AM
  • The reconnection issues happen at both disconnection and log off we have found but I'm glad this is working for you.
    Friday, January 22, 2016 11:45 AM
  • Hi Benji,

    What’s your printer model? Please see that you have updated driver installed.

    Whether it happened with any particular user account? I suggest you to check by creating new user account and check if you can set default printer for user.
    How do you set default printer for your user, by login script?

    You can check the registry setting whether default profile on printer is not corrupted. You can check on following reg keys.
    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

    To resolve this issue:
    1. Log the user off the terminal server.
    2. Copy the %SYSTEMDRIVE%\Documents and Settings\Default User folder from a working Windows Server computer running the same Service Pack to %SYSTEMDRIVE%\Documents and Settings\Default User on the terminal server, overwriting all files.
    3. Delete the problem user profile on the terminal server.

    After this try to allow the user to logon.

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    Look like you did not fully read the post, "Document and Settings" will be for server 2003/XP.

    He's talking about Server 2012!

    Friday, July 15, 2016 2:21 PM
  • Had an issue similar to this. We had to deploy a vbs script during logon/logoff to save the last printer selected as default. Seems to have fixed our issue.
    Wednesday, December 28, 2016 6:41 PM
  • I found this issue was 100% repeatable if I disconnected a session from a host and then rebooted the server. I couldn't find anything in the registry that was different between a properly logged off session and a disconnected.

    ANYWAY

    Thanks after months of investigation this has fixed my issue. 

    Monday, January 16, 2017 10:36 PM
  • Hey Frank, this issue has been haunting me for years...awfull.

    Im sure your solution is the one I need, im just a little uncertain why you would delete/rename the key on server01 ? (Print server) and also deleting the "C:\Windows\System32\spool\Printers" ? will I need to create all shared printers on server01 again ?

    Thanks you so much for sharing

    Wednesday, February 1, 2017 9:10 PM
  • It's a shame that this is still a thing in 2018, your fix worked flawlesly. Huge thank you to you !!
    Wednesday, February 21, 2018 3:37 PM
  • We are still experiencing this issue on newly installed Windows 2016 printserver + RDS servers. The issues have been here now for 5-6 years. Still I cannot find any official KB from Microsoft on how to handle.

    We've tried to create a case with MS about this issue in 2013 but we got nowhere with them.

    How can MS still act as if it does not exist?

    To prevent us from losing customers, we are still reverting to local printers. Which is not a nice solution obviously.

    Thursday, May 24, 2018 10:16 AM