locked
Client problem on SC 2012 new deployment RRS feed

  • Question

  • Just stood up an SC 2012 SP1 config manager environment and having issues with my first client, which is a 2008 R2 server.

    This CM environment has a very specific purpose so my site boundary is one single IP address, and it is the IP address of the 2008 R2 server.

    I manually installed the client and while the client installed ok, it's not completely "checked" in.  And it doesn't show up in the config mgr console.

    On the client under configuration manager --> general tab I have the following properties only:
    Assigned management point - correct 2012 box
    Client certificate - none
    Connection type - Always intranet
    Site code - Correct
    Unique ID
    Version

    I am missing a ton of properties there.  Under the Site tab the code is correct.  Under actions I have only Machine policy retrieval and user policy retrieval.  I am able to execute both but nothing happens.

    Here's a relevant portion of the smscliui.log:

    <![LOG[WARNING - Client is currently unassigned or an error occurred retrieving the assigned site. GetAssignedSite() returned : 0X0]LOG]!><time="11:45:59.340+240" date="07-03-2013" component="smscliui" context="" type="2" thread="2580" file="clicfgdlg.cpp:1412">
    <![LOG[Currently assigned FQDN: ]LOG]!><time="11:46:03.403+240" date="07-03-2013" component="smscliui" context="" type="1" thread="2580" file="clicfgdlg.cpp:4283">
    <![LOG[WARNING - Client is currently unassigned or an error occurred retrieving the assigned site. GetAssignedSite() returned : 0X0]LOG]!><time="11:46:35.510+240" date="07-03-2013" component="smscliui" context="" type="2" thread="1588" file="clicfgdlg.cpp:1412">
    <![LOG[wszMonikerName Elevation:Administrator!new:{9967A433-A640-4A56-8C3D-D8E8F95FF8F3}]LOG]!><time="11:46:36.931+240" date="07-03-2013" component="smscliui" context="" type="1" thread="1588" file="clicfgdlg.cpp:430">
    <![LOG[WARNING - Client is currently unassigned or an error occurred retrieving the assigned site. GetAssignedSite() returned : 0X80040002]LOG]!><time="11:46:38.212+240" date="07-03-2013" component="smscliui" context="" type="2" thread="1588" file="clicfgdlg.cpp:1885">

    ClientIDManagerStartup.log portion:

    <![LOG[[RegTask] - Sleeping for 1920 seconds ...]LOG]!><time="13:39:02.423+240" date="07-03-2013" component="ClientIDManagerStartup" context="" type="1" thread="512" file="regtask.cpp:1445">
    <![LOG[[RegTask] - Client is not registered. Sending registration request for GUID:FCA0A0C8-F32F-4286-A55A-3CAAFC5ED738 ...]LOG]!><time="14:11:02.468+240" date="07-03-2013" component="ClientIDManagerStartup" context="" type="1" thread="512" file="regtask.cpp:1634">
    <![LOG[RegTask: Failed to send registration request message. Error: 0x87d00231]LOG]!><time="14:11:02.515+240" date="07-03-2013" component="ClientIDManagerStartup" context="" type="3" thread="512" file="regtask.cpp:1322">
    <![LOG[RegTask: Failed to send registration request. Error: 0x87d00231]LOG]!><time="14:11:02.515+240" date="07-03-2013" component="ClientIDManagerStartup" context="" type="3" thread="512" file="regtask.cpp:1508">

    CCMMessaging.log:

    <![LOG[Successfully sent location services HTTP failure message.]LOG]!><time="14:11:02.515+240" date="07-03-2013" component="CcmMessaging" context="" type="1" thread="512" file="ccmhttperror.cpp:396">

    Any help would be most welcome.  I tend to lean toward an MP issue but I can't put my finger on it.

    Wednesday, July 3, 2013 6:13 PM

Answers

  • Looks like this resolution fixed it from what I can tell.

    http://scug.be/sccm/2013/05/14/cm12-sp1-management-point-will-not-install-on-server-2012/

    The system I built for SC 2012 was via OSD and automatically got the SCMM 2007 client installed.  Apparently despite doing a ccmsetup.exe /uninstall and ccmclean it didn't get rid of it.  

    Running powershell elevated:  Get-WMIObject -namespace “root” -query “SELECT * FROM __Namespace where name = ‘ccm’” | remove-wmiobject

     That got rid of whatever was remaining from the SCCM 2007 client.  

    If you are using this fix, be careful of the copy/paste as the single quotes around CCM will probably be wrong.  After you paste, remove them and retype them manually and you should be good to go.  

    My client after a reboot immediately checked in and the client settings were all fully populated.


    Wednesday, July 3, 2013 9:38 PM

All replies

  • Is the MP working at all (Monitoring node + mpcontrol.log)?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, July 3, 2013 6:31 PM
  • It appears I have no mpcontrol.log.  That can't be good.  I have removed and reinstalled the MP and it appeared successful.  Not sure what to do from here without the logs to help.
    Wednesday, July 3, 2013 6:58 PM
  • So it looks like the MP isn't actually installing, despite it reporting as being installed in Config Mgr console, so that's awesome.

    This is a stand alone primary site box.

    The MP won't install.  I verified BITS was installed.  I even removed the MP and uninstalled IIS and BITS and rebooted and re-installed IIS and BITS and rebooted again.  Tried to install the MP and receive the following entries in the mpsetup.log, same as before:

    <07/03/13 16:21:54> ~RoleSetup().
    <07/03/13 16:22:20> ====================================================================
    <07/03/13 16:22:20> SMSMP Setup Started....
    <07/03/13 16:22:20> Parameters: C:\Program Files\Microsoft Configuration Manager\bin\x64\rolesetup.exe /install /siteserver:SERVERNAME SMSMP 0
    <07/03/13 16:22:20> Installing Pre Reqs for SMSMP
    <07/03/13 16:22:20>         ======== Installing Pre Reqs for Role SMSMP ========
    <07/03/13 16:22:20> Found 2 Pre Reqs for Role SMSMP 
    <07/03/13 16:22:20> Pre Req MSXML60 found.
    <07/03/13 16:22:20> No versions of MSXML60 are installed.  Would install new MSXML60.
    <07/03/13 16:22:20> Enabling MSI logging.  msxml6_x64.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\msxml6_x64MSI.log
    <07/03/13 16:22:20> Installing C:\Program Files\Microsoft Configuration Manager\bin\x64\00000409\msxml6_x64.msi 
    <07/03/13 16:22:20> msxml6_x64.msi exited with return code: 0
    <07/03/13 16:22:20> msxml6_x64.msi Installation was successful.
    <07/03/13 16:22:20> Pre Req SqlNativeClient found.
    <07/03/13 16:22:20> SqlNativeClient already installed (Product Code: {D411E9C9-CE62-4DBF-9D92-4CB22B750ED5}). Would not install again.
    <07/03/13 16:22:20> Pre Req SqlNativeClient is already installed. Skipping it.
    <07/03/13 16:22:20>         ======== Completed Installation of Pre Reqs for Role SMSMP ========
    <07/03/13 16:22:20> Installing the SMSMP
    <07/03/13 16:22:20> Passed OS version check.
    <07/03/13 16:22:20> IIS Service is installed.
    <07/03/13 16:22:20> No versions of SMSMP are installed.  Installing new SMSMP.
    <07/03/13 16:22:20> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <07/03/13 16:22:20> Installing C:\Program Files\Microsoft Configuration Manager\bin\x64\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <07/03/13 16:22:34> mp.msi exited with return code: 1603
    <07/03/13 16:22:34> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <07/03/13 16:22:34> Fatal MSI Error - mp.msi could not be installed.

    I have no idea what else to do except maybe start over from scratch with this box, and I'd rather not do that.  

    Wednesday, July 3, 2013 8:35 PM

  • <07/03/13 16:22:20> Enabling MSI logging.  mp.msi will log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    <07/03/13 16:22:20> Installing C:\Program Files\Microsoft Configuration Manager\bin\x64\mp.msi CCMINSTALLDIR="C:\Program Files\SMS_CCM" CCMSERVERDATAROOT="C:\Program Files\Microsoft Configuration Manager" USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
    <07/03/13 16:22:34> mp.msi exited with return code: 1603
    <07/03/13 16:22:34> Backing up C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
    <07/03/13 16:22:34> Fatal MSI Error - mp.msi could not be installed.

    I have no idea what else to do except maybe start over from scratch with this box, and I'd rather not do that.  


    What about the logfile?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, July 3, 2013 8:57 PM
  • MPMSI.log:

    Property(S): InstallErrorDialog_Title = Setup Aborted
    Property(S): InstallErrorDialog_SubTitle = Setup failed
    Property(S): InstallErrorDialog_Info = Setup encountered an error and could not continue.
    Property(S): PolReqStagingDir.1114972D_590D_4AB6_BA2E_779928CEDCC2 = C:\Program Files\SMS_CCM\PolReqStaging\
    Property(S): SystemFolder.1114972D_590D_4AB6_BA2E_779928CEDCC2 = C:\WINDOWS\SysWOW64\
    Property(S): System64Folder.1114972D_590D_4AB6_BA2E_779928CEDCC2 = C:\WINDOWS\system32\
    Property(S): CcmDefaultPolicyAuthority = SMS:MP:Default:{6CED3AB0-05AF-4C81-8DBE-A62661C26F40}
    Property(S): MPVDirRoot.67022EC1_A401_46E9_91FC_2DF2ED04CF15 = C:\Program Files\SMS_CCM\SMS_MP\
    Property(S): Res1033.0EACD2EE_412B_4985_9727_96BC217AABD8 = C:\Program Files\SMS_CCM\1033\
    Property(S): Res1033.4CB41E5B_59DE_4D09_98C5_332377961F73 = C:\Program Files\SMS_CCM\1033\
    Property(S): MsiLogFileLocation = C:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
    Property(S): ProductState = -1
    Property(S): PackagecodeChanging = 1
    Property(S): USESMSPORTS = TRUE
    Property(S): SMSPORTS = 80
    Property(S): USESMSSSLPORTS = TRUE
    Property(S): SMSSSLPORTS = 443
    Property(S): USESMSSSL = TRUE
    Property(S): SMSSSLSTATE = 0
    Property(S): CCMENABLELOGGING = TRUE
    Property(S): CCMLOGLEVEL = 1
    Property(S): CCMLOGMAXSIZE = 1000000
    Property(S): CCMLOGMAXHISTORY = 1
    Property(S): CURRENTDIRECTORY = C:\Program Files\Microsoft Configuration Manager\bin\x64
    Property(S): CLIENTUILEVEL = 3
    Property(S): MSICLIENTUSESEXTERNALUI = 1
    Property(S): CLIENTPROCESSID = 2232
    Property(S): VersionDatabase = 200
    Property(S): MsiSystemRebootPending = 1
    Property(S): VersionMsi = 5.00
    Property(S): VersionNT = 602
    Property(S): WindowsBuild = 9200
    Property(S): ServicePackLevel = 0
    Property(S): ServicePackLevelMinor = 0
    Property(S): MsiNTProductType = 3
    Property(S): WindowsFolder = C:\WINDOWS\
    Property(S): WindowsVolume = C:\
    Property(S): System64Folder = C:\WINDOWS\system32\
    Property(S): SystemFolder = C:\WINDOWS\SysWOW64\
    Property(S): RemoteAdminTS = 1
    Property(S): TempFolder = C:\WINDOWS\TEMP\
    Property(S): ProgramFilesFolder = C:\Program Files (x86)\
    Property(S): CommonFilesFolder = C:\Program Files (x86)\Common Files\
    Property(S): ProgramFiles64Folder = C:\Program Files\
    Property(S): CommonFiles64Folder = C:\Program Files\Common Files\
    Property(S): AppDataFolder = C:\WINDOWS\system32\config\systemprofile\AppData\Roaming\
    Property(S): FavoritesFolder = C:\WINDOWS\system32\config\systemprofile\Favorites\
    Property(S): NetHoodFolder = C:\WINDOWS\system32\config\systemprofile\AppData\Roaming\Microsoft\Windows\Network Shortcuts\
    Property(S): PersonalFolder = C:\WINDOWS\system32\config\systemprofile\Documents\
    Property(S): PrintHoodFolder = C:\WINDOWS\system32\config\systemprofile\AppData\Roaming\Microsoft\Windows\Printer Shortcuts\
    Property(S): RecentFolder = C:\WINDOWS\system32\config\systemprofile\AppData\Roaming\Microsoft\Windows\Recent\
    Property(S): SendToFolder = C:\WINDOWS\system32\config\systemprofile\AppData\Roaming\Microsoft\Windows\SendTo\
    Property(S): TemplateFolder = C:\ProgramData\Microsoft\Windows\Templates\
    Property(S): CommonAppDataFolder = C:\ProgramData\
    Property(S): LocalAppDataFolder = C:\WINDOWS\system32\config\systemprofile\AppData\Local\
    Property(S): MyPicturesFolder = C:\WINDOWS\system32\config\systemprofile\Pictures\
    Property(S): AdminToolsFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\
    Property(S): StartupFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\
    Property(S): ProgramMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
    Property(S): StartMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\
    Property(S): DesktopFolder = C:\Users\Public\Desktop\
    Property(S): FontsFolder = C:\WINDOWS\Fonts\
    Property(S): GPTSupport = 1
    Property(S): OLEAdvtSupport = 1
    Property(S): ShellAdvtSupport = 1
    Property(S): MsiAMD64 = 6
    Property(S): Msix64 = 6
    Property(S): Intel = 6
    Property(S): PhysicalMemory = 8192
    Property(S): VirtualMemory = 6577
    Property(S): AdminUser = 1
    Property(S): MsiTrueAdminUser = 1
    Property(S): LogonUser = SYSTEM
    Property(S): UserSID = S-1-5-18
    Property(S): UserLanguageID = 1033
    Property(S): ComputerName = PACDCSC2012TST
    Property(S): SystemLanguageID = 1033
    Property(S): ScreenX = 1024
    Property(S): ScreenY = 768
    Property(S): CaptionHeight = 23
    Property(S): BorderTop = 1
    Property(S): BorderSide = 1
    Property(S): TextHeight = 16
    Property(S): TextInternalLeading = 3
    Property(S): ColorBits = 32
    Property(S): TTCSupport = 1
    Property(S): Time = 17:10:39
    Property(S): Date = 7/3/2013
    Property(S): MsiNetAssemblySupport = 4.0.30319.17929
    Property(S): MsiWin32AssemblySupport = 6.2.9200.16384
    Property(S): RedirectedDllSupport = 2
    Property(S): MsiRunningElevated = 1
    Property(S): Privileged = 1
    Property(S): DATABASE = C:\WINDOWS\Installer\136f8d.msi
    Property(S): OriginalDatabase = C:\Program Files\Microsoft Configuration Manager\bin\x64\mp.msi
    Property(S): UILevel = 2
    Property(S): ACTION = INSTALL
    Property(S): SMSCWSADSPATH = IIS://LocalHost/W3SVC/1
    Property(S): CCMSHAREMODE = 1
    Property(S): IISAnonymousUserAccount = IUSR
    Property(S): ROOTDRIVE = D:\
    Property(S): CostingComplete = 1
    Property(S): OutOfDiskSpace = 0
    Property(S): OutOfNoRbDiskSpace = 0
    Property(S): PrimaryVolumeSpaceAvailable = 91772904
    Property(S): PrimaryVolumeSpaceRequired = 53862
    Property(S): PrimaryVolumeSpaceRemaining = 91719042
    Property(S): INSTALLLEVEL = 1
    Property(S): CcmAdministratorsGroupName = Administrators
    Property(S): CcmUsersGroupName = Users
    Property(S): CcmCreatorOwnerAccountName = CREATOR OWNER
    Property(S): PrimaryVolumePath = C:
    Property(S): SOURCEDIR = C:\Program Files\Microsoft Configuration Manager\bin\x64\
    Property(S): SourcedirProduct = {6CED3AB0-05AF-4C81-8DBE-A62661C26F40}
    Property(S): LASTSTATESERIALNUM = 0
    Property(S): CCMHTTPSPORT = 443
    Property(S): CCMHTTPSSTATE = 0
    Property(S): CCMHTTPPORT = 80
    Property(S): ProductToBeRegistered = 1
    === Logging stopped: 7/3/2013  17:10:39 ===
    MSI (s) (98:E8) [17:10:39:263]: Note: 1: 1708 
    MSI (s) (98:E8) [17:10:39:263]: Product: ConfigMgr Management Point -- Installation operation failed.

    MSI (s) (98:E8) [17:10:39:264]: Windows Installer installed the product. Product Name: ConfigMgr Management Point. Product Version: 5.00.7804.1000. Product Language: 1033. Manufacturer: Microsoft Corporation. Installation success or error status: 1603.

    MSI (s) (98:E8) [17:10:39:270]: Deferring clean up of packages/files, if any exist
    MSI (s) (98:E8) [17:10:39:270]: MainEngineThread is returning 1603
    MSI (s) (98:E8) [17:10:39:279]: RESTART MANAGER: Session closed.
    MSI (s) (98:E8) [17:10:39:279]: No System Restore sequence number for this installation.
    MSI (s) (98:E8) [17:10:39:285]: User policy value 'DisableRollback' is 0
    MSI (s) (98:E8) [17:10:39:289]: Machine policy value 'DisableRollback' is 0
    MSI (s) (98:E8) [17:10:39:289]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (98:E8) [17:10:39:289]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
    MSI (s) (98:E8) [17:10:39:289]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
    MSI (s) (98:E8) [17:10:39:289]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (s) (98:E8) [17:10:39:290]: Destroying RemoteAPI object.
    MSI (s) (98:04) [17:10:39:290]: Custom Action Manager thread ending.
    MSI (c) (B8:A4) [17:10:39:292]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (B8:A4) [17:10:39:293]: MainEngineThread is returning 1603

    Here are some additional errors further up in the log:

    [17:10:34] Failed to compile 'C:\Program Files\SMS_CCM\CcmExec_Global.mof' (Phase: 3, Object: 5, Lines: 76 - 83, Error: 80041002)
    [17:10:34] Failed to compile 'C:\Program Files\SMS_CCM\PolicyDefaults.mof' (Phase: 3, Object: 4, Lines: 49 - 57, Error: 80041002)
    [17:10:34] Failed to compile 'C:\Program Files\SMS_CCM\StateMsgSchema.mof' (Phase: 3, Object: 6, Lines: 89 - 94, Error: 80041002)
    [17:10:34] Failed to compile 'C:\Program Files\SMS_CCM\DataTransferService.mof' (Phase: 3, Object: 5, Lines: 318 - 323, Error: 80041002)

    [17:10:35] Failed to compile 'C:\Program Files\SMS_CCM\CcmExec_MP.mof' (Phase: 3, Object: 1, Lines: 31 - 36, Error: 80041002)

    Error 25140. Setup was unable to compile the file CcmExec_Global.mof
    The error code is 80041002
    MSI (s) (98!D4) [17:10:36:173]: Product: ConfigMgr Management Point -- Error 25140. Setup was unable to compile the file CcmExec_Global.mof
    The error code is 80041002

    CustomAction CcmRegisterWmiMofFile returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

    I did a ccmclean to remove all remnants of SCCM client.  I have UAC disabled.  End of my rope here.

    Wednesday, July 3, 2013 9:15 PM
  • Property listings are just ... listings of (msi) properties - so pretty much useless.
    This part of the log does not contain the actual error. Search for 'return value 3' in the log. The error should be listed a few lines above the ocurrance.

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, July 3, 2013 9:32 PM
  • Looks like this resolution fixed it from what I can tell.

    http://scug.be/sccm/2013/05/14/cm12-sp1-management-point-will-not-install-on-server-2012/

    The system I built for SC 2012 was via OSD and automatically got the SCMM 2007 client installed.  Apparently despite doing a ccmsetup.exe /uninstall and ccmclean it didn't get rid of it.  

    Running powershell elevated:  Get-WMIObject -namespace “root” -query “SELECT * FROM __Namespace where name = ‘ccm’” | remove-wmiobject

     That got rid of whatever was remaining from the SCCM 2007 client.  

    If you are using this fix, be careful of the copy/paste as the single quotes around CCM will probably be wrong.  After you paste, remove them and retype them manually and you should be good to go.  

    My client after a reboot immediately checked in and the client settings were all fully populated.


    Wednesday, July 3, 2013 9:38 PM