none
Exchange 2016 CU10 bug/and/or related to latest round of september patches (GAL errors out on outlook 2010/2016)

    Question

  • I first wrote to reddit.

    https://www.reddit.com/r/exchangeserver/comments/9idpuj/outlook_address_book_the_operation_failed/



    details:

    Between Sept 21-23 I've installed couple of patches

    on windows 10 clients 

    KB4100347: Intel microcode updates

    September 17, 2018—KB4464218 (OS Build 17134.286)



    on exchange server 2016 cu 10.
    2018-09 Cumulative Update for Windows Server 2016 for x64-based Systems (KB4457127)

    2018-09 Update for Windows Server 2016 for x64-based Systems (KB4091664)

    I also happen to have installed exchange server 2016 CU 10 from CU7 on 8/9/2018

    ---

    so users on outlook 2016 complain when they open the address book, they get "the operation failed" pop up.
    event viewer shows no related events.

    I tested myself on outlook 2010 as well with same results.

    we don't use cache mode, so i eventually excluded OAB generation issues. besides, i can see all my recipient lists on OWA

    after realising that some address lists work and some don't . i found out that if an address lists contains more than 18 recipients, it fails to load in outlook. the GAL thus will always fail to load

    as a work around i broke down my larger address lists into multiple lists with less than 18 recipient each 


    Monday, September 24, 2018 8:13 AM

Answers

  • Hello,

    The problem is the update KB4457127.
    With Exchange 2010, there is the same problem.

    You have to uninstall the update on the domain controller again.

    See link:

    https://social.technet.microsoft.com/Forums/en-US/27d386de-5c48-4398-83ee-24677c88b62a/error-quotthe-operation-failedquot-when-accessing-address-list-from-exchange-server?forum=exchange2010

    • Marked as answer by chrisloup Tuesday, September 25, 2018 3:39 AM
    Monday, September 24, 2018 2:02 PM

All replies

  • Hello,

    The problem is the update KB4457127.
    With Exchange 2010, there is the same problem.

    You have to uninstall the update on the domain controller again.

    See link:

    https://social.technet.microsoft.com/Forums/en-US/27d386de-5c48-4398-83ee-24677c88b62a/error-quotthe-operation-failedquot-when-accessing-address-list-from-exchange-server?forum=exchange2010

    • Marked as answer by chrisloup Tuesday, September 25, 2018 3:39 AM
    Monday, September 24, 2018 2:02 PM
  • ok done.

    i have 2 dc, i've uninstalled from one and rebooted, I  have not rebooted the 2nd dc

    KB4457127 remains installed on exchange server.

    problem is "fixed" at the moment.

    • Proposed as answer by Marcel Laven Thursday, September 27, 2018 7:56 PM
    Tuesday, September 25, 2018 3:40 AM
  • I can confirm that uninstalling KB4457127 on your domaincontrollers is the solution for the GAL issue.

    (Windows 2016 Domain controllers and Exchange 2016 CU10 on W2016)

    Thursday, September 27, 2018 7:58 PM
  • Hi,

    I have installed the new update KB4462917 and the error in the Outlook does not appear anymore.

    Link: https://support.microsoft.com/en-us/help/4462917

    greetings
    Michael

    Wednesday, October 10, 2018 2:26 PM
  • Hi,

    it seems that introducing the first Windows 2019 Domain Controller brings back this problem. Anyone aware of this issue with 2019 and hopefully a solution?

    Regards

    Norbert

    Saturday, November 24, 2018 12:09 AM
  • Same here, first DC2019 and the GAL is not working anymore. Funny ting, it's not only happening to users which has the DC2019 as logonserver, it happens also to users with a DC2012R2 as logonserver.

    Any news about a DC2019 fix?

    Monday, November 26, 2018 12:27 PM