locked
BCDedit RRS feed

  • Question

  • i had a sever installed on a test laptop that also had vista Ulitmate SP1 installed. i formatted the drive that the server was installed on but it still asks me to pick what o/s i want. i want to know step my step instructions on how to delete this in the BCDedit.exe please can someone help.
    Sunday, February 15, 2009 6:56 PM

Answers

  •  

    Hi,

     

    To prevent the operating system selection menu from appearing when you start the computer, you can use the Boot Configuration Data Editor (Bcdedit.exe) to remove the Windows Server startup option. To do this, follow these steps:

     

    1.    Click Start, type cmd in the Start Search box, and then click Command Prompt in the application list.

    2.    At the command prompt, type the following command, and then press ENTER:

     

    bcdedit /enum all

     

    Note: This command displays the GUIDs of the installed operating systems. Note the GUID for the Windows Server operating system.

     

    3.    At the command prompt, type the following command, and then press ENTER:

     

    bcdedit /delete ID

     

    For example, the bcdedit /delete {802d5e32-0784-11da-bd33-000476eba25f} command deletes the entry with ID {802d5e32-0784-11da-bd33-000476eba25f}.

     

    Note: The ID placeholder specifies the GUID of the startup option for the operating system that you want to delete. If you do not specify the ID, the startup option for the current operating system will be deleted.

    If you specify a well-known GUID, you must force the deletion by using the /f switch.

     

    If the server you mentioned is Windows Server 2003, you can also use the following command to remove its startup option

     

    bcdedit /delete {default} /f

     

    4.    Close the Command Prompt window.

     

    The simplest way to remove the Windows Server startup option is to use a tool named VistaBootPro:

     

    http://www.softpedia.com/get/System/OS-Enhancements/VistaBootPRO.shtml

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Monday, February 16, 2009 3:15 AM
    Moderator

All replies

  •  

    Hi,

     

    To prevent the operating system selection menu from appearing when you start the computer, you can use the Boot Configuration Data Editor (Bcdedit.exe) to remove the Windows Server startup option. To do this, follow these steps:

     

    1.    Click Start, type cmd in the Start Search box, and then click Command Prompt in the application list.

    2.    At the command prompt, type the following command, and then press ENTER:

     

    bcdedit /enum all

     

    Note: This command displays the GUIDs of the installed operating systems. Note the GUID for the Windows Server operating system.

     

    3.    At the command prompt, type the following command, and then press ENTER:

     

    bcdedit /delete ID

     

    For example, the bcdedit /delete {802d5e32-0784-11da-bd33-000476eba25f} command deletes the entry with ID {802d5e32-0784-11da-bd33-000476eba25f}.

     

    Note: The ID placeholder specifies the GUID of the startup option for the operating system that you want to delete. If you do not specify the ID, the startup option for the current operating system will be deleted.

    If you specify a well-known GUID, you must force the deletion by using the /f switch.

     

    If the server you mentioned is Windows Server 2003, you can also use the following command to remove its startup option

     

    bcdedit /delete {default} /f

     

    4.    Close the Command Prompt window.

     

    The simplest way to remove the Windows Server startup option is to use a tool named VistaBootPro:

     

    http://www.softpedia.com/get/System/OS-Enhancements/VistaBootPRO.shtml

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Monday, February 16, 2009 3:15 AM
    Moderator
  • thanks Tim for you help. did that in less than one minute from your CMD instructions.

    you have saved me alot of hasle that that wsa causnig me.
    Friday, February 20, 2009 2:26 PM