locked
Hardware Inventory Error Sheet 9 (Vista assessment) RRS feed

  • Question

  • Greetings,

    Our inventory runs on 15k machines and everything works smoothly without errors, then when reading the report it shows an error on the Hardware inventory. I've tried re-running the inventory with the same error. When I ran a smaller inventory(5k machines) the report checks out perfectly.

    For report 'HardwareInventory':

    Excel engine failed while Getting report data.
    Error:
    String or binary data would be truncated.
    The statement has been terminated.


    Any clues?

    If anything is hazy, please get back to me. Any help would be greatly appreciated.
    Friday, September 5, 2008 1:11 PM

All replies

  • This means that the MAPS tool collected some data from a machine that is different from what the tool expected in some way.  There's probably one machine in your set that's returning an unusual value for one of the WMI calls.  When the tool gets resady to create the reports and queries that data for the report, an error is occuring because the data is too big to fit in the space allotted for it.


    We can track this down and fix it.   The easiest way to do this is if you can share your database with us and let us look at the data & fix the issue.

    If you're not comfortable doing that, then let me know exactly which report (which Excel workbook) and which tab in that workbook is giving you the error and we might be able to make a guess about which column of data is causing the problem.

    I'll be glad to follow up with you privately if you like.

    Thanks,
    Jay
    Friday, September 5, 2008 7:24 PM
  • That would be very helpful. Could you please contact me at demian [dot] amundsen [at] edb [dot] com

    Thanks
    Monday, September 8, 2008 1:32 PM
  • Jay,

    Could you please get back to me?

    Thanks,
    Demian
    Friday, September 12, 2008 8:05 AM
  • Sorry for the delay in replying.   We've now had several people report this issue and we've been able to reproduce the issue here.

    Unfortunately, the problem seems to be in SQL Server itself.  We've engaged the SQL Server team to try to figure out a workaround.

    Right now, I don't have a way around the issue.   I'll post more information here as I get it.

    Thanks,
    Jay
    • Proposed as answer by Jay Sauls Wednesday, November 12, 2008 5:22 PM
    Tuesday, September 23, 2008 5:59 PM
  • This issue was fixed in MAPS 3.2 that was released last week.
    • Proposed as answer by Jay Sauls Wednesday, November 12, 2008 5:22 PM
    Wednesday, November 12, 2008 5:22 PM