none
Project Server published via UAG throwing errors RRS feed

  • Question

  • Hi, After successfully publishing the site via UAG I notice that we are getting script errors when trying to load some parts of the project for ex- the Project itself. The links and pages load up just fine however when I click the project link I get a security error that the page is trying to access information that is not secure. This poses a security risk. Do you want to continue?. If I say yes, then the page tries to load up for an indefinite amount of time ( I also see script errors in the status bar related to webmethod.js) , if I click no, them we get the message cannot communicate with the server.

    Please suggest how can we approach this issue.

    Thanks


    RRS

    Thursday, May 24, 2012 5:52 PM

Answers

  • We had lots of problems publishing PWA using the TMG "Publish Webserver" or "Publish SharePoint Server" options.  In the end we created a simple server publishing rule, and used HTTPS as the protocol - in other words basically directly port forwarding as opposed to reverse proxy.

    This seems to have helped with our problems.


    http://blogs.umtsa.co.za/nicoo

    • Marked as answer by srituraj Monday, June 11, 2012 5:24 PM
    Tuesday, June 5, 2012 1:11 PM

All replies

  • Hi there,

    Have you seen the TechNet documentation for SharePoint 2010 and UAG?

    http://technet.microsoft.com/en-us/library/dd857299

    Might be worth a read to make sure all is set correctly.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com

    Thursday, May 24, 2012 7:02 PM
    Moderator
  • Hi Paul,

    I reconfigured the AAM and rebind the certificates in IIS, and after that it seems to work in the sense that I can access the site and navigate to all sections through the UAG. However when trying to edit a project from the browser into the client while accessing via UAG, the client crashes with the following log :

    Problem signature:

      Problem Event Name: APPCRASH
      Application Name: WINPROJ.EXE
      Application Version: 14.0.6114.5000
      Application Timestamp: 4ec6ea19
      Fault Module Name: WINPROJ.EXE
      Fault Module Version: 14.0.6114.5000
      Fault Module Timestamp: 4ec6ea19
      Exception Code: c0000005
      Exception Offset: 00033c45
      OS Version: 6.1.7601.2.1.0.256.4
      Locale ID: 1033

    Additional information about the problem:
      LCID: 1033
      skulcid: 1033

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt

    Also notre when I am connected via VPN I can easily edit the project in the client. 

    Any suggestions?


    RRS

    Friday, June 1, 2012 5:48 PM
  • We had lots of problems publishing PWA using the TMG "Publish Webserver" or "Publish SharePoint Server" options.  In the end we created a simple server publishing rule, and used HTTPS as the protocol - in other words basically directly port forwarding as opposed to reverse proxy.

    This seems to have helped with our problems.


    http://blogs.umtsa.co.za/nicoo

    • Marked as answer by srituraj Monday, June 11, 2012 5:24 PM
    Tuesday, June 5, 2012 1:11 PM