locked
Adding adding the DOS cmd as a folder option RRS feed

  • Question

  • At  one time I was shown how to add the DOS cmd to the folders option - specifically when in winfile/filemgr/windows explorer if I selected a folder/directory I could right click on it and a dos cmd window would open up at that folder/directory which comes in handy when you have to run dos commands.  How can this be done in Windows 7?

    Friday, February 19, 2010 8:21 PM

Answers

  • if you open file explorer and you click right mouse and you hold Shift you see command Open CMD here.

    If you don´t want everytime use shift you can add this entries to registry


    Windows Registry Editor Version 5.00
    ;Show 'open command window here' on right-click without having to press shift
    ;Context-menu for folders
    [HKEY_CLASSES_ROOT\Directory\shell\cmd]
    "Extended"=-
    ;Context-menu for drives
    [HKEY_CLASSES_ROOT\Drive\shell\cmd]
    "Extended"=-
    ;For context-menu when you right-click in the empty/blank space within a folder
    [HKEY_CLASSES_ROOT\Directory\Background\shell\cmd]
    "Extended"=-

    save this as shell.reg and run it

    (you can of course rename this file:)
    Friday, February 19, 2010 10:19 PM
  • Send To Toys by Gabriele Ponti:  http://www.gabrieleponti.com/software/index.html

    Send To -> Command Prompt is part of the set, and though the software has been around for a while it works perfectly on Windows 7.

    I don't know what I'd do without Send To -> Clipboard (as name) myself, and it brings a nice control panel applet for configuring Send To for other things.

    This software is an absolute jewel.

    -Noel
    Saturday, February 20, 2010 2:51 AM

All replies

  • if you open file explorer and you click right mouse and you hold Shift you see command Open CMD here.

    If you don´t want everytime use shift you can add this entries to registry


    Windows Registry Editor Version 5.00
    ;Show 'open command window here' on right-click without having to press shift
    ;Context-menu for folders
    [HKEY_CLASSES_ROOT\Directory\shell\cmd]
    "Extended"=-
    ;Context-menu for drives
    [HKEY_CLASSES_ROOT\Drive\shell\cmd]
    "Extended"=-
    ;For context-menu when you right-click in the empty/blank space within a folder
    [HKEY_CLASSES_ROOT\Directory\Background\shell\cmd]
    "Extended"=-

    save this as shell.reg and run it

    (you can of course rename this file:)
    Friday, February 19, 2010 10:19 PM
  • Send To Toys by Gabriele Ponti:  http://www.gabrieleponti.com/software/index.html

    Send To -> Command Prompt is part of the set, and though the software has been around for a while it works perfectly on Windows 7.

    I don't know what I'd do without Send To -> Clipboard (as name) myself, and it brings a nice control panel applet for configuring Send To for other things.

    This software is an absolute jewel.

    -Noel
    Saturday, February 20, 2010 2:51 AM
  • Thanks
    Saturday, February 20, 2010 11:58 AM
  • I have Windows Registry Editor Version 6.01 and the values in the registry are different:

    Show 'open command window here' on right-click without having to press shift
    ;Context-menu for folders
    [HKEY_CLASSES_ROOT\Directory\shell\cmd]
    "Extended"=-

    But [HKEY_CLASSES_ROOT\Directory\shell\cmd] doesn't have an "Extended" String - just has the default set to cmd.exe /s /k pushd "%V"

    The [HKEY_CLASSES_ROOT\Directory\Background\shell\cmd] has the "Extended" String, but deleting this string did not produce the desired effect of having the "Open Command Window Here" appear in the context menu without holding down the shift key.

    Can anyone help on this?

    Thanks


    Matt

    Tuesday, May 1, 2012 3:39 PM
  • A quick follow up - I get the "Open Command Window Here" when I click on the black space in an Explorer Window so the [HKEY_CLASSES_ROOT\Directory\Background\shell\cmd] change apparently worked.

    I just can't get it to work when I right click a folder.


    Matt

    Tuesday, May 1, 2012 3:41 PM
  • Got it working now.  Problem was that I was in the 'command' sub-key of the cmd key.  

    Matt

    Tuesday, May 1, 2012 3:48 PM