locked
GPO drops startup scripts RRS feed

  • Question

  • Hello Technet

    I encounter a weird problem now and then. We have different scripts (.cmd, .bat) running as startup script, but sometimes the gpo 'drops' those scripts. They are simply gone, when you look in the startup scripts 'management' window. And obviously, the system (workstations) complains when attempting a gpupdate.

    I have no clue what courses the problem, but adding the scripts again solves the problem..

    Best Regards,

    Jesper Vindum, Denmark.

    Thursday, September 6, 2012 11:05 AM

Answers

  • Hi,

    I agree with Mr P. I suggest you we follow the below steps to configure startup script:

    1. Expand Computer Configuration, Windows Settings, Script(Startup/Shutdown)

    2. Click Startup in the right pane, them click Show Files to list all stored script in the GPO.

    3. Click Add, and then click Browe to find out a startup script. Please note, the default path for you to choose the script is:

    \\domain\SYSVOL\domain\Policies\Policy GUID\Machine\Scripts\startup

    Remember, it is the place where our startup script shoud be put.

    Hope this helps.

    Regards,

    Yan Li

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.



    Yan Li

    TechNet Community Support


    • Edited by Yan Li_ Friday, September 7, 2012 7:10 AM
    • Proposed as answer by Yan Li_ Monday, September 10, 2012 7:58 AM
    • Marked as answer by Yan Li_ Friday, September 14, 2012 3:04 AM
    Friday, September 7, 2012 7:10 AM

All replies

  • Hi Jesper

    When you say the scripts are gone do you mean the policy no longer points to them or the scripts have been deleted from the share you keep them on.

    Cheers

    Mr P

    Thursday, September 6, 2012 12:37 PM
  • Hi Jesper

    When you say the scripts are gone do you mean the policy no longer points to them or the scripts have been deleted from the share you keep them on.

    Cheers

    Mr P

    The policy stops pointing to them (removed in 'Startup Properties'). The scripts stays on the network share.

    //vindum

    Thursday, September 6, 2012 1:13 PM
  • Hi

    policy uses scripts.ini file to point to where startup scripts are stored.

    the ini file is stored

    \\server\SYSVOL\domain\Policies\Policy GUID\Machine\Scripts

    Check the ini file to make sure it's got the correct settings in it and the it's present on all your sysvol shares.

    Next time policy drops those settings go and check the scripts.ini file is still present.

    You may have some process that is intermittently deleting the ini file or it might not be there on one of your sysvol shares.

    Cheers

    Mr P

    • Proposed as answer by Yan Li_ Monday, September 10, 2012 7:58 AM
    • Unproposed as answer by Yan Li_ Monday, September 10, 2012 7:58 AM
    Thursday, September 6, 2012 1:29 PM
  • Hi,

    I agree with Mr P. I suggest you we follow the below steps to configure startup script:

    1. Expand Computer Configuration, Windows Settings, Script(Startup/Shutdown)

    2. Click Startup in the right pane, them click Show Files to list all stored script in the GPO.

    3. Click Add, and then click Browe to find out a startup script. Please note, the default path for you to choose the script is:

    \\domain\SYSVOL\domain\Policies\Policy GUID\Machine\Scripts\startup

    Remember, it is the place where our startup script shoud be put.

    Hope this helps.

    Regards,

    Yan Li

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.



    Yan Li

    TechNet Community Support


    • Edited by Yan Li_ Friday, September 7, 2012 7:10 AM
    • Proposed as answer by Yan Li_ Monday, September 10, 2012 7:58 AM
    • Marked as answer by Yan Li_ Friday, September 14, 2012 3:04 AM
    Friday, September 7, 2012 7:10 AM