none
Deployed Windows 7 Image Resetting Time -1HR RRS feed

  • Question

  • Hi All,

    Having a bit of an issue with MDT 2013 Update 1 at the moment.

    Ever since the clocks changed my Windows 7 images aren't deploying with the correct time which is causing me some trouble with joining the domain / gpupdates etc.

    The clock is -1HR at the point where it joins the domain. I've got the task sequence set to reboot after the tattoo which used to allow for the group policy settings to apply ready for the WSUS run (computer group targeting). When the machine reboots it does correct the time but I'm not sure that it does it quick enough before it tries to download the policies or check WSUS (next step).

    Is there any way that I am able to correct this without having to recreate my base image? In WinPE the time is correct (BIOS time). It reverts back as soon as it's deployed and I'm booted into Windows 7.

    Cheers

    Matt

    Monday, November 2, 2015 10:35 PM

All replies

  • WinPE doesn't know anything about Daylight Savings Time.  And when you first get into the OS it just used BIOS time.

    Try adding a step to sync the time:

    net time /RTSDOMAIN:yourdomainname /SET /Y


    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Monday, November 2, 2015 10:58 PM
    Moderator
  • Thanks for your reply.

    Yes - This is what I'd assumed but if I cancel the deployment and enter the command prompt and enter 'time', it shows the correct time. This time is altered through part of the deployment and by the time I reach the first boot it's incorrect as it's modified the BIOS clock - 1 HR.

    I'd ideally need to sync the time before it attempts to join the domain - Will this command work if the client is not a member of the domain?

    Monday, November 2, 2015 11:01 PM
  • Try it before your recover from domain step.  I haven't tried this but, it seems that the time is the root issue.  If this doesn't work maybe search and see if you can find another command line way sync.


    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.


    Monday, November 2, 2015 11:06 PM
    Moderator
  • Unfortunately it doesn't work - Access denied unless it's on the domain already :-(
    Tuesday, November 3, 2015 10:17 AM
  • Then add runas on the step with an account that is authorized to do it maybe?

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Tuesday, November 3, 2015 6:58 PM
    Moderator
  • You could also try:

    net time \\<MDTServer> /set /y


    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Tuesday, November 3, 2015 7:43 PM
    Moderator