none
Old servers visible in SCOM

    Question

  • Hi,

    In our infrastructure we have two Management servers, four SQL servers and two Gateway Servers running.

    We see something crazy within SCOM 2012 R2. At different times, old servers that we have previously retrieved from SCOM may suddenly appear in SCOM again. These old servers had already been phased out, or no longer provided with a SCOM agent.

    Does anyone know why this event occurs?


    • Edited by akashs001 Thursday, July 12, 2018 10:09 AM
    Thursday, July 12, 2018 10:06 AM

All replies

  • Hey,

    Did you make sure there's no agent on the server? If you've just "deleted" the agent from console instead of "uninstalling" they come back in the pending mgmt. If your pending management setting is set to "approve automatically" they'll come in windows server view.

    Cheers


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!) Blog:AnalyticOps Insights Twitter:Sameer Mhaisekar


    Thursday, July 12, 2018 10:26 AM
  • Hi,

    Thanks for your message. 

    I am sure that there are no agents left, because these servers have been removed / phased out. I know that if a server is still equipped with a SCOM agent, a deleted SCOM agent will return to SCOM.

    Old servers have long been phased out or no longer exist, yet they always appear within SCOM. Then I have to remove those returned servers within SCOM. Fortunately, this does not happen very often, but this is frustrating.

    Thursday, July 12, 2018 12:47 PM
  • Hi, that is strange indeed. Never seen/heard that yet.

    Could it be that the new servers are spinning up with old names with agent installed in them?

    Cheers


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!) Blog:AnalyticOps Insights Twitter:Sameer Mhaisekar

    Thursday, July 12, 2018 1:29 PM
  • Never hear of that neither.

    Do these "zombie" servers appear as healthy or greyed?

    Thursday, July 12, 2018 1:39 PM
  • Hi,

    I also think it's crazy. That's what I thought about, but I checked whether it was indeed new servers. No, in my AD and VMware environment I just do not see new servers with old names!

    The old servers come on spontaneously at times, at once a long overview with old servers with a critical status.


    Thursday, July 12, 2018 2:40 PM
  • Hi,

    No, I just saw a list of old servers with a critical status within SCOM. Had to close unnecessary alerts.

    Thursday, July 12, 2018 2:41 PM
  • Are these ghost servers in the BaseManagedEntity table in the OM DB?

    "Fear disturbs your concentration"

    Thursday, July 12, 2018 3:59 PM
  • >>At different times, old servers that we have previously retrieved from SCOM may suddenly appear in SCOM again. These old servers had already been phased out, or no longer provided with a SCOM agent.
    what is your procedure of phase out the old servers. does it just uninstall old servers in client machine without delete its corresponding entity on Management sever?
    OR There is a cache on your operations console. In this case, please restart operations console with /clearcache parameter
    Roger
    Friday, July 13, 2018 6:42 AM
  • Hi,

    Thank you for your comment!

    We follow a procedure within our organization to completely remove a server, for example the complete removal of a virtual or physical HDD disk, a server name from AD, an agent from SCOM etc.

    Okay, I'll try to perform your advice method and see if this can get a desired effect on this problem.

    Monday, July 16, 2018 7:30 AM