none
Compiling UE4 with nVidiaPhysx

    Question

  • Hey guys,

    I've been trying for days days to compile the Physx samples of Nvidia for UE4 , the ones on Github. I failed over and over , and I'm so close but I don't know what is wrong.

    I've never compiled the engine before, I never used github until I discovered Nvidida Gameworks..

    These were my steps:

    1. Download .zip/ Pull Engine source from gameworks repo on Github.

    2. Run Setup.bat

    3. Generate .proj files.bat

    4. open Visual Studio Community 2015

    5. setting up in "Dev Editor mode" and "Win64" , right click UE4 and Build.

    The error I get goes like this:

     Error LNK1181 cannot open input file 'GFSDK_SSAO_D3D11.win64.lib' ShaderCompileWorker C:\Users\Selim\Desktop\UnrealEngine\Engine\Intermediate\ProjectFiles\LINK 1

    Error Failed to produce item: C:\Users\Selim\Desktop\UnrealEngine\Engine\Binaries\Win64\ShaderCompileWorker-RHI.dll ShaderCompileWorker C:\Users\Selim\Desktop\UnrealEngine\Engine\Intermediate\ProjectFiles\ERROR 1

    Error MSB3075 The command "....\Build\BatchFiles\Build.bat ShaderCompileWorker Win64 Development -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command. ShaderCompileWorker C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets 41

    I tried to compile the Engine alot of times , I also saw the updates recently made, which i also tried to compile: - Flex for UE4.15 - Cataclysm demo for UE4.15 (updated 3 days ago) - List item

    I tried them all but I always get stuck at the visual studio part of the compilation. There always an error popping up. I'm very grateful for any help.

    Friday, April 21, 2017 12:08 PM

Answers