none
Dism problem mounting Windows 10 1607 image

    Question

  • I have the latest Assessment and Deployment Kit (Windows 10 - 1607) installed on my Windows 10 x64 1607 desktop.  Using DISM, I can mount and make changes to Windows 7 images and Windows 10 1511 images but I cannot mount a 1607 image so either there is something odd with the 1607 image or something with my computer or my ASDK install.    I've tried about everything I can think of.  I used DISM from another computer and try to mount the image but it failed using that DISM as well so maybe it is something with the image itself but I can't figure it out.  Hoping someone here who is a lot smarter than I am can give me some ideas.  Here is a log file from trying to mount our latest image:

    2017-03-21 07:55:41, Info                  DISM   PID=3612 TID=1432 Scratch directory set to 'C:\Users\jmrawl2\AppData\Local\Temp\'. - CDISMManager::put_ScratchDir
    2017-03-21 07:55:41, Info                  DISM   PID=3612 TID=1432 DismCore.dll version: 10.0.14393.0 - CDISMManager::FinalConstruct
    2017-03-21 07:55:41, Info                  DISM   Try to initialize Panther logging 1 times, last error: 0x0
    2017-03-21 07:55:41, Info                  DISM   PID=3612 TID=1432 Successfully loaded the ImageSession at "C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM" - CDISMManager::LoadLocalImageSession
    2017-03-21 07:55:41, Info                  DISM   Try to initialize Panther logging 1 times, last error: 0x0
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Found and Initialized the DISM Logger. - CDISMProviderStore::Internal_InitializeLogger
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Failed to get and initialize the PE Provider.  Continuing by assuming that it is not a WinPE image. - CDISMProviderStore::Final_OnConnect
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Finished initializing the Provider Map. - CDISMProviderStore::Final_OnConnect
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Getting Provider DISMLogger - CDISMProviderStore::GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   Try to initialize Panther logging 1 times, last error: 0x0
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Getting Provider DISMLogger - CDISMProviderStore::GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Manager: PID=3612 TID=1432 Successfully created the local image session and provider store. - CDISMManager::CreateLocalImageSession
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Getting Provider DISMLogger - CDISMProviderStore::GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: 
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: <----- Starting Dism.exe session ----->
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: 
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Host machine information: OS Version=10.0.14393, Running architecture=amd64, Number of processors=8
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Dism.exe version: 10.0.14393.0
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Executing command line: dism  /mount-wim /wimfile:c:\W10x64_base.wim /index:1 /mountdir:c:\dism
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Getting the collection of providers from a local provider store type. - CDISMProviderStore::GetProviderCollection
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\FolderProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Connecting to the provider located at C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\FolderProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\WimProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Connecting to the provider located at C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\WimProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\VHDProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Connecting to the provider located at C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\VHDProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\ImagingProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Connecting to the provider located at C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\ImagingProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\CompatProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Connecting to the provider located at C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\CompatProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\FfuProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Connecting to the provider located at C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\FfuProvider.dll. - CDISMProviderStore::Internal_LoadProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has not previously been encountered.  Attempting to initialize the provider. - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Loading Provider from location C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\SiloedPackageProvider.dll - CDISMProviderStore::Internal_GetProvider
    2017-03-21 07:55:41, Warning               DISM   DISM Provider Store: PID=3612 TID=1432 There is a possible 32-bit versus 64-bit cross architecture issue with the provider (or one of its dependencies). - CDISMProviderStore::Internal_LoadProvider(hr:0x800700c1)
    2017-03-21 07:55:41, Warning               DISM   DISM Provider Store: PID=3612 TID=1432 Failed to Load the provider: C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\AMD64\DISM\SiloedPackageProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x800700c1)
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Got the collection of providers. Now enumerating them to build the command table.
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: DISM Log Provider
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: FolderManager
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: WimManager
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Succesfully registered commands for the provider: WimManager.
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: VHDManager
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: GenericImagingManager
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Succesfully registered commands for the provider: GenericImagingManager.
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: Compatibility Manager
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Succesfully registered commands for the provider: Compatibility Manager.
    2017-03-21 07:55:41, Info                  DISM   DISM.EXE: Attempting to add the commands from provider: FfuManager
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Getting Provider WimManager - CDISMProviderStore::GetProvider
    2017-03-21 07:55:41, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Provider has previously been initialized.  Returning the existing instance. - CDISMProviderStore::Internal_GetProvider
    [3612] Caller did not request sparse mount
    [3612] Mounting new image.
    Wim:         [c:\W10x64_base.wim]
    Image Index: [1]
    Mount Path:  [c:\dism]
    [3612] [0x80070057] RestoreReparsePoint:(1445): The parameter is incorrect.
    [3612] [0xc144012e] 
    2017-03-21 07:56:12, Error                 DISM   DISM WIM Provider: PID=3612 [RestoreReparsePoint:(1446) -> ioctl: setting reparse point tag failed] c:\dism\Windows\assembly\NativeImages_v4.0.30319_64\WindowsBase\18f0da2999188287b7e4e44037d403f6\WindowsBase.ni.dll (HRESULT=0x80070057) - CWimManager::WimProviderMsgLogCallback
    [3612] [0x80070057] RestoreFileData:(3008): The parameter is incorrect.
    [3612] [0x80070057] RestoreRefNode:(1578): The parameter is incorrect.
    [3612] [0xc144012e] 
    2017-03-21 07:56:12, Error                 DISM   DISM WIM Provider: PID=3612 c:\dism\Windows\assembly\NativeImages_v4.0.30319_64\WindowsBase\18f0da2999188287b7e4e44037d403f6\WindowsBase.ni.dll (HRESULT=0x80070057) - CWimManager::WimProviderMsgLogCallback
    [3612] [0x80070057] RestoreRefNodeCallback:(1788): The parameter is incorrect.
    [3612] [0x80070057] ProcessWimQueueNode:(96): The parameter is incorrect.
    [3612] [0x80070057] DequeueWimData:(304): The parameter is incorrect.
    [3612] [0x80070057] ImageWorkerThread:(203): The parameter is incorrect.
    [3612] [0x80070057] GetImageErrorCode:(2833): The parameter is incorrect.
    [3612] [0x80070057] ImageWorkerThread:(187): The parameter is incorrect.
    [3612] [0x80070057] GetImageErrorCode:(2833): The parameter is incorrect.
    [3612] [0x80070057] RestoreFileNodeList:(1950): The parameter is incorrect.
    [3612] [0x80070057] RestoreFilesCallback:(3668): The parameter is incorrect.
    [3612] [0x80070057] EnumImageDataEntries:(1048): The parameter is incorrect.
    [3612] [0x80070057] RestoreAllData:(990): The parameter is incorrect.
    [3612] [0x80070057] WIMApplyImageInternal:(709): The parameter is incorrect.
    [3612] [0x80070057] ImageStubMountDirectory:(1136): The parameter is incorrect.
    [3612] [0x80070057] WIMMountImageHandle:(1425): The parameter is incorrect.
    [3612] [0x80004005] DeleteAndRestoreDirectory:(333): Unspecified error
    [3612] [0xc1420117] DeleteAndRestoreDirectory:(334)
    [3612] [0xc1420117] RestoreMountDirectory:(402)
    [3612] [0xc1420117] WIMMountImageHandle:(1478)
    2017-03-21 07:56:44, Error                 DISM   DISM WIM Provider: PID=3612 TID=1432 "Failed to mount the image." - CWimImageInfo::Mount(hr:0x80070057)
    2017-03-21 07:56:45, Error                 DISM   DISM WIM Provider: PID=3612 TID=1432 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2706 - CWimManager::InternalOpMount(hr:0x80070057)
    2017-03-21 07:56:45, Error                 DISM   DISM WIM Provider: PID=3612 TID=1432 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:4050 - CWimManager::InternalCmdMount(hr:0x80070057)
    2017-03-21 07:56:45, Error                 DISM   DISM WIM Provider: PID=3612 TID=1432 "Error executing command" - CWimManager::InternalExecuteCmd(hr:0x80070057)
    2017-03-21 07:56:45, Error                 DISM   DISM WIM Provider: PID=3612 TID=1432 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2223 - CWimManager::ExecuteCmdLine(hr:0x80070057)
    2017-03-21 07:56:45, Info                  DISM   DISM.EXE: Image session has been closed. Reboot required=no.
    2017-03-21 07:56:45, Info                  DISM   DISM.EXE: 
    2017-03-21 07:56:45, Info                  DISM   DISM.EXE: <----- Ending Dism.exe session ----->
    2017-03-21 07:56:45, Info                  DISM   DISM.EXE: 
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Found the OSServices.  Waiting to finalize it until all other providers are unloaded. - CDISMProviderStore::Final_OnDisconnect
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Disconnecting Provider: FolderManager - CDISMProviderStore::Internal_DisconnectProvider
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Disconnecting Provider: WimManager - CDISMProviderStore::Internal_DisconnectProvider
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Disconnecting Provider: VHDManager - CDISMProviderStore::Internal_DisconnectProvider
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Disconnecting Provider: GenericImagingManager - CDISMProviderStore::Internal_DisconnectProvider
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Disconnecting Provider: Compatibility Manager - CDISMProviderStore::Internal_DisconnectProvider
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Disconnecting Provider: FfuManager - CDISMProviderStore::Internal_DisconnectProvider
    2017-03-21 07:56:45, Info                  DISM   DISM Provider Store: PID=3612 TID=1432 Releasing the local reference to DISMLogger.  Stop logging. - CDISMProviderStore::Internal_DisconnectProvider

    Tuesday, March 21, 2017 2:16 PM

All replies

  • Hello

    Use the Windows 10 version of DISM with Wofadk.sys filter driver. For more information, see DISM Supported Platforms and Copy DISM to Another Computer.


    Regards, Regin Ravi

    Tuesday, March 21, 2017 3:30 PM
  • Hi kubasa,

    Is the wim file captured by yourself?

    I have tried to use the Windows 10 ADK deployment tool "dism" command to mount a Windows 10 1607 image and  it could mount well.

    Please try to mount a different Windows 10 1607 image then check the symptom again. Try to mount the image on a Windows 10 machine with the dism command in C:\Windows\System32.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 22, 2017 6:09 AM
    Moderator
  • Thanks for the suggestions.  I forgot to mention this was Windows 10 EDU 1607.  Education shouldn't make a difference but I didn't specify it.  Anyway, I tried mounting from c:\windows\system32, from another box with DISM and mounting using DISM remotely and nothing would mount the image.  I'm rebuilding the image from scratch and will try it again.  It might be something with this image since everything else works. 
    Thursday, March 23, 2017 3:28 PM
  • I pulled down my base 1511 image which works fine.  I can mount it, work with it and deploy it for images.  If I try to apply the 1607 update, it almost completes but then blows up at some point and then uninstalls the update.  Makes me wonder if there is something wrong with 1607 on the EDU version since no one else seems to be having problems from what I can see.  
    Thursday, March 23, 2017 3:45 PM
  • I have it working now.  Two things were changed.  I rebuilt my Windows 10 Education 1607 image and I manually captured it and added the /CheckIntegrity flag during the capture process.  Here's what Microsoft states for this flag:

    Detects and tracks .wim file corruption when used with capture, unmount, export, and commit operations. /CheckIntegrity stops the operation if DISM detects that the .wim file is corrupted when used with apply and mount operations.

    I don't like problems like this because I don't feel like there was any real solution but hopefully this will help someone down the road.  The original error code was error 87 which I failed to mention. 

    Friday, March 24, 2017 12:53 PM
  • Hi kubasa,

    I am glad the issue has been resolved now and thanks for updating. Please remember to mark the reply.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 27, 2017 7:17 AM
    Moderator