locked
Core affinity RRS feed

  • Question

  • Ok I don't know if this has been answered in the past, I guess so but here goes. I play an old game : Quake3Arena which really doesn't like multi-core PC. I was on Windows XP before and I have been able to play it normally. Now I switched recently to Windows 7 Home Premium 64 and have been having really bad lag spike issue until I found out that it was running on both core (I have a Core2Duo E8400) so I can manually go to task manager and set the affinity to use core 0 instead of both 0 and 1 and it runs good. But Quake3 doesn't likt to ALT-TAB to windows and I want to make it permanently. I tried a number of command in my shortcut but none have worked so far. Here is what it looks like :

    C:\Windows\System32\cmd.exe /C start /affinity 1 quake3.exe +nologo

    Don't mind the +nologo, it's a Q3 command to stop the startup logo and go directly to the Q3 menu. So I read in many web site that this should work just fine but it doesn't. The program starts but when I go to task manager to check the core used by it, it still uses both core 0 and 1 even though the command tells it not to. Help here. Also, everytime the program start I get that annying windows that warns me and ask me to allow Quake3.exe to make modification to my system and bla bla bla.Very annoying. Any way to stop that also ?

    Monday, August 5, 2013 7:43 PM

Answers

  • Hi Slimsimon 1973,

    According to my judgment, there must be wrong with your command line syntax. Here is an example (BingDict): Right click on BingDict shortcut, then click Properties, and then you’ll see the Target option.
    Target: "E:\Microsoft Bing Dictionary\BingDict.exe" (the original command line).

    Target: C:\Windows\System32\cmd.exe /C start "" /affinity 1 "E:\Microsoft Bing Dictionary\BingDict.exe" (modified command line to set BingDict using the cpu 0).

    Towards your second issue mentioned, please attempt to Run as administrator or turn off User Account Control. However, we don’t recommend to turn off UAC for security reason.

    Note The affinity should be a single hexadecimal number, not a list of CPU numbers:
    1 = use CPU 0
    2 = use CPU 1
    3 = use CPU 1 and 0
    4 = use CPU 2
    ...
    F = use CPU 3, 2, 1 and 0

    Hope this helps!


    • Edited by hipop man Wednesday, August 7, 2013 12:34 AM modify
    • Proposed as answer by 暁北 Thursday, August 15, 2013 11:33 AM
    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:38 PM
    Tuesday, August 6, 2013 12:15 PM

All replies

  • Use this tool to set the affinity to only 1 core:

    http://www.prnwatch.com/prio/


    "A programmer is just a tool which converts caffeine into code"

    Tuesday, August 6, 2013 5:48 AM
  • Hi Slimsimon 1973,

    According to my judgment, there must be wrong with your command line syntax. Here is an example (BingDict): Right click on BingDict shortcut, then click Properties, and then you’ll see the Target option.
    Target: "E:\Microsoft Bing Dictionary\BingDict.exe" (the original command line).

    Target: C:\Windows\System32\cmd.exe /C start "" /affinity 1 "E:\Microsoft Bing Dictionary\BingDict.exe" (modified command line to set BingDict using the cpu 0).

    Towards your second issue mentioned, please attempt to Run as administrator or turn off User Account Control. However, we don’t recommend to turn off UAC for security reason.

    Note The affinity should be a single hexadecimal number, not a list of CPU numbers:
    1 = use CPU 0
    2 = use CPU 1
    3 = use CPU 1 and 0
    4 = use CPU 2
    ...
    F = use CPU 3, 2, 1 and 0

    Hope this helps!


    • Edited by hipop man Wednesday, August 7, 2013 12:34 AM modify
    • Proposed as answer by 暁北 Thursday, August 15, 2013 11:33 AM
    • Marked as answer by Cloud_TS Sunday, August 18, 2013 1:38 PM
    Tuesday, August 6, 2013 12:15 PM