none
KB2596911 breaks FIM Portal WSS RRS feed

  • Question

  • Hi,

    We have just applied WSS 3.0 KB2596911 to our FIM Portal and the Portal no longer works, with the following errors in Event Viewer:

    A process serving application pool 'SharePoint - 80' suffered a fatal communication error with the Windows Process Activation Service. The process id was '2084'. The data field contains the error number.


    Unknown SQL Exception 33002 occured. Additional error information from SQL Server is included below.
    Access to module dbo.proc_GetRunnableWorkItems is blocked because the signature is not valid.
    The description for Event ID 33002 from source MSSQL$MICROSOFT##SSEE cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    module
    dbo.proc_GetRunnableWorkItems

    The specified resource type cannot be found in the image file

    Faulting application name: w3wp.exe, version: 7.5.7601.17514, time stamp: 0x4ce7afa2
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e21213c
    Exception code: 0xe053534f
    Fault offset: 0x000000000000cacd
    Faulting process id: 0x%9
    Faulting application start time: 0x%10
    Faulting application path: %11
    Faulting module path: %12
    Report Id: %13

    Has anyone else experienced this?

    The hotfix cannot be rolled back or reapplied.

    Thanks

    Friday, July 13, 2012 1:38 AM

All replies

  • Just an update - we had to restore the FIM Portal from backup.

    For now, going to avoid this particular hotfix until further notice.

    Saturday, July 14, 2012 2:30 AM
  • I can confirm that we have this issue also on our production FIM 2010 server. Investigating resolution...
    Tuesday, August 21, 2012 10:11 PM
  • I have my FIM portal site working again. Tracing back my steps, I did the following:

    • Checked that our DEV FIM server had the patch applied (it did, back in July)
    • Looked at the patch release notes and found the following: "Known issues with this security update. After you install this security update, PSCONFIG may run automatically. To prevent this from occurring, you must run the update by using the following command line. Note that the command is case-sensitive: sts2007-kb2596911-fullfile-x86-glb.exe PATCH_ARGS=runupgrade=no After you have updated all of the servers in the farm, you can run PSCONFIG.". So we were warned...
    • I then found the following post which suggested trying this: psconfig -cmd upgrade -inplace b2b -wait
    • It failed saying "A previous attempt to upgrade SharePoint Products and Technologies has failed." so I tried again with the -force switch: psconfig -cmd upgrade -inplace b2b -wait -force. This completed successfully.
    • I was then able to access the FIM portal home page.  I received an error about connecting to the portal service, so restarted the Forefront Identity Manager Service and life went back to normal after that.

    Hopefully this hasn't damaged anything, so I will continue to monitor it for a short while and keep you posted.

    Cheers!


    Tuesday, August 21, 2012 11:26 PM
  • No further issues :)
    Wednesday, August 22, 2012 4:42 AM