locked
DVD not being recognised in Vista Ultimate RRS feed

  • Question

  • I have a Sony DVD drive in my Vista Ultimate PC. At first, it was showing driver problems with the DVD drive, so I removed the Upper Filter (there was no lower filter), and restarted, the drive got recognised fine. But now, even when I enter any CD into it, it says 'Please insert a disc into drive F:'. I don't know what to do, as most online articles are regarding the drive itself not being recognised, not the DVD.

    I had installed some software relating to cds before this : DVD Region + CSS free, and Virtual CloneDrive. I tried uninstalling both and retrying the DVD drive, but nothing worked. Please help.
    Neil
    Tuesday, October 20, 2009 11:14 AM

All replies

  • Hello,
    I think that your problem may be solved with this "fix it" :
    http://support.microsoft.com/kb/314060/en-us

    Regards.
    Patrice.
    Microsoft MVP WDE
    Tuesday, October 20, 2009 11:47 AM
  • If you see my question, I had already manually removed the Upper Filters. There was no lower filter. So I have already done what the Fixit suggests. The DVD drive is being recognised by my machine, its the DVDs inside that aren't. And its not a specific DVD/CD that has the problem. And I believe its a software problem, not hardware.
    Neil
    • Proposed as answer by Pat84 Wednesday, October 21, 2009 12:29 PM
    Wednesday, October 21, 2009 10:47 AM
  • Hello,
    I don't find more information about that...
    It may be that the audio device is disabled. Try this :

    1. Click Start, click Control Panel, and then double-click Sound.
    2. On the Playback tab, right-click in the blank area under Select a playback device below to modify its settings, and then select Show Disabled Devices.
    3. Right-click an audio device, and then click Enable.

    OR
    Try to unisntall your DVD Drive : In the device manager, right-clic on the DVD Drive, and choose Uninstall. After, restart your computer.

    But it is without certainty :-(
    I search for again...

    Patrice.

    Wednesday, October 21, 2009 12:35 PM