none
DirectAccess unstable on Windows 7 RRS feed

  • Question

  • Hi,

    We have an issue whit current DirectAccess environment.

    • Unstable, client gets disconnected on random basis
    • Can't transfer large files, get interrupted
    • When client is waking up from hibernation/sleep it don't gets connected. Sometimes takes up 15 min or never gets connected. An reboot fixes this.

    The client is running Windows 7 SP1 and the DA-servers is Windows 2012. The servers is running on single NIC configuration and are NAT:ed, they have a external load balancer and what we could determine is this issue arise when configuration for external LB. We have applied all the patches there for both the servers and the clients but we can not find anything wrong with the DA-servers.

    Friday, October 3, 2014 3:13 PM

All replies

  • I'd start here: https://support.microsoft.com/kb/2883952
    Monday, October 6, 2014 3:23 PM
  • With the item "
    • Can't transfer large files, get interrupted"

    Is that transferring from the corporate network to your machine (e.g. downloads), or from your  machine to the corporate network (uploads), or both?

    Tuesday, October 7, 2014 4:10 AM
  • We did apply all patches, still the same problem.

    Since this issue happened when we implemented the Load balancer we deiced to rollback and try with another scenario. But of course, new problems have arise.

    Tuesday, October 7, 2014 12:06 PM
  • Both, usually it's the disconnection of DA that causes it to fail to upload files.

    Tuesday, October 7, 2014 12:06 PM
  • What load balancer were you using? What load balancing method?

    We are using F5's with the "Least Connection" load balancing method. 

    Tuesday, October 7, 2014 11:14 PM
  • Also when you say, clients doesn't connect after waking up from  hibernation/sleep can you confirm if you have 2FA enabled on your DA setup ?

    Instead of rebooting the whole machine, what happens if you disable and re-enable the NIC ? Or restart of iphlpsvc.

    Please let me know, how it goes, will be happy to help! :)

    Friday, October 10, 2014 6:50 AM
  • When restarting the IP-Helper it works, We tried that a couple of times. It's Windows 7 clients so, well it's userntml and computer certificates, but no other two-factor.
    Friday, October 10, 2014 11:00 AM
  • Interesting, could you tell me what "Least connection" means in F5 terms?

    We do however have a Cisco LB.

    Friday, October 10, 2014 11:01 AM