none
MDT and NET Framework 1.1 Compatibility Assistant RRS feed

  • Question

  • Hi everyone,

    I have MDT 2012 update 1 which I use to deploy Win7Sp1 with Light Touch dep. and NET Framework 1.1 with SP1 slipstreamed. My problem is that the Application Compatibility Assistant would not allow NET framework to be installed, any ideas how I can disable application compatibility before MDT runs NET framework install?

    Thank you

    Wednesday, March 20, 2013 8:00 PM

All replies

  • dotNET 1.1 is not officially supported on Windows 7.  That being said, see these forum post for information on how to make it work (maybe): http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/how-to-install-net-framework-11-in-windows-7-64/eb1e6232-e874-432e-ab43-17660e25e43d

    The way I've dealt with similar apps is thus... I'll install it, click the dialog and tell the Compatibility Assistant that the application is ok, then find it in the registry (HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags).  Find whatever was added, and create a Step in your Task Sequence to do this (with your own apps GUID) before trying to install the application.

    Here's mine for McAfee VSE 8.8P2 on Win8:

    reg add "HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags" /v {a7253c85-7598-413d-b7fe-0cfcc74996b2}  /t REG_DWORD /d 4

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Wednesday, March 20, 2013 8:38 PM
    Answerer
  • Hi David,

    Thank your reply and sorry for reply so late. Yes NET Framework 1.1 officially is not supported on Win7, however with SP1 its supported, apart from Win7 x64 which has some IIS issues for which I do receive compatibility warnings, on the other hand on Win7 x32 it will install without any warnings.

    What I did, is I created a mast images from my reference Win7 x64bit machine, by pre-installing NET Framework 1.1 with SP1, and now I do not need to deploy NET Framework 1.1 as a separate sequence.

    All the best

    Bujar 

    Tuesday, April 16, 2013 2:03 PM