none
Desktop Wallpaper's problematic GPO

    Question

  • Hello,

    I have Windows Server 2012 R2 installed on my domain controllers and on client side I'm using windows XP/7/8 versions. 

    I've pushed new wallpaper on client computers by using Group Policy and except Windows XP all works great - On windows 7 and 8 desktop wallpaper is showing on the display.

    As for installation of desktop wallpaper on Windows XP - after login nothing is changing on the display, but in the display properties, on the "themes" and "Desktop" tab is showing the new wallpaper, that already was displayed without problems on 7 and 8 versions.
    On XP computers gpresult showing me that wallpaper policy was successfully pushed.

    So, What about this issue guys, what should I do to display this wallpaper on windows XP machines?

    Thanks a lot,



    • Edited by GMG888 Friday, February 13, 2015 3:37 PM
    Friday, February 13, 2015 3:29 PM

Answers

All replies

  • Guys,

    Do you have any suggestions for this issue ?

    Monday, February 16, 2015 8:12 AM
  • Hi

    I had this issue. How are you applying the policies? For example, do you copy the wallpaper in the computer GPO and force the desktop wallpaper on the user GPO? This seemed to resolve it for me. 

    I'd also check GP extensions are installed on the Windows XP machines (http://www.microsoft.com/en-gb/download/details.aspx?id=3628)

    Cheers


    Craig Brand

    Monday, February 16, 2015 8:38 AM
  • Hi,

    Before going further, how did we deploy the wallpaper via group policy? Besides, please try to use Fill Wallpaper Style as this will work best with most screen resolutions. Moreover, we can try to logon continuously twice to see if the wallpaper can take effect, or we can try to enable the setting Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon.

    In addition, there are several ways to deploy wallpaper via group policy. If the issue persists, we can try alternative solutions to see if it helps.

    Regarding this point, the following article can be referred to for more information.

    Using Group Policy to configure Desktop Wallpaper (“Background”)

    http://www.grouppolicy.biz/2011/03/best-practice-using-group-policy-to-configure-desktop-wallpaper-background/

    If we want to try to use Group Policy Preferences to deploy wallpaper, as also mentioned by Craig, we need to install client side extensions of GPP for Windows XP clients. Regarding this point, the following article can be referred to for more information.

    Information about new Group Policy preferences in Windows Server 2008

    http://support.microsoft.com/kb/943729

    Best regard,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, February 16, 2015 8:49 AM
    Moderator
  • Thanks a lot guys for your comments,

    I have the following configuration in the group policy for Installing the wallpaper on the desktop:

    1. The GPO that copy .jpg file in the computers locally
    2. The GPO for which is written a local path like this - C:\windows\web\wallpaper\name.jpg  

    As I said above I have various client OS and this method of installing wallpapers on client computers (XP/7/8) is more convenient for me.

    As for your suggestions, I tested and installed GP extensions on XP machines but still the same issue.

    Monday, February 16, 2015 10:50 AM
  • Happy to help. 

    The black screen appearing in my experience is possibly a file permission issue. Try copying the file for XP computers to a public user folder; "C:\Document and Settings\All users\..."

     



    Craig Brand

    Monday, February 16, 2015 11:55 AM
  • > C:\windows\web\wallpaper\name.jpg
     
    Hm - I slightly remember that in XP, you cannot use jpg in GPO, only
    bmp. If you use jpg in XP interactively, the system converts it to a bmp
    and uses this bmp instead. If you use GPO, you must provide a bmp
    because the conversion doesn't take place.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Monday, February 23, 2015 4:46 PM
  • Hi,

    Regarding this point, the following thread can also be referred to for more information.

    "Desktop Wallpaper" Group Policy Setting Causing Two Issues in XP

    https://social.technet.microsoft.com/Forums/windows/en-US/393e845c-2763-4ada-9030-3580c0f051b7/desktop-wallpaper-group-policy-setting-causing-two-issues-in-xp?forum=itproxpsp

    Best regards,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Lucianosecure Wednesday, May 27, 2015 7:24 PM
    • Unproposed as answer by Lucianosecure Wednesday, May 27, 2015 7:25 PM
    Thursday, March 5, 2015 1:35 AM
    Moderator
  • Hi, try this ... worked for me this way

    0) User Configuration/Policies/Administrative Templates/Desktop/Desktop Wallpaper ==> \\SRVDOMAIN\SHARE\WALLPAPER.JPG

    1) User Configuration/Preferences/Windows Settings/Registry ==> Action ==> Exclude ==> HKEY_CURRENT_USER ==> Control Panel\Desktop ==> TranscodedImageCache

    2) User Configuration/Preferences/Windows Settings/Registry ==> Action ==> Exclude ==> HKEY_CURRENT_USER ==> Control Panel\Desktop ==> TranscodedImageCount

    3) User Configuration/Preferences/Windows Settings/Registry ==> Action ==> Update ==> HKEY_CURRENT_USER ==> Control Panel\Desktop ==> Wallpaper  ==> REG_SZ  ==>  \\SRVDOMAIN\SHARE\WALLPAPER.JPG

    bye. Luciano
    Wednesday, May 27, 2015 7:25 PM