locked
UAG Installation Failures On Server 2008 R2 RRS feed

  • Question

  • What am I missing here folks.  I've tried several times to install UAG Beta RC0 on Server 2008 R2 Enterprise Edition and every time it fails when it gets to 'installing TMG'.  Here's an event log entry ->

    Product: Microsoft Forefront Threat Management Gateway Beta EE  -- Error 1305.Error reading from file D:\ISA\FPC\program files\Microsoft ISA Server\UI_HTMLs\EE\06AlertsTab.htm.  Verify that the file exists and that you can access it.

    Here's the ISAWRAP_255.log ->

    15:34:06 INFO:    Installer activated, command-line='/v" /qn REBOOT=ReallySuppress FULLPATHANSWERFILE=\"C:\Users\2333\AppData\Local\Temp\TmgInstall.091112.153406.2848.ini\""'
    15:34:06 INFO:    Running setup wrapper in quiet mode.
    15:34:06 INFO:    Expanded full extraction path of SQL Express 2008 SP1 Package is 'C:\Windows\temp\{CECBAEFD-9EB9-4C4F-8136-21C75BD74050}'.
    15:34:06 INFO:    Install scenario
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: Upgrade code is not set
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: There is no any product code for upgrade code
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: Upgrade code is not set
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: There is no any product code for upgrade code
    15:34:06 ERROR:    CSSEInstaller::GetInstanceId failed to open reg key 'SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\SQL'
    15:34:06 INFO:    CSSEInstaller::Prepare: Failed to get the instace id of MSFW
    15:34:06 ERROR:    CSSEInstaller::GetInstanceId failed to open reg key 'SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\SQL'
    15:34:06 INFO:    CSSEInstaller::Prepare: Failed to get the instace id of ISARS
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: Upgrade code is not set
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: There is no any product code for upgrade code
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: Upgrade code is not set
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: There is no any product code for upgrade code
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: Upgrade code is not set
    15:34:06 INFO:    CMsiAttendantInstaller::Prepare: There is no any product code for upgrade code
    15:34:06 INFO:    Installing ISA (Core components)...
    15:34:06 INFO:    Service W3SVC is running.
    15:34:06 INFO:    Service iisadmin is stopped.
    15:34:06 INFO:    CFirewallInstaller: Activating installation, command line args = '-I "D:\ISA\FPC\MS_FPC_Server.msi " /qn REBOOT=ReallySuppress FULLPATHANSWERFILE="C:\Users\2333\AppData\Local\Temp\TmgInstall.091112.153406.2848.ini" WRAPPER=1 ARPSYSTEMCOMPONENT=1 REBOOT=ReallySuppress'
    15:34:49 ERROR:    Setup failed. Error returned: 0x643
    15:34:49 ERROR:    CBasicInstaller: Install failed, hr=0x80070643
    15:34:49 ERROR:    Installation failed. hr = 0x80070643
    15:34:49 ERROR:    Installation failed, hr=0x80070643
    15:34:49 INFO:    Service W3SVC is running.
    15:34:49 INFO:    Service iisadmin is stopped.
    15:34:49 ERROR:    InstallProducts: Install ISA (Core components) failed, hr=0x80070643
    15:34:49 ERROR:    Wrapper: Install failed, hr = 0x80070643
    15:34:49 ERROR:    Wrapper: DoSetup failed, hr = 0x80070643
    15:34:49 ERROR:    Wrapper: DoSetup failed, hr = 80070643
    15:34:49 ERROR:    Setup of ISA failed. Return value: SETUP_ERROR_ISA
    Thursday, November 12, 2009 8:48 PM

Answers

  • That is correct.  It is english.  I downloaded the Server 2008 180-day trial code to make sure the code was up to date.  I did try to extract the UAG ISO file using WinRAR and then install from the directory.  This got me further along, now TMG fails at 98%.  When I was trying to install from the ISO directly (mount the ISO in Hyper-V), TMG failed at 2%.

    Next I will try to install TMG directly and then try to install UAG.  I suspect this will not work as the UAG installation of TMG is probably heavily customized.
    • Marked as answer by Erez Benari Monday, November 16, 2009 5:50 PM
    Friday, November 13, 2009 11:53 AM

All replies

  • Hi,

    Your 2008 R2 OS is an english built-in version ? Fresh installation of 2008 R2 ?

    Have a nice day,
    alex
    GIRAUD Alexandre - MVP Forefront France - http://www.alexgiraud.net/blog
    Friday, November 13, 2009 12:54 AM
  • That is correct.  It is english.  I downloaded the Server 2008 180-day trial code to make sure the code was up to date.  I did try to extract the UAG ISO file using WinRAR and then install from the directory.  This got me further along, now TMG fails at 98%.  When I was trying to install from the ISO directly (mount the ISO in Hyper-V), TMG failed at 2%.

    Next I will try to install TMG directly and then try to install UAG.  I suspect this will not work as the UAG installation of TMG is probably heavily customized.
    • Marked as answer by Erez Benari Monday, November 16, 2009 5:50 PM
    Friday, November 13, 2009 11:53 AM
  • I've the exact same problem. 

    Fresh install of Windows 2008 R2 standard, completely patched.   

    Getting the exact error as the OP.  

    Did you end up working around this error  in the end?

    Sunday, November 25, 2012 3:46 AM