locked
CBS is returning 0x800288c5 when I try to remove a feature from Vista Ultimate SP1 RRS feed

  • Question

  • Hello,

     

    I have a clean install of Windows Vista Ultimate SP1. Some of the development projects I am working on require testing in a MUI environment, so I have also installed all available language packs to assist me in this. Perhaps a bit of overkill, but I have found it necessary in today's "flat world." Anyway, the error in question, 0x800288c5, is returned by CBS when I attempt to remove a feature from the "Windows Features" control panel. It does not matter what feature, any attempt to remove any feature causes this error. For example, let's say I uncheck the "FTP Publishing Service" feature of the IIS feature group and hit ok. What happens is the TrustedInstaller spends about 1.5 hours thrashing my disk and then promptly fails. It's the same result, every single time. I tried shutting down all unused services and still no luck. Using Process Explorer, I noticed that what is happening is TrustedInstaller is parsing manifests from the C:\Windows\WinSxS\Manifests the entire time. What caught my eye is that it is *actually* leaving the file handle open for each manifest it opens, reaching an open handle count well over the theoretical limit of 65,536 handles by the time it fails. For the record, there are 80,449 manifests in my C:\Windows\WinSxS\Manifests folder. Examination of CBS.log reveals the following:

     

    Code Snippet
    2008-05-21 14:45:33, Info                  CBS    WER: Generating failure report for package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~x86~~6.0.6000.16386, status: 0x800288c5, failure source: CBS Other, start state: 7, target state: 7
    2008-05-21 14:47:40, Info                  CBS    Exec: Processing complete.  Session: 29932383:757337806, Package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~x86~~6.0.6000.16386, hr: 0x800288c5

     

    Now being a developer, I know that "hr" is shorthand for HRESULT, the Windows error handle. Referencing my handy copy of Winerror.h:
     
    Code Snippet
    //
    // MessageId: TYPE_E_SIZETOOBIG
    //
    // MessageText:
    //
    // Size may not exceed 64K.
    //
    #define TYPE_E_SIZETOOBIG _HRESULT_TYPEDEF_(0x800288C5L)

     

    Has anyone else run into this problem? I really would like to be able to remove features. Is this a bug in CBS, as I suspect?

     

    BTW, should it really be leaving file handles open like that? And why the heck does it take so long to parse those manifests? I know my box is getting on in years (4 year old Dual Processor Athlon MP), but still, 1.5 hours to read in 64k+ of ~7Kb files (383Mb total)?!?

     

    Cheers,
    Nicholas

    Wednesday, May 21, 2008 10:52 PM

All replies

  • I am getting exactly the same error trying to add MSMQ to my Vista Ultimate SP1 machine (64 bit).

     

    Did you resolve this issue? Or any workarounds.....

     

    Monday, August 4, 2008 12:09 PM
  •  

    Were any of you able to resolve this issue? I am also getting and don't have much of an idea on what to do about it. Thank you.

    Monday, August 4, 2008 8:56 PM
  • Hi,

     

    This problem has been raised with Microsoft through a customer support case.

    I'll update the thread with any public conclusions and workarounds as and when.

     

    Cheers

    John Breakwell (MSFT) 

    Tuesday, August 5, 2008 2:05 PM