locked
Opening files from SharePoint in client program RRS feed

  • Question

  • Hi,

    I need to open a particular non-Office file type in the client application from SharePoint however when I do it throws the error below. The file is an FME Workbench file - if I download and open it from my local PC, it will open in the client program but not directly from SharePoint.

    Is this a limitation of the product, or is there a way of configuring SharePoint or IIS to open it in the client program?

    "the xml page cannot be displayed, cannot view the xml input using style sheets, please the correct the error and click the refresh button and try again later - invalid at the top level of the document, error processing resource (web link to url) - #![?xml version = "1.0" encoding = "iso - 8859-1"?]

    Tuesday, April 30, 2013 5:48 PM

All replies

  • Hi Josh,

    That is true that there is not “Edit in …” entry for Non-Office program, but we can add a custom entry this way.
    http://msdn.microsoft.com/en-us/library/aa978104(v=office.12).aspx

    It involved the following subtask.

    • Creating a document template file, which in effect adds a DocumentTemplate to the Onet.xml file of the site definition
    • Adding a Mapping element to DocIcon.xml for a file type icon and for identification of the control to use to open the file
    • Creating a DLL that provides the necessary functions for creating or editing documents in the application

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please click here.


    Emir Liu
    TechNet Community Support

    Wednesday, May 1, 2013 2:39 AM
  • Hi, this partially answers the question. Unfortunately the final (and hardest bit) of this seems to have no detail in the TechNet article on how you actually do this. Is there any further information available anywhere?
    Wednesday, May 1, 2013 9:12 AM
  • Hi,

    I am not exactly sure why you are getting that error. Typically IE will download the XML file and ask you to save it. To configure IE to open the file in a client application, there are 2 requirements,
    1. The client application should have registered itself as the default application to open the specific type of file extension.
    2. To change the behavior, so that IE does not prompt to save the file but opens it using the default registered application, we will need to configure SharePoint. This can be done via powershell - http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.splist.browserfilehandling.aspx - This is the property which needs to be set to Permissive through powershell OR this can also be changed under "General Settings" of the Web application.

    If you need more information about this property and how it works - refer http://social.technet.microsoft.com/wiki/contents/articles/8073.sharepoint-2010-and-2013-browser-file-handling-deep-dive.aspx.

    The other approach is what Emir has suggested above. Regarding your question about the last part, check if the same given here helps - http://msdn.microsoft.com/en-us/library/dd588661(v=office.11).aspx

    Regards, Vijay R G Microsoft Online Community Support

    Thursday, May 2, 2013 9:10 AM
  • Hi, this is for MOSS 2007. It isn't actually an XML file that is the problem, but an FMW file, which in Windows is defaultly set to open with the FME Workbench application.
    Thursday, May 2, 2013 9:15 AM
  • Hi,

    Then you should be able to follow the steps in the article http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.splist.browserfilehandling.aspx to make it work. Did you try that?

    Regards, Vijay R G Microsoft Online Community Support

    Friday, May 10, 2013 12:30 PM
  • Appreciate the rwesponse, but that does not help. I guess I will need to log a call with Microsoft to get a definitive answer. Such a shame as this should be standard functionality...
    Friday, May 10, 2013 12:50 PM