none
Can't access smb share after update to 1709 RRS feed

  • Question

  • Hi there, a have got a problem with my access to Ubuntu 14.04.3 LTS Sambaserver share.

    Share \\10.0.0.2\Films works well (available for clients) on Windows 1703 and previous versions, but all 1709 clients show error "Windows cannot access" 0x80004005 


    Friday, October 20, 2017 7:37 AM

All replies

  • I believe this is by design, SMB v1.0 has been deprecated, hopefully you can update the share to SMB 2 or 3

    Please see Microsoft's explanation here

    SMBv1 is not installed by default in Windows 10, version 1709 and Windows Server, version 1709

    • Proposed as answer by mix717 Sunday, January 21, 2018 5:24 PM
    • Unproposed as answer by mix717 Sunday, January 21, 2018 5:24 PM
    Friday, October 20, 2017 8:34 AM
  • Hey, i have the same problem with my Debian Jessie Server. Since the last update (1709) i cant access to my shares. With my android phone, other linux distros and older windows versions i can access to these shares.

    Have you found a way to configure your smb-server that the new windows can connect to these shares?

    Edit:
    I have found out that the smb-server is not responsible for the problems, but the new windows 10 update 1709. I can't also access Windows 10 (latest version) to Windows 10 (before the update 1709) over smb.

    Whats wrong with microsoft? :-(


    Friday, October 20, 2017 11:34 AM
  • I'm seeing that as well. I know that 1709 doesn't have smb1 enabled by default, but I've also disabled smb1 on my file server regardless. All other client versions seem to still work.

    server min protocol = SMB2_10
    client min protocol = SMB2
    client max protocol = SMB3


    Friday, October 20, 2017 8:46 PM
  • FYI, I found someone else who found the problem and a fix (for me anyway).

    https://tech.nicolonsky.ch/windows-10-1709-cannot-access-smb2-share-guest-access/

    MS has an article now to.

    https://support.microsoft.com/de-ch/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

    essentially 1709 disables unauthenticated access to shares using SMB2. There is a GPO that can easily be flipped to fix the problem if setting up auth isn't an option. Here is the policy in question.

    Computer configuration\administrative templates\network\Lanman Workstation "Enable insecure guest logons"

    • Proposed as answer by FujitsuSpeed Tuesday, October 24, 2017 8:24 AM
    Tuesday, October 24, 2017 12:14 AM
  • I have the same problem... but more confusing...

    Ok, win 10 1709 installed in a DELL XPS laptop.

    I am no more able to access to a win 2012 r2 server, used as print server with guest user anabled.

    I am not able to rich a synology NAS server (based on linux)

    I CAN access to a second synology NAS server, that is a twin of the previous one, save versione of everything exactly a twin.

    The two synology are located in the same rack and in the same subnet.

    Why??

    daniele

    Tuesday, October 31, 2017 9:36 AM
  • I have the same problem... but more confusing...

    Ok, win 10 1709 installed in a DELL XPS laptop.

    I am no more able to access to a win 2012 r2 server, used as print server with guest user anabled.

    I am not able to rich a synology NAS server (based on linux)

    I CAN access to a second synology NAS server, that is a twin of the previous one, save versione of everything exactly a twin.

    The two synology are located in the same rack and in the same subnet.

    Why??

    daniele

    Guest access has been deprecated in Windows 10 for security reasons.

    You can't enable the Guest account in Windows 10

    • Edited by NoneAndOne Tuesday, October 31, 2017 11:32 AM
    Tuesday, October 31, 2017 11:26 AM
  • Yes, I understand, but what about 2 (twin) server machines, with normal smb account, one can be rich the other no??

    d.

    Tuesday, October 31, 2017 2:25 PM
  • It is likely the sharing is configured differently on the working NAS, check through all the config options around sharing and look for differences.  Also compare the BIOS versions.
    • Edited by NoneAndOne Tuesday, October 31, 2017 2:37 PM
    Tuesday, October 31, 2017 2:31 PM
  • Hello.

    Same problem here: in particular I can mount and read all the SMB shares, but I can't save the files inside them.

    After 1709, I have many problem with SMB network shares on all the Synology NAS: the only solution is to enable again the "SMB1.0 Client" on MS Windows 10 1709.

    Regards.

    Alessandro

    p.s. per Daniele: please try to execute "Clear SMB Cache" in the Advanced Properties of SMB Settings on DSM of the first NAS, where you have the problem.

    • Proposed as answer by thangesh Monday, December 17, 2018 3:09 AM
    Friday, November 17, 2017 6:09 AM
  • Click the start button and type "Turn windows features on or off" and open this window. 

    Then check the "Simple Network Management Protocol (SNMP)" option. Thats all... 

    If you have troubles with samba, find and check the option "SMB 1.0/CIFS Client" 

    Sorry for bad english. 


    M.AYGÜN

    Friday, November 17, 2017 6:01 PM
  • I have also a problem accessing a Synology DS414J from Windows 10 Pro since the 1709 update.

    Before the update it worked perfectly, now i can only access from Windows 7 / Linux / Android clients.

    SMB on the synology was set to smb2 / smb3 even BEFORE the update.

    Re-enabling smb1 on Windows 10 does not change anything.

    Re-enabling smb1 on NAS does not change anything

    I CAN access the CIFs share on the synology from Win10, the explorer will display some folder contents quite fast but when accessing a deeper folder level at the NAS directory update takes forever (>10 minutes).

    Accessing files is almost impossible from Win10, this was no problem before the 1709 update and is still possible from all other systems.

    The second problem is that i cannot access the NAS web frontend any more from Win10. I tested Firefox, IE, Chrome. Interface was https only but even after enabling http access it does not work anymore.

    Upon entering the NAS address al browsers display the obligate certificate error (Synology uses a not signed certificate) and the just stop and display an empty page till a timeout error. This means that they can SEE the NAS but then get a timeout before displaying the logon page.

    I contacted Synology support but they just state that the problem must obviously be a Win 10 bug and i shall contact microsoft.

    This problem is getting really anoying as i cannot make any backups from Win 10 clients to the NAS any more.

    Hope somebody can help.

    Gemi

    Friday, November 24, 2017 7:10 PM
  • Hi Monominta,

    thanks for the link, already tried all these suggestions as re-eanabling smb-1 but none did solve the problem.

    Both, synology NAS and Win10 are on latest update level.

    I can see the NAS under network places and i can access it using explorer which is different from the case in the link.

    Problem is that opening a sub-folder takes forever and accessing files or accesing the web frontend is impossible since 1709. It simply stopped working the moment i rebooted the pc after the 1709 update.

    Since this day i cannot open the synology web frontend any more. I only get a timeout after some 5 to 10 minutes.

    Max

    Saturday, November 25, 2017 10:34 AM
  • This was the case for me. The error message I was getting when trying to access the shares indicated something along the lines of group security policy. The change in GPO fixed it for me.

    Thanks!

    Saturday, November 25, 2017 4:30 PM
  • Hi, unfortunatly this also did not change anything for me.

    I am currently comparing wireshark recordings from the failing Win10 logon process to those of the working Win7.

    There are a lot of TCP dup acks, retransmissions, even some out of order packages from Win10 whereas on the Win7 i do not see a single retransmission...

    Have to investigate this more...

    Max

    Sunday, November 26, 2017 2:49 PM
  • Hi Momominta,

    Norton AV and Comodo Firewall on both Win10 and Win7, same versions, (almost) same rule sets

    Already tried to disable them on the Win10 machine, makes no difference.

    According to the wireshark recordings, there seem to be lost segments in the transmission... i see many tcp out of order and fast retransmissions but still dont know why.

    I did plug the Win7 machine to the network socket of the Win10 machine to see if there is a hardware problem but Win7 is just doing fine on this port (means there should be no cable or wiring or switch problem).

    Max

    Sunday, November 26, 2017 5:55 PM
  • Hi all,

    i finally found the culprit !!!!

    The Win10 machine was running HyperV (was needed for certain development projects).

    After removing HyperV i can again access the NAS via Web Interface and Explorer without any issues.

    Must have been a bug or something in HyperV network stack that came to surface after the 1709 upgrade...

    Thanks for the hints and help !

    Max

    Sunday, November 26, 2017 6:27 PM
  • hi FujitsuSpeed,

    i have same problem with my Debian Jessie Server. Can tell me how did u solved the  problem.


    Tuesday, January 16, 2018 10:37 AM
  • Thanks, Momominta, for your detailed answer! I had the same problem with a Laptop with Windows 10 that actually does not get any automated updates and an Openmediavault NAS with an old kernel (I think OMV version 2.7). Your answer worked! Fcuk you Microsoft!
    Saturday, January 27, 2018 2:20 PM
  • For my part, to have my share back to work I had to change the smb.conf file on my centOs 7 server:

    [global]
            workgroup = WORKGROUP
            security = user
            server min protocol = SMB3
            client min protocol = SMB3
            client max protocol = SMB3

    I tried to set the min protocol to SMB2 but it didnt worked. Hope this can help someone.

    Wednesday, February 7, 2018 4:45 AM
  • Awesome, thank you! My mapped drive and Quick Access links to my Samba share were still working (could read and write) but it was missing from Network Locations. Checking the SNMP option corrected and made all samba servers visible again.
    Saturday, February 17, 2018 1:54 AM
  • My connection issue got solved when I mapped the drives using credentials.

    Simply browsing to a (public) network share does not work (anymore).

    From Explorer -> home -> easy access -> map as drive, enter IP or hostname and tick Connect using different credentials.


    Using Samba 4.2.1 and 4.3.11-Ubuntu

    ps "easy access"?? why does every new Windows version comes with a new labyrinth

    Tuesday, March 6, 2018 10:16 AM
  • Thank you, that solved my problems. (i checked both and now 1. samba can access windows shares and 2. all windows 10 computer see all the shares, windows and linux, in the network)
    Wednesday, March 21, 2018 1:20 PM
  • thanks momominta

    this did the trick for me

    Saturday, March 24, 2018 2:59 AM
  • My connection issue got solved when I mapped the drives using credentials.

    Simply browsing to a (public) network share does not work (anymore).

    From Explorer -> home -> easy access -> map as drive, enter IP or hostname and tick Connect using different credentials.


    Using Samba 4.2.1 and 4.3.11-Ubuntu

    ps "easy access"?? why does every new Windows version comes with a new labyrinth

    adding my ubuntu-share ip/username/password in Contro Panel Credential Manager worked for me, thx
    Friday, March 30, 2018 1:42 AM
  • I was two days on this. There were no meaningful error messages as to why my Laptop with Build 1709 wouldn't see my NAS. Even upgrading the NAS Firmware didn't work! Finally found the SMB1.0/CIFS Client in Windows Features was Unchecked, so Rechecked it and found my 'lost' NAS.

    Thanks to M.Aygun

    Monday, April 2, 2018 8:34 PM
  • PROBLEM SOLVED!!  Mustafa Aygun - THANK YOU!  Such a wonderful short answer, right to the point.

    Start/Run - Turn Windows Features On and Off

    Expand SMB 1.0/CIFS File Sharing Support

    Place checkmark next to SMB 1.0/CIFS Client

    Reboot Computer

    My issue was that one of my computers could not see my brand new USB 3.0 flash drive (Readyshare) plugged into my brand new Netgear AC home router.  My other computer COULD see it, even though both computers are running exactly the same Windows 10 Build 16299 so I was very confused.  I still don't understand why only one of the computers had the SMB 1.0/CIFS Client checked and the other did not, but once I checked the client on the other computer and rebooted, then both could see the USB flash drive equally.  Took me two full days of searching forums to find this post.

    Tuesday, April 3, 2018 1:44 AM
  • BUT: I understand SMB 1.0 is insecure, and one is only supposed to turn it on if a networked component can't function without it!

    So, I'd still like to learn how to browse networked win10 pc's *without* SMB 1. MS suggests making the "Function Discovery" services start auto, but that doesn't seem to make other pc's visible. Am I missing something, or is there no way "browse" the local subnet?

    Thursday, April 5, 2018 12:14 AM
  • All, I have been struggling with this for almost two years now. I have a company laptop and cannot access my NAS or other Windows machines at home. With some NAS I am able to access the contents via putty/WINSCP but with a Linux share which only provides guest access not even this works. To be precise, when I say “it does not work” I mean: \\IP ADDRESS\share does not work Mapping the share does not work Mapping the share with command prompt does not work The device is not visible in the Network The device does not show up in net view The only solution which consistently but only temporarily works is to 1. Disable SMB1 in Windows features... 2. Reboot 3. Open features and re-enable SMB1 4. Reboot Pathetic! Any better ideas???
    • Edited by DrPo64 Wednesday, April 25, 2018 6:22 PM
    Wednesday, April 25, 2018 6:21 PM
  • I spent 8 hours dealing with 0x80070035 error and https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows lead here and you finally provided a simple way to turn back on what microsoft turned off to ruin my life. 
    Tuesday, May 1, 2018 2:46 AM
  • I tried your method. I enabled again the "SMB 1.0 client" on MS windows 10.

    It works!! 

    Thanks a million!

    Saturday, May 12, 2018 2:21 AM
  • Thank you. This did the trick for me. Now I can access my NAS on my desktop PC.

    What is strange is that I do not have the problem on my W10 Notebook or tablet.

    Both have 1709 and 1803. (I say no 2 windows systems or update are ever the same)

    You can go directly to Control Panel to access features on or off.


    Doug

    Thursday, May 24, 2018 1:37 PM
  • Click the start button and type "Turn windows features on or off" and open this window. 

    Then check the "Simple Network Management Protocol (SNMP)" option. Thats all... 

    If you have troubles with samba, find and check the option "SMB 1.0/CIFS Client" 

    Sorry for bad english. 


    M.AYGÜN

    This worked for me, thank you so much!!
    Sunday, June 10, 2018 6:13 AM
  • Update your windows 10 1709 to 1803 and enable SMB1 and all will work fine, 1709 is full of bugs.
    Unfortunately there is a lot of equipment including many NAS Servers, network Printers, ADSL Routers and other network devices that only support SMBv1. so you won't see these devices in windows under Network without it, you also do not see your own computer and its shared folders. Unfortunately SMBv1 has security issues, but so does most of MS's software as well as Java and Adobe software.
    Our whole company wend down after update 1709 and we had to go back to 1703 on some and others we just re-installed our original windows 7, I have now updated machines from 1709 to 1803 and all problems solved, Had to wait for 1803 to first become ready for Business use as was very unstable on early release. So far 1803 has been win10's most stable feature update, hope it stays that way! Still nothing as stable as Windows 7 FULL-STOP....

    Thursday, July 19, 2018 5:37 PM
  • Two problems, 1709 update and Edge Browser problems. MS Fixed problems in 1803.
    With Synology you need to use Google Chrome as default browser to eliminate most problems or IE-11 also helps. Edge is a problematic browser with some devices and file transfers. MS needs to fix but has made some good changes in the Edge Browser in 1803 but it still has bugs with folder and file transfers in Synology apps.

    I do not like Google Chrome or trust it, but it at least works..! 

    Thursday, July 19, 2018 5:57 PM
  • I had this issue as well - Windows Server not being able to access SMB Share on Synology.  I fixed it on the Synology side by going to Control Panel -> File Services.  Under SMB Advanced Settings, set the minimum SMB to version 2.  Bam...Fixed.
    Monday, July 30, 2018 5:35 PM
  • I was having a problem with connecting to my shares on centos 6. If you look in the firewall settings windows 10 is using port 445. If you enable the smb-out port under private/public. I also opened the port on my share and I am now able to connect. I did not have to change my smbconf file at all.
    Saturday, August 18, 2018 12:02 AM
  • You can enable SMB1.0 in the apps and features section of Windows 10 in the settings.

    This worked for me in an enterprise environment running an older Windows 2008 setup that we are working on migration.

    The end game would be to update the server, but a workaround right now fix would be to enable SMB1.0 in Windows 10.

    This is working in Windows 10 1803.

    Tuesday, August 21, 2018 4:12 PM
  • My connection issue got solved when I mapped the drives using credentials.

    Simply browsing to a (public) network share does not work (anymore).

    From Explorer -> home -> easy access -> map as drive, enter IP or hostname and tick Connect using different credentials.


    Using Samba 4.2.1 and 4.3.11-Ubuntu

    ps "easy access"?? why does every new Windows version comes with a new labyrinth

    I have solved it using a similar solution. I checked the logs of NAS and found that after migration to W10 version 1709 it started to try to map Samba share using my windows credentials (always failing as there was no such user set up on NAS), so I had to create the user on NAS side and access using this user, not guest as this is not allowed anymore by policies after upgrade to 1709.
    Wednesday, August 29, 2018 10:50 AM
  • Strangely, that got me access to my Ubuntu server shares, but the path to my Mint desktop still doesn't work.
    Tuesday, September 11, 2018 2:19 PM
  • gpedit.msc 

    Local Group Policy Editor


    Computer configuration\Administrative Templates\Network\Lanman Workstation

     Enable insecure guest logons 

    Enable 

    Sunday, March 10, 2019 7:04 AM
  • I had the same issue and this setting fixed my problem.
    Wednesday, March 20, 2019 1:21 AM
  • That did the trick for me
    Sunday, May 19, 2019 3:44 PM
  • This is by far my most favourite Microsoft update/feature. I absolutely love spending 2 days of my life trying to figure out how Microsoft have decided to fuck my day up. Amazingly great work, keep it up!

    Anyway, i digress. In the meantime, I have  windows service using a samba share on on Ubuntu 16.04, This was working great until Monday when my laptop ground to halt (thank you again Windows updates) and needed rebooting. Updates we're installed and low and behold my service stops working.

    Tried the above settings, I'm about ready to throw the server out the window.

    Running my service from command prompt works, i can see the shares being accessed and my service is running. As soon as i set the service running, nothing.

    I've renabled/disabled SMB1, added teh registry fix. Changed the GPO. Anyone else had this?

    In short.

    Windows 10 service getting config from samba share - does not work
    Windows 10 running the same service from the command line, does work
    Windows 7 running the service can get its config from the samba share. it also works from command prompt.

    SMB1 disabled, SMB2/3 enabled. Samba server is forcing minimumn version of 2 and max version is set to 3.

    Setting the min/max version both to 3 stopped the share working completely from Windows 10 (No browse, no running application from command prompt, no running as a service.)

    I can't ait for the next feature update. Hey Microsoft, if you could just brick my hard drive or OS completely next time that would be awesome.
    Thursday, July 18, 2019 11:22 AM
  • This is by far my most favourite Microsoft update/feature. I absolutely love spending 2 days of my life trying to figure out how Microsoft have decided to fuck my day up. Amazingly great work, keep it up!

    Anyway, i digress. In the meantime, I have  windows service using a samba share on on Ubuntu 16.04, This was working great until Monday when my laptop ground to halt (thank you again Windows updates) and needed rebooting. Updates we're installed and low and behold my service stops working.

    Tried the above settings, I'm about ready to throw the server out the window.

    Running my service from command prompt works, i can see the shares being accessed and my service is running. As soon as i set the service running, nothing.

    I've renabled/disabled SMB1, added teh registry fix. Changed the GPO. Anyone else had this?

    In short.

    Windows 10 service getting config from samba share - does not work
    Windows 10 running the same service from the command line, does work
    Windows 7 running the service can get its config from the samba share. it also works from command prompt.

    SMB1 disabled, SMB2/3 enabled. Samba server is forcing minimumn version of 2 and max version is set to 3.

    Setting the min/max version both to 3 stopped the share working completely from Windows 10 (No browse, no running application from command prompt, no running as a service.)

    I can't ait for the next feature update. Hey Microsoft, if you could just brick my hard drive or OS completely next time that would be awesome.

    This worked for me on Version 1809...

    1) Window + R  (run)

    2) Type gpedit.msc then press enter

    3) Go to Computer configuration >> administrative templates >> network >>Lanman Workstation 

    4) "Enable insecure guest logons"

    5) No restarted needed. Good luck.



    • Edited by error420 Friday, July 19, 2019 12:07 AM
    Friday, July 19, 2019 12:06 AM