none
1703 "Something went wrong" message during oobe

    Question

  • I've just created my first image using Win 10 Pro creators update. Everything seems to go fine until you get to the OOBE. I'm getting the error "Something went wrong. You can try again, or skip this for now." Retrying doesn't work. Choosing to skip works fine, no further problems. It's more an irritation.

    I'm using WDS, Server 2012 R2. I've tried the same answer files I've always used for Windows 10 and created new ones using the latest catalog file generated from the new install.wim. Both result in the same error. 

    The log file in C:\Windows\Panther\UnattendGC shows the error:

    [CloudExperienceHostBroker.exe] Disabling default account failed [hr=0xD00000E5]

    Any suggestions on a fix?

    

    Friday, April 07, 2017 4:20 PM

All replies

  • I am having the same problem i am waiting for the iso so i can install it on my Acer laptop i have tried 6 times already and i am waiting on Microsoft so i am trying to be calm you see the update went great on the desktop computers i built the only one i could not install it on was the computer i bought anyway i will be calm through out and in the end  i will have myself one hell of a laptop.
    Saturday, April 08, 2017 7:17 PM
  • Hi hailst0rmxp,

    Have you added any configurations related to account such as enabled the built-in administrator account?

    If you have configured any account settings, please remove them then check the symptom again.
    To analyze the issue deeply, please  upload the log (setup*.log) to OneDrive and paste the link here. Upload the unattend answer file, too.

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    Monday, April 10, 2017 6:26 AM
    Moderator
  • setupact.log - https://drive.google.com/open?id=0BwfiwUZ4hBI-NXpYeWZaMWRWd2s

    setuperr.log - https://drive.google.com/open?id=0BwfiwUZ4hBI-dFI1R3pvWDZQaTQ

    Yes the answer file does have configuration relating to the build in administrator account.

    During the specialize stage the administrator account is set as active: net user administrator /active:yes

    CopyProfile is enabled.

    The during the OOBE stage the AdministratorPassword is set.

    Monday, April 10, 2017 7:01 AM
  • The during the OOBE stage the AdministratorPassword is set.


    What about all those "Failed to load oobe.xml file" messages which preceded the error message?

    FWIW I would be using ProcMon to help supplement the diagnostics that you have.

    Otherwise looking just at the crash code  0xD00000E5

    For a stab at interpreting it without such clues there is this

    https://technet.microsoft.com/en-us/itpro/windows/deploy/resolve-windows-10-upgrade-errors?f=255&MSPPError=-2147217396#result-codes

    leading to this

    0xC00000E5
    STATUS_INTERNAL_ERROR
    An internal error occurred.

    which doesn't seem very informative.

     

    Good luck



    Robert Aldwinckle
    ---

    Monday, April 10, 2017 12:32 PM
  • Thanks. I'm doing some trial and error at the moment to see if I can eliminate what bit of the answer file is tripping it up.
    Monday, April 10, 2017 1:00 PM
  • Hi hailst0rmxp,

    How about the issue, is there anything to update? Have you tried to remove the administrator account settings in unattend file?

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 12, 2017 9:36 AM
    Moderator
  • I have tried removing the sections relating to administrator but didn't seem to make any difference. I tried removing the OOBE section but was still getting the same error. I'm giving up for now and will stick with the anniversary update until Microsoft have patched these problems.
    Wednesday, April 12, 2017 10:02 AM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>
    Saturday, April 15, 2017 12:33 AM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>
    I thought those settings were deprecated: https://technet.microsoft.com/en-us/library/cc765947%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396
    Monday, April 17, 2017 7:00 PM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>

    I thought those settings were deprecated: https://technet.microsoft.com/en-us/library/cc765947%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    Yes, I agree, all Microsoft documentation points to those settings being depreciated. Documentation for version 1703 answer file settings only has two changes listed, which don't relate to this issue. However, it is the only thing I found that works.
    Also, refer to here.
    • Edited by Spin-0 Monday, April 17, 2017 11:34 PM Added further information
    Monday, April 17, 2017 11:30 PM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>

    Are you applying those settings to the Capture OS or during the Deploy TS in the Install Operating System step?
    Monday, April 17, 2017 11:53 PM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>

    Are you applying those settings to the Capture OS or during the Deploy TS in the Install Operating System step?

    During Deploy OS.
    Tuesday, April 18, 2017 12:42 AM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>

    Are you applying those settings to the Capture OS or during the Deploy TS in the Install Operating System step?


    During Deploy OS.
    I tried the same during the Apply Operating System Image step and have seen no change, still getting the something went wrong screen. 
    Tuesday, April 18, 2017 2:50 PM
  • Hey All, 

    I'm also having this exact issue. Same events in the setuperr.log and same symptoms. I added those lines to my unattended.xml and it didn't resolve the issue.

    What I noticed is, if you ALT-TAB at that point in time there is a prompt for elevated credentials sitting behind the 'something went wrong' screen. If you enter admin credentials, and then ALT-TAB back to 'Something went wrong' and then click 'Try Again' OOBE finished successfully.

    So... this got me thinking that it was something to do with Group Policy. So I unlinked all GPOs from my test OU and built again and it successfully ran through OOBE.

    Currently going through GPO with a fine-toothed comb looking at UAC / Restricted Group / Local Admin settings that might be causing this.

    Wednesday, April 19, 2017 3:40 AM
  • For me, this error was being caused by the Restricted Groups settings I have in Group Policy. This policy was inherited from the Win7 SOE, and worked fine in Win7 and Win10 <=1607 perfectly. For some reason it breaks OOBE in 1703.

    Instead I moved these settings to GPPrefs and I haven't had the error again (I still have the settings from the post above in unattended.xml).

     
    Wednesday, April 19, 2017 5:56 AM
  • Hey All, 

    I'm also having this exact issue. Same events in the setuperr.log and same symptoms. I added those lines to my unattended.xml and it didn't resolve the issue.

    What I noticed is, if you ALT-TAB at that point in time there is a prompt for elevated credentials sitting behind the 'something went wrong' screen. If you enter admin credentials, and then ALT-TAB back to 'Something went wrong' and then click 'Try Again' OOBE finished successfully.

    So... this got me thinking that it was something to do with Group Policy. So I unlinked all GPOs from my test OU and built again and it successfully ran through OOBE.

    Currently going through GPO with a fine-toothed comb looking at UAC / Restricted Group / Local Admin settings that might be causing this.

    Correct..it is GPO related, or at least was in my case. I have had the same issue and it was due to a legacy GPO configuring the local administrators group members via GP Preferences.

    Wednesday, April 19, 2017 10:32 PM
  • For me, this error was being caused by the Restricted Groups settings I have in Group Policy. This policy was inherited from the Win7 SOE, and worked fine in Win7 and Win10 <=1607 perfectly. For some reason it breaks OOBE in 1703.

    Instead I moved these settings to GPPrefs and I haven't had the error again (I still have the settings from the post above in unattended.xml).

     
    That is interesting, as in my case it was GP Preferences that caused the problem. I removed those and re-created with restricted groups and have the same issue.
    Wednesday, April 19, 2017 10:58 PM
  • We have the same error. Unfortunately, the error also occurs when the computer is moved to an OU without a GPO.
    I had seen the bug myself during a test installation using original ISO on a Hyper-V client. So without "unattended.xml" and GPOs.

    Martin Schneeberger

    Friday, May 05, 2017 5:14 AM
  • For me changing "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" from "Prompt for consent on the secure desktop" to "Prompt for consent for non-Windows binaries" corrects the issue and allows it to complete.

    Friday, May 05, 2017 5:40 PM
  • Thanks TTroy1!

    I have now set the "User Account Control: Behavior of the elevation prompt for Admin Approval Mode" setting to "Prompt for consent for non-Windows binaries" in Group Policy. In addition, in the OSD task sequence I set the registry value "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\ConsentPromptBehaviorAdmin" to the DWORD value 5. This ensures that UAC is also configured correctly if Group Policy does not yet work.


    Martin Schneeberger

    Sunday, May 07, 2017 12:42 PM
  • Adding defaultuser0 as a local administrator seems to have done the trick for me.
    Tuesday, May 09, 2017 8:58 AM
  • that's interesting.  Are you doing this as a step in the task sequence? if so can you tell me the command?

    Tuesday, May 09, 2017 9:25 AM
  • I did it via GPP. Just adding "defaultuser0" as a member of the "administrators (built In)".
    • Proposed as answer by sccman Wednesday, May 10, 2017 10:06 AM
    Tuesday, May 09, 2017 11:21 AM
  • I'm having this same issue, with a vanilla build, and no WDS answer file. There is also a dialog in the background looking for microsoft account details, but alt-tab does not bring it to focus


    Things would be great if they worked properly.

    Tuesday, May 09, 2017 3:48 PM
  • Creating a vanilla build with no domain join, machine builds with no issues.

    On domain build, clicking "Skip" brings up screen asking to set location, privacy etc. This does not happen with non-domain answer file. The only difference between my domain and non-domain answer files is the domain join.

    After setting privacy etc. a dialog pops up saying something like, "great, you're connected. Now checking for updates."

    My guess is it's the domain join process that is causing the Windows setup to fail.

    setuperr.log for failed install below:

    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:06:57, Error      [0x0b003a] WDS          <GetNameInfo failed; status 0x8007276d>[gle=0x0000276d]
    2017-05-10 10:07:46, Error      [0x064237] IBSLIB <InstallTo>/<PartID> is missing
    2017-05-10 10:07:46, Error      [0x0b0049] WDS    CallBack_WdsClient_ConnectToImageStore: Error processing unattended image selection. Error [0x80300007]
    2017-05-10 10:21:59, Error      [0x0606ae] IBS    [SetupCl library] Required profile hive does not exist: [\??\C:\WINDOWS\system32\config\systemprofile\NTUSER.DAT].
    


    Things would be great if they worked properly.

    Wednesday, May 10, 2017 10:02 AM
  • schoolt3chy, adding defaultuser0 as a local administrator using GP worked a treat, thanks very much. 

    Now it gets past that point I get a voice speaking telling me something like "You're now connected, lets check for updates".  anybody know how I can disable this?

    edit:  I used the now deprecated-in-1703 <SkipMachineOOBE> function within the OOBE configuration in unattended.xml.  My test machines are now all building exactly how they should.

    • Edited by sccman Wednesday, May 10, 2017 1:10 PM updated information
    Wednesday, May 10, 2017 10:11 AM
  • Using <SkipMachineOOBE> function within the OOBE worked for me too. Now it builds, but the start menu is inoperative like in some of the earlier builds. Cortana works, but not the menu. Very frustrating.

    And before someone suggests it, I am not running sfc, or Dism.exe /Online /Cleanup-Image /RestoreHealth on every newly built system as was suggested for the earlier builds. That's a ridiculous notion.
    It didn't work in any case.

    Things would be great if they worked properly.

    Wednesday, May 10, 2017 3:40 PM
  • the start menu is inoperative
    In a really early build I used Narrator to demonstrate that it was there just not rendering.  What exactly is your symptom?


    Robert Aldwinckle
    ---

    Wednesday, May 10, 2017 6:11 PM
  • Click/tap Start and nothing happens. Click inside the Search box and Cortana pops up offering to be terribly helpful. Typing application names in the Search box offers the application, plus all the associated web links as one would expect. The menu itself just does not appear.
    Right-Click on Start brings up the context menu as one would expect.

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} Fixes nothing.

    SFC.exe /scannow Fixes nothing.

    Create new user Fixes nothing.

    (The above are all the previous suggestions from previous builds)

    The odd thing is, this all works from a DVD build, just not from WDS. I am using the boot.wim & install.wim from the SW_DVD5_WIN_ENT_10_1703_64BIT_Eng_Intl_MLF_X21-36480 ISO.

    The ClientUnattend.xml file partitions the drive. Nothing else.

    The WDSUnattend.xml file sets the organisation (and now has <SkipMachineOOBE> function within the OOBE added too) but does nothing else.

    I had this same issue with the Windows10_InsiderPreview_x64_EN-GB_10074 ISO, and had to mess with the language files within the install.wim to fix it.

    Looks like I will have to go down the same route again, building 2 systems, then comparing file and registry values looking for differences.


    Things would be great if they worked properly.

    Thursday, May 11, 2017 8:29 AM
  • Click/tap Start and nothing happens.

    That's what I meant about what Narrator could help with.  In fact, you can go further and uncheck the Search icon in the Taskbar to see how it works normally.  E.g. press Win-Enter (now Win-Shift-Enter unfortunately; it was changed recently) and hear "Starting Narrator".   So, then, without any Search button to see, press Ctrl-Esc and hear "Search box. Editing.".  You may also see a blue box where the Search box will be.  But then, using Narrator commands you can explore what it is "seeing".  Even more remarkably you can use them!  And the best thing of all is that once you have explored them using Narrator they start appearing on the screen!  YMMV.

    Windows 10.  Still an Adventure ("Twisty passages, all different.")



    Robert Aldwinckle
    ---

    Thursday, May 11, 2017 1:28 PM
  • I was getting the same error. I found that if you add the following (in bold) to Autounattend.xml it will at least get you past the 'something went wrong' error:

        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">          
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
            </component>
        </settings>

    This ended up fixing this annoying issue on my deployments! Thanks a ton!
    Friday, May 12, 2017 7:49 PM
  • Adding the <SkipMachineOOBE>true</SkipMachineOOBE> entry to the answer file does skip past the "Something went wrong" screen, but prevents the domain join, which is of no use to anyone using WDS to deploy operating systems.

    Did Microsoft actually test this build of Windows with WDS?


    Things would be great if they worked properly.

    Monday, May 15, 2017 8:06 AM
  • Adding the <SkipMachineOOBE>true</SkipMachineOOBE> entry to the answer file does skip past the "Something went wrong" screen, but prevents the domain join, which is of no use to anyone using WDS to deploy operating systems.

    Did Microsoft actually test this build of Windows with WDS?


    Things would be great if they worked properly.

    They did.  Then when they saw what sysadmins all over the world would have to do to make it work they probably chuckled and released the build. Because...  sysadmins are so 2003.
    Monday, May 15, 2017 12:08 PM