How do i get IE11 on Windows 7 to Spell Check 2 language (English, French) using only 1 keyboard layout (Canadian French - Canadian French)


  • Issue since moving from IE9 to IE11 in the office (New installation as well since we moved from Win 7 32 to Win 7 64 at the same time)

    I've changed the Language Preference on IE11 to add both of them, English by default

    Microsoft Office is already set to use both language

    Although using Internet Explorer, we are having an issue where it only seem to spell check one language, giving errors when typing words in the other language.

    Read on the internet some people that added both language in the keyboard layout, but that's not an interesting solution because first the French keyboard layout does all the English keys and second people tend to accidentaly switch language while typing using shortcut or whatever

    Any help regarding this issue would be appreciated


    • Edited by Matt_1689 Thursday, September 24, 2015 5:50 PM
    Wednesday, September 23, 2015 4:34 PM


  • Hi,

    Based on my test, it is only English spelling check that installed in Internet Explorer by default. Although you add a language in “Internet Options”, you also need to select language for spelling check if you want it.

    Therefore, you need to install it manually in “All dictionaries”. Just click “Tools” > “Manage add-ons” > “Spelling Correction”. In the “Show” column, choose “All dictionaries”. Then add the language for test.

    If you want to use one keyboard layout to detect two languages spelling check, we are sorry to tell you it is hard to realize currently.

    Wish you will troubleshoot the issue smoothly.

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact

    Friday, September 25, 2015 1:59 AM