locked
Problems installing Microsft Visual C++ 2010 SP1 Redistributable Package RRS feed

  • Question

  • I am using Vista Ultimate (SP2) on a Dell PC. I am up to date with all Windows updates.

    I downloaded Microsft Visual C++ 2010 SP1 Redistributable Package (http://www.microsoft.com/download/en/details.aspx?id=8328) but when I tried to install I got the message "Setup Installer has stopped working".

    I then tried to install Package with PC started in safe mode. I got a bit further but installation failed. I got to point of accepting licence (did not get this far when PC was started normally) then files were extracted then installation failed. Summary failure message was:

    "Final Result: Installation failed with error code: (0x80070641), "The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance. " (Elapsed time: 0 00:00:07)."

    I have found Microsoft support page: http://support.microsoft.com/kb/2642495

    I have tried Method 1 and Method 2 but installation of Package continues to fail as above for the PC in normal mode and in safe mode.

    Since trying to install Microsft Visual C++ 2010 SP1 Redistributable Package, I have had some Microsoft updates that were downloaded and notified to me. All these updates installed without problems.

    I have now exhausted my expertise in trying to solve problem of installation of Microsft Visual C++ 2010 SP1 Redistributable Package.

     If you do have any suggestions I would be very grateful (not keen on going through complete rebuild of PC software!!).

     All help much appreciated.

    Thursday, December 15, 2011 9:39 AM

Answers

  • You may go to check if the Windows Installer Service is running in Services.msc. Is it able to manually restart this service?

     

    Also, please try to install the Microsoft Visual C++ 2010 SP1 Redistributable Package in the Clean Boot.


    Sabrina

    TechNet Community Support

    • Marked as answer by Sabrina Shen Tuesday, December 27, 2011 5:40 AM
    Monday, December 19, 2011 10:02 AM
  • Windows Installer service is not available in safe mode. So, please test it in clean boot.

    Sabrina

    TechNet Community Support

    • Marked as answer by Sabrina Shen Tuesday, December 27, 2011 5:40 AM
    Wednesday, December 21, 2011 10:21 AM

All replies

  • You may go to check if the Windows Installer Service is running in Services.msc. Is it able to manually restart this service?

     

    Also, please try to install the Microsoft Visual C++ 2010 SP1 Redistributable Package in the Clean Boot.


    Sabrina

    TechNet Community Support

    • Marked as answer by Sabrina Shen Tuesday, December 27, 2011 5:40 AM
    Monday, December 19, 2011 10:02 AM
  • You may go to check if the Windows Installer Service is running in Services.msc. Is it able to manually restart this service?

     

    Also, please try to install the Microsoft Visual C++ 2010 SP1 Redistributable Package in the Clean Boot.


    Sabrina

    TechNet Community Support


    When I looked under services.msc Windows Installer Service was not running (Status was blank) and the Startup Type was manual. I was able to manually start the service without any difficulty.

     I have tried to install Microsoft Visual C++ 2010 SP1 Redistributale Package with the PC in safe mode (see post). Isn't that even "cleaner" than Clean Boot?? If it fails in Safe Mode doesn't that mean that it will fail in Clean Boot mode??

    Tuesday, December 20, 2011 10:33 AM
  • Windows Installer service is not available in safe mode. So, please test it in clean boot.

    Sabrina

    TechNet Community Support

    • Marked as answer by Sabrina Shen Tuesday, December 27, 2011 5:40 AM
    Wednesday, December 21, 2011 10:21 AM