locked
Missing Group attributes in FIMMA RRS feed

  • Question

  • I have a working FIM2010 setup. Active Directory inbound synchronization is configured and its user accounts are exposed successfully in the FIM2010 Portal.
    Whilst configuring attributes flows for Group (based on the article further below) , I found the following attributes mysteriously missing under the FIMMA -> Configure Attribute Flow -> Data Source Object Type: Group
    Scope
    Type
    Member
    MembershipLocked
    MembershipAddWorkflow
    How Do I Synchronize Groups from AD DS to FIM
    http://technet.microsoft.com/en-us/library/ff686936(WS.10).aspx
    An inspection in FIM Portal schema for Groups checks out ok, these five attributes are bindings under object type Group. I've tried refreshing the FIMMA schema multiple times but these 5 attributes never seem to appear in the FIMMA. Can anyone help? My FIM Portal and FIM Sync version are both on 4.0.3576.2
    Tuesday, June 14, 2011 9:18 AM

Answers

  • Thanks for the pointers Carol and Paul. Yes, I've checked the MPRs and the attributes are llisted, also have checkbox show all enabled with Group object type enable in FIMMA. Strange enough after a few reboots and schema refreshes, those missing attributes eventually showed up. I'll just hope for no hidden surprises beyond this.. Thanks again for your advice :)
    • Marked as answer by Norman Choo Wednesday, June 15, 2011 5:46 PM
    • Unmarked as answer by Norman Choo Wednesday, June 15, 2011 5:46 PM
    • Marked as answer by Norman Choo Wednesday, June 15, 2011 5:46 PM
    Wednesday, June 15, 2011 5:46 PM

All replies

  • There are 2 things.

    1) Check the MPR that allowes the attributes to be exported/exposed

    2) Check if the attributes are listed on the first page within the FIM MA (don't forget to check the checkbox 'show all')


    Need realtime FIM synchronization? check out the new http://www.traxionsolutions.com/imsequencer that supports FIM 2010 and Omada Identity Manager real time synchronization!
    Tuesday, June 14, 2011 9:59 AM
  • Have you mapped the Group object type in the FIM MA?

    On the Attributes tab you often need to tick "Show All" before you can select attributes for inclusion.


    http://www.wapshere.com/missmiis
    Wednesday, June 15, 2011 7:29 AM
  • Thanks for the pointers Carol and Paul. Yes, I've checked the MPRs and the attributes are llisted, also have checkbox show all enabled with Group object type enable in FIMMA. Strange enough after a few reboots and schema refreshes, those missing attributes eventually showed up. I'll just hope for no hidden surprises beyond this.. Thanks again for your advice :)
    • Marked as answer by Norman Choo Wednesday, June 15, 2011 5:46 PM
    • Unmarked as answer by Norman Choo Wednesday, June 15, 2011 5:46 PM
    • Marked as answer by Norman Choo Wednesday, June 15, 2011 5:46 PM
    Wednesday, June 15, 2011 5:46 PM