none
Problems connecting to Synology NAS in Windows 10 RRS feed

  • Question

  • Hi

    I've recently purchased a new laptop running Windows 10 Home (v1703) and am having problems connecting to my Synology NAS. 

    Apologies for the lack of technical detail / knowledge, but I'm a novice when it comes to these things.

    I can access the NAS drive through web browsers with the IP address, and it's showing in "Network" in Explorer. However, whenever I try to access it through Explorer (e.g. to map one of my shared folders) I get the following error message:

    "Windows cannot access \\LONGDISKSTATION

    Check the spelling of the name.  Otherwise, there might be a problem with your network.  To try to identify and resolve network problems, click Diagnose.

    Error code: 0x80070035

    The network path was not found."

    So far as I can tell, there's not a problem with the drive as I can access it through web browsers and can access it on other devices - e.g. non-Windows 10 PCs, iPhone / iPad and my Sonos system.  Having said that, when I run Synology Assistant on my laptop, it doesn't seem to be able to find the NAS drive, even though it's clearly there and apparently can be seen by Windows.

    I've tried the basics, such as disabling my firewall and anti-virus, but that doesn't make any difference.

    I've had a look at some of the Google threads on this but - honestly - I'm a novice it when it comes to these things and I'm not sure I'm looking in the right place.

    If anyone can offer an solutions - in plain English that a layman can follow! - that would be appreciated.

    Thanks

    Adam

    Friday, September 8, 2017 6:57 AM

All replies

  • See Can't find Synology NAS on Windows 10 and try the suggestions in that thread. Any further advice applying those of if they do not help post back.
    • Proposed as answer by astro-tech Saturday, October 27, 2018 8:56 PM
    Saturday, September 9, 2017 8:55 PM
  • Hi Adam,

    Let's first check the SMB settings in NAS, if it was configured SMB 1.0 as default, please configure the same version of SMB to fix this issue:

    1. Run PowerShell as Administrator

    2. Set-SmbClientConfiguration -RequireSecuritySignature 1

    Answer Y when prompted to confirm the modification.

    3. Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force
    4.  Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    If this issue still persists, Please Reinstall and reset TCP/IP to check this issue.

    1) Click on the Start button
    2) Search for CMD
    3) Right click on Command Prompt and select Run as Administrator
    4) Type netsh int ip reset c:\resetlog.txt in the Command Prompt window, and press the Enter key.
    5) Type winsock reset in the Command Prompt window, and then press the Enter key.
    6) Restart the computer.

    For further troubleshooting, please let me know if you can access with IP address in File explorer.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, September 12, 2017 1:48 AM
    Owner
  • Thanks.  I tried following a number of these and none seemed to work (at least they didn't appear to have worked in the time immediately following trying them, notwithstanding re-starting the system, etc.). 

    I then switched everything off, left it for a few days (busy at work), booted everything up again and it all seems to be running fine (for the time being).  I can't be sure which solution solved the problem but something obviously did the trick!

    Saturday, September 16, 2017 7:18 PM
  • Glad to hear that your issue has been resolved.

    The most possible cause of the NAS connection issue could be: SMB and NTLM authentication level.

    I have noticed that several similar issue was solved by the suggestions I posted here. Please help to mark the post as answered, so that other communities could find the solution more efficiently when they encounter the similar issue.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 19, 2017 5:41 AM
    Owner
  • Hi,

     


    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

     

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

     



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 12, 2017 8:14 AM
    Owner
  • I tried all of the recommendations here and none of them worked for me, but I did find a solution that worked.

    The Win10 machine was using an Ethernet connection (Realtek PCIe GBE) but it also had a WIFI adapter (Dell Wireless 1705) that was disabled.

    I disabled the Ethernet adapter and enabled the WIFI adapter and I could then see \\nas from Windows Explorer.

    This pointed to an issue with the Ethernet adapter so I

    1. Disabled the WIFI adapter again
    2. Went to Device Manager and deleted the Ethernet adpater
    3. From Device Manager ran "Find new hardware" which found the Ethernet adapter

    Everything is now working with the new Ethernet adapter

    Monday, January 8, 2018 8:31 PM
  • i resolved my issue with following steps - it might work for you too..

    1) DSM

    2) Control Panel/Files Services/Windows File Service/Advanced Settings

    3) Change "Max protocol for Windows file service:" to Enable SMB 3

    Good luck!

    GK

    • Proposed as answer by Viktor Logwin Thursday, May 10, 2018 5:34 PM
    Monday, January 15, 2018 10:29 PM
  • This solution/allow max SMB3/ helped me!

    THX

    R.

    Tuesday, February 27, 2018 10:11 PM
  • This worked initially and for around 5 mins, then i was locked out again via windows. only access was ip through browser. quickconnect stopped also.
    Tuesday, March 13, 2018 11:21 PM
  • This fixed my problem also. Thanks!!!!
    Friday, March 16, 2018 5:00 AM
  • This did the trick for my particular Windows 10 client that could not reach the NAS via \\ notation. Thanks for posting the tip!

    Cale

    Friday, April 20, 2018 7:35 PM
  • I tried all of these fixes in vain.  Oddly I was working on my media server for a completely unrelated issue.  My server and a few other network devices all use static IPs (the network device I was accessing was not rebooting, but did also have a static IP).  Since they were going to be automatically rebooting, I figured I'd set my system to static as well, just as a remote precaution to avoid any accidental grab of another device's IP address.  I also set the DNS to a generic 4.2.2.2 & 4.2.2.1 temporarily.  

    Not thinking this would work, I figured I'd try it again.  Connected without issue. ?!?!?!  After 2 weeks, still no issue, even after system reboots.  And this is the only system that was having the issue.  Puzzling, but not going to look into it further.
    Saturday, May 5, 2018 5:31 PM
  • i resolved my issue with following steps - it might work for you too..

    1) DSM

    2) Control Panel/Files Services/Windows File Service/Advanced Settings

    3) Change "Max protocol for Windows file service:" to Enable SMB 3

    Good luck!

    GK

    Worked for me as well.  
    Tuesday, June 26, 2018 11:41 PM
  • Worked! Here are my details

    Mode: DS211j

    DSM: 6.1.2-15132

    Tuesday, July 10, 2018 12:16 PM
  • i resolved my issue with following steps - it might work for you too..

    1) DSM

    2) Control Panel/Files Services/Windows File Service/Advanced Settings

    3) Change "Max protocol for Windows file service:" to Enable SMB 3

    Good luck!

    GK

    Worked for me as well.  

    After that proposed:

    1) DSM

    2) Control Panel/Files Services/Windows File Service/Advanced Settings

    3) Change "Max protocol for Windows file service:" to Enable SMB 3

    Needs one more step to work for me:

    4) Tick on "Enable Windows network discovery to allow file access via SMB"


    • Edited by PanosGRC Saturday, July 21, 2018 3:39 PM
    Saturday, July 21, 2018 3:38 PM
  • Navigate to the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters key.

    LanmanWorkstationRegEditRight click the contents pane and choose new DWORD (32 bit value).

    LanmanWorkstationRegEdit_Step2Name the new key AllowInsecureGuestAuth.

    LanmanWorkstationRegEdit_Step3Double click the new value and change the value to 1.

    LanmanWorkstationRegEdit_Step4Close regedit and you should now be able to access unsecured network shares.
    Sunday, September 9, 2018 1:33 AM
  • I'll put this here for all the truly nontechnical people here, myself included.  

    My computer > Right click in devices and drives > add a network location > \\yourdrivename\home

    Your drive name can be found at:

    DSM > control panel > file services > SMB > The blue box where it says "Enter the below address to access shared folders using a computer in your local network:

    Took me hours to noodle this out.

    Wednesday, September 26, 2018 5:53 AM
  • Hi Kate,

    I've had the same issue as Adam above and your solution worked for me.

    I did not have to reset TCP/IP

    Thank you.

    Sunday, October 28, 2018 5:46 PM
  • Thank you!

    Weird that it only became a problem after a fresh Windows install.

    It works!!

    Saturday, December 1, 2018 7:41 PM
  • Nope, didn't work for me AND what a strange way to annotate a list?
    Friday, December 28, 2018 4:15 PM
  • This solution/allow max SMB3/ helped me!

    Thanks!

    Sunday, January 13, 2019 9:18 PM
  • Hi!

    I only occasionally hopped in here.

    All my W10(64bit) Systems suffered from the same issue.

    Every time I wanted to access the DS218 (even the DS itself) i had to "ping" it.

    Then it stayed connected for a while (or not)

    This week seemingly a new W10 build was istalled - the flaw has gone by itself!

    E. Schloemmer

    Austria

    Thursday, January 31, 2019 10:19 PM
  • For information, all of this is because an update to Windows10 disabled the v1.0 for SMB protocol. As mentionned above, it is still possible to reinstall it through the Windows components if you don't want to /can't modify your NAS settings.
    Sunday, July 21, 2019 9:05 AM
  • Thank you. Enabling SMB3 as Max protocol for Windows file services  worked like a charm for me.
    Thursday, September 5, 2019 3:23 PM
  • I had the same problem. SMB 3 did not helped but I figured out that I can authenticate without any problem when using the IP Address instead of the DNS Name.

    That brought me to the idea that this might be a networking issue and in fact it was: When pinging the Synology, Windows 10 preferred IPv6 over IPv4. Disabling IPv6 on the Synology solved the issue for me (maybe you can also solve it by properly configuring IPv6 on the NAS but my router is not supporting it so I got stuck with IPv4 for the moment).

    Sunday, October 20, 2019 10:58 AM
  • Control Panel/Files Services/Windows File Service/Advanced Settings -> SMB3

    This worked for me.

    Cheers

    John

    Thursday, November 14, 2019 1:47 AM