locked
List's Form displaying empty RRS feed

  • Question

  • Please help me with a perplexing problem. I'm running SharePoint on a development box,  on one VM. Following are the steps I take to get the error:

    I create a new 'Custom List'

    I add a new item, works fine

    I open the list and choose 'Customize form'

    It opens in InfoPath

    I edit 'Title' to say 'Name'

    I choose 'Quick Publish'

    and get the message 'Your form was published successfully'

    I add a new item

    The form is blank, see below.

    What am i doing wrong?
    form after edit
    BTW, The url for the form is:

    http://xxxxxxxx:801/sites/XXX/_layouts/listform.aspx?PageType=8&ListId={4BE55E84-558E-439A-B2F1-FC5559359ABE}&RootFolder=

    and it is empty. I've confirmed the guid for the list is correct. I find no associated error messages in the logs. 

    Thanks in advance.

    Friday, June 15, 2012 2:17 PM

All replies

  • Hi,

    Try to rename back the Name to title and try, we need to know where this problem came from?


    Eng.Mostafa Absy SharePoint Developer http://wmostafaw.wordpress.com

    Friday, June 15, 2012 4:11 PM
  • I tried it just now. Here are the steps.

    choose 'Customize form'

    The form opens in InfoPath

    I edit 'Name' back to say 'Title'

    I choose 'Quick Publish'

    and get the message 'Your form was published successfully'

    I click to 'add a new item'

    The form is still blank.

    Any other troubleshooting ideas?

    BTW, great post on wordpress posts. Just what I was looking for!

    Friday, June 15, 2012 6:56 PM
  • Hi empytea,

    By default, the form will be published to this URL:

    http://server/site/Lists/list name/Item/newifs.aspx

    Could you please go to this page and can you see the InfoPath New Form there?

    If no, please open this URL in another new browser tab > Click Site Action > Edit Page > Can you see the InfoPath Form Web Part? Perhaps someone set a target audience to it under Advance option in Edit Web Part.

    If the problem persists, please go to List Settings > Form Settings under General Settings > Select User the default SharePoint form and delete the InfoPath Form from the server > Click OK and re-customize the InfoPath form and publish it and see how it works.

    Because it should be a SharePoint 2010 question, I will move it to SharePoint 2010 forum later.

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Emir Liu

    TechNet Community Support

    • Marked as answer by Emir Liu Friday, June 22, 2012 3:28 AM
    • Unmarked as answer by empytea Thursday, July 5, 2012 8:25 PM
    Monday, June 18, 2012 11:18 AM
  • Any other hints or ideas?
    Thursday, July 5, 2012 8:26 PM
  • Hi!

    Basically such behavior (empty list form) means that some error occured during form parsing. You need to go SharePoint logs (14\Logs) to find out details on exception and then you can figure out what is wrong with your form. Just run iisrecent and look the most recent log file - exception must be there.

    Friday, July 6, 2012 6:19 AM
  • Hi,

    Did you find any answer to your problem because I got the same behaviour?

    No proposed solution has solved my problem... and it seems very difficult to find a solution on the web...

    Thank's in advance!

    Wednesday, September 19, 2012 2:40 PM
  • Hi,

    Got the same !! any idea ? any solutions ?

    Thank's in advance

    Thursday, September 19, 2013 12:29 PM
  • Hai

    I too had the same problem, but when i followed, List Settings > Form Settings under General Settings > Select User the default SharePoint form and delete the InfoPath Form from the server > Click OK. i could see the form and add item too. but when i re-customize the form It throws same problem again.

    Can i have solution for it.

    Thank you!

    Tuesday, June 24, 2014 10:55 AM
  • Please help me with a perplexing problem. I'm running SharePoint on a development box,  on one VM. Following are the steps I take to get the error:

    I create a new 'Custom List'

    I add a new item, works fine

    I open the list and choose 'Customize form'

    It opens in InfoPath

    I edit 'Title' to say 'Name'

    I choose 'Quick Publish'

    and get the message 'Your form was published successfully'

    I add a new item

    The form is blank, see below.

    What am i doing wrong?
    form after edit
    BTW, The url for the form is:

    http://xxxxxxxx:801/sites/XXX/_layouts/listform.aspx?PageType=8&ListId={4BE55E84-558E-439A-B2F1-FC5559359ABE}&RootFolder=

    and it is empty. I've confirmed the guid for the list is correct. I find no associated error messages in the logs. 

    Thanks in advance.

    I'm having the same problem too, when I customize the new item and edit item forms, it shows a blank page. when I edit the page once and exit the new item form, the form re appears and disappears again after some time.

    Is this a SharePoint 2013 bug? have anyone found an answer for this? If someone has a solution please respond.

    Cheers

    Shaiju


    shaiju


    Wednesday, October 7, 2015 10:53 AM
  • In your List Tools ribbon, go to the Form Web Parts dropdown. Check the New Form, Edit Form, and Display Form to see if the problem is with all or only one of them (Add New Item link renders the New Form). If you click New Form, it will show you the web parts used to render the form. You may need to delete and re-add the InfoPath Form web part. Also check for any Content Editor web parts that may link to or contain code that is interfering with the proper rendering of your form.
    Friday, February 12, 2016 2:48 PM
  • I had the same thing, but with a slight twist.  My form just would not load, and was generating a SharePoint 2013 Foundation error.  Which was useless.  My first thought was - "Huh? I am pretty good a this stuff, what went wrong?" 30 minutes and 15 googles later, I get here.  But, I finally stumbled across a solution that did to resolved this, because none of the other suggestions worked and I was unwilling to trash 5 hours of work:

    List Settings > Form settings >

    check "Use the default SharePoint form"

    do not check "Delete the InfoPath Form from the server"

    Click OK

    Verify that OOB default form is now loading for "add New Item". If so - great!

    Return to List Settings > Form settings

    Check "Customize the current form using Microsoft InfoPath"

    click Ok  InfoPath designer opens with the custom form (not the OOB) that would not load before.  Publish this form directly back to list using quick publish.

    Poof! InfoPath form now loads when "New Item" is clicked.

    Why this happened I have no clue about.  I have never run into this problem before.

    Hope my solution works for anyone else who runs into this.

    Thursday, July 7, 2016 8:47 PM