locked
Search is not working after a SSL cert change RRS feed

  • Question

  • We get the following message.  essentially what happened was.  We had a single domain certificate and search was working fine, we purchased a 5-domain certificate, we added mysite.doamin.com and docs.domain.com to the certificate and added it to the server.  Ever since then we have been getting this error. 

    When I browse externally or internally the certificate is fine, I don't receive any errors.  I have a feeling SP is using the old certificate?

    An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. ( Error from SharePoint site: WebExceptionStatus: TrustFailure The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.; SearchID = 9DC4EE21-6E34-41EB-8008-5D5C3E1B9FBB )

    Tuesday, June 11, 2013 12:23 AM

All replies

  • what if you open browser on the server where search crawler is running, and put the start address in search content source (find it in search administration site) into the browser address bar.
    Tuesday, June 11, 2013 3:00 AM
  • Can you please explain clearly what do you mean ?

    i have the same problem 

    thanks in advance

    • Proposed as answer by Dikov Friday, November 11, 2016 2:05 PM
    Tuesday, January 14, 2014 10:14 AM
  • You need to add the cert signer's root cert to the farm's cert store:

    Go to Central Administration >> Security >> Manage Trust

    And Click New

    And a name and specify the location for the certificate and Click Ok.

    After the search will work.


    Dawe

    • Proposed as answer by nbrattoliMVP Monday, July 6, 2015 4:42 PM
    Tuesday, January 14, 2014 3:31 PM
  • You can click the "Farm Administration" link on the search service application and then click the "Ignore SSL warnings" link, then set the checkbox.  That should also fix the issue.

    Chris Givens CEO, Architecting Connected Systems Blog Twitter

    • Proposed as answer by nbrattoliMVP Monday, July 6, 2015 4:42 PM
    Tuesday, January 14, 2014 3:58 PM
  • Did you ever determine the solution to this issue? I am facing the same issue, trying to crawl an external site requring form credentials, tried both solutions:1) CA - Farm Search Administration - Ignore SSL warnings: Set to Yes, and 2) Adding the certificates in the entire path, in CA - Security - Manage Trusts page.

    Chetan Garude, M.S. Computer Science, Microsoft Certified Professional

    Wednesday, November 5, 2014 6:09 PM
  • This worked for me. I also set the farm search admin to ignore ssl errors
    Monday, July 6, 2015 3:49 PM
  • We found just  rebooting the search servers works. I think this clears out a cache and enables things to start working again. 
    Monday, December 23, 2019 10:17 AM