locked
Spooler service crashes after applying xp spk3 RRS feed

  • Question

  • xp pro

    just applied spk3, and now the spooler won't stay running for more than a few seconds. 

    (this happened a while back when I originally tried to install spk3, and I wound up giving up and uninstalling, and doing system restore to get it back;  now I have an app that requires spk3).

    I've already gone through the recommended KBs on deleting the drivers from the spooler directories, and from the registry.  No printers are installed now.  Spooler still won't run.

    also ran a "fixit" tool, which didn't do anything either. 

    Event log entry (windows application event log).

    source 100

    event ID 1000

    Faulting application: spoolsv.exe, version 5.1.2600.6024, faulting module advapi32.dll, version 5.1.2600.5755, fault address 0x000070c9

    I've also disabled all items in the startup (msconfig) to see if something there was causing a conflict--no change.  spooler crashes on startup. 

    Saturday, April 14, 2012 11:06 PM

All replies

  • Hi,

    This problem can be related to virus infection or corrupted Spooler Registry.

    We can check the solutions in the articles below to see whether they can help in our situation.

    http://forums.techguy.org/windows-xp/998760-solved-print-spooler-keeps-stopping.html

    http://answers.microsoft.com/en-us/windows/forum/windows_xp-hardware/print-spooler-does-not-run-xp-sp3-x86/c712969e-2274-e011-8dfc-68b599b31bf5

    In the meantime, please check whether the Windows XP system is a preinstalled OEM version which can have problem after installing SP3.

    Regards

    Kevin

     


    TechNet Community Support

    Monday, April 16, 2012 7:51 AM
  • I ran a full scan with malwarebytes, and also Kaspersky rescue disk--both came back clean.

    Also did an sfc /scannow

    I also cleared the spooler directories and registry keys listed here: http://support.microsoft.com/kb/810894

    After checking your links, I checked the "providers" key, and only the default print providers are listed there.  I did notice the "printers" key, (hklm\system\currentcontrolset\control\print\printers) and saw that my print driver was in there, so I cleared that key as well.   (even though the ms kb article above did not mention that key).

    restarted the spooler, and it didn't crash.  I was able to re-install the printer, (downloaded the latest driver from the manufacturer--it is a Canon mp600), and print a test page.  Thought I had it licked...but then I re-booted, logged in as a different user, and the spooler crashed again with the same error.  

    It isn't an OEM install. generic machine--intel motherboard/processor, manually installed.

    (fwiw, the printer on the affected machine was originally shared;  I have another xp machine that is probably an oem install, has spk3, and has the same canon driver installed, which was printing to this printer through the share, so the driver should work w/ xpspk3).

    Monday, April 16, 2012 7:16 PM
  • Hi,

    I suggest we create a new administrative user account and test the issue again.

    Does the problem persist? 

    If not, the problem can be related to that specific user account.

    Regards

    Kevin


    TechNet Community Support

    Tuesday, April 17, 2012 7:36 AM
  • I repeated the previous steps, created a new administrative account; tested on all 3 accounts. 

    No change;  print spooler still crashes with the same error. 

    Thursday, April 19, 2012 12:23 PM
  • Hi,

    In this situation, we can try performing repair install of Windows XP as a test.

    http://support.microsoft.com/kb/978788

    Regards

    Kevin


    TechNet Community Support

    Friday, April 20, 2012 5:51 AM
  • Well, I might as well just back it up and blow it away and do a complete reinstall, in that case. 

    It would be nice if there were some way to debug spoolsv.exe and advapi32.dll to see exactly what it is that is making them choke. 

    Saturday, April 21, 2012 12:40 PM