none
Hyper-V Black screen when starting a Virtual Machine

    Question

  • Hi there,

    I've recently started using hyper-v for my school, but I've run into a problem when starting my vm.

    I'm using Windows 10, and on hyper-v I'm trying to run Windows Server 2012.

    As soon as i start my virtual machine the screen basically freezes, i can see that windows server is definitely running in the small preview window but i have to way to clearly see what i'm doing because the screen is just black,

    When i turn on full-screen mode i have no other choice but to Alt-Ctrl-Delete myself out of it because it gets stuck there,

    Any suggestions what i could do to fix this?..
    Help will be much appreciated :)

    Thanks in advance, 
    Jake

    Monday, March 6, 2017 11:46 PM

All replies

  • First thing is to ensure your host system supports all the hardware requirements for running Hyper-V - hardware virtualization and data execution prevention enabled in the BIOS and SLAT support.  Once that is verified, ensure that you have the latest drivers/firmware/BIOS updates for your host system.

    . : | : . : | : . tim

    Tuesday, March 7, 2017 2:46 PM
  • Hi Jake,

    >>i can see that windows server is definitely running in the small preview window

    Have you tried to enable and use  "enhanced session mode " for that VM ?

     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 7, 2017 3:36 PM
    Moderator