none
PXE boot in gen 2 machine doesn't work since Hyper-V version 10.0.15063 RRS feed

  • Question

  • Hi

    I use a Hyper-V machine for a build and capture tasksequence with Config Manager. PXE boot worked perfectly until I upgraded my Hyper-V Host to Windows 10 1703. After the upgrade PXE boot doesn't work anymore. I get "DHCP failed". I tried different settings, deleted and recreated the virtual switch, disabled and reenabled the Hyper-V role, and tried with another fresh installed machine with another network card. Physical machines can PXE boot in the same subnet without problems. The only workaround for Hyper-V I found was to create a Gen 1 machine and to add a legacy network adapter. 

    Thanks for any help.
    Christian


    Thursday, May 11, 2017 8:55 AM

All replies

  • Hi Christin,

    You could try to turn off secure boot.

    Also, check the NIC in the virtual switch, make sure you are using the correct NIC and it has the correct configuration. From my search, some user fix similar issue by removing the DHCP scope and recreating it, you could have a try.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 12, 2017 2:45 AM
    Moderator
  • Hi Teemo

    Thanks for your help. NIC in virtual switch looks ok. Turn off secure boot didn't help. At the Moment I can't remove the DHCP scope because it's a scope in production. But I could try it in another scope or recreate it during the weekend. 

    But that sounds like it's not a bug in 1703 and there are systems with 1703 with working PXE boot. So I have to dig further (otherwise I just would wait for a patch). 

    Regards, Christian

    Friday, May 12, 2017 7:52 AM
  • Hi

    Starting a virtual machine creates a lease entry at the DHCP server. In SMSPXE.log on the SCCM Server there's also an entry: "MAC Address, GUID: found optional advertisement ...". So it looks like DHCP and SCCM are answering correct to the virtual machine, but the virtual machine couldn't handle the answers. 

    Regards, Christian

    Monday, May 15, 2017 8:57 AM
  • Yes, Christian, your idea is reasonable.

    I search one and find out this thread, the solution here worth trying.

    [SCCM 2012] Not PXE booting

    http://www.edugeek.net/forums/o-s-deployment/118049-not-pxe-booting-2.html

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 16, 2017 7:34 AM
    Moderator
  • Hi Teemo

    Thanks for your suggestion. I tried to untick "Enabled command Support" but that didn't work either.

    Regards, Christian

    Tuesday, May 16, 2017 7:58 PM
  • Hi,

    Has anyone found a solution to this issue? It is affecting several of my colleagues and has no difference on whether we upgraded from 1607 or did a fresh install. None of the suggested fixes have resolved the problem for us.

    Thanks,

    James.

    Monday, June 12, 2017 3:21 PM
  • I'm having the same problem. Tried uninstalling and reinstalling Hyper-v, did all windows updates. Still not working. 
    Wednesday, June 21, 2017 4:39 PM
  • It works in the same subnet as the servers.

    We have IP helper addresses at the switch and not set DHCP Options 66 and 67 what is the recommended way (see also https://deploymentbunny.com/2016/02/29/osd-how-make-pxe-work-in-configmgr-osd-mdt-and-wds-work-perfectly-fine-stop-using-dhcp-option-66-67/).

    Like said before, physical machines can PXE boot in other subnets than the servers without problems, and Hyper-V machines before 1703 could also. On the server side everything looks ok. There are entries in SMSPXE.log.

    So it looks like there is a bug in Hyper-V. My workaround is to set the servers vlan ID in Hyper-V. Do not forget to configure the port of your physical machine at the switch.

    Friday, June 23, 2017 2:34 PM
  • I had the same issue. We solved it by disabling jumbo frames in out WDS nic. 
    Friday, August 11, 2017 10:19 AM
  • Same Problem with Windows 10 1803 here. Can't believe this problem still exists -.- how could M$ leave this bug ignored for more than a year?

    Setup Gen2 Server 2016 VM with WDS and MDT and DHCP, PXE boot with Gen1 VM Client without problems, PXE boot with Gen2 VM Client impossible.

    Has anyone a working solution for this?

    Wednesday, July 4, 2018 4:24 PM
  • Same issue here on a 1703 build.

    It worked fine when we had another test DP configured for PXE on the same switch as my Hyper-V workstation.  We removed that and it doesn't work to the server but physical machines do.

    PXE log shows offer received but then a few retries and nothing.  Failes with DHCP failed on the VM.
    Gen2/Secure boot.


    nick

    Friday, July 13, 2018 5:30 PM
  • Hey Tried this many times with 1 virtual CPU on the WDS VM and it works fine. Adding one more virtual CPU on the WDS VM don’t work anymore. 1 virtual CPU = OK 2 virtual CPUs = NOT OK Maybe an interaction with NUMA or so. Anyway. The main point ist that it works fine for us. Best regards Alex
    Friday, September 28, 2018 11:05 AM
  • you should use the UEFI PXE image within boot Option 67
    Option 67: SMSBoot\x64\wdsmgfw.efi
    Afterwards Hyper-V Gen2 VMs and UEFI Clients will be able to boot from PXE, but BIOS based clients no longer.
    Sunday, February 17, 2019 9:00 AM
  • you should use the UEFI PXE image within boot Option 67
    Option 67: SMSBoot\x64\wdsmgfw.efi
    Afterwards Hyper-V Gen2 VMs and UEFI Clients will be able to boot from PXE, but BIOS based clients no longer.

    Thanks HamidReza Molaei this worked for me.  However, I believe the correct default path would be: \boot\x64\wdsmgfw.efi

    • Proposed as answer by JAllende Thursday, April 18, 2019 11:12 PM
    Thursday, April 18, 2019 11:11 PM