none
IE11 constantly needing reset RRS feed

  • Question

  • Hello. I have an install of win 8.1. IE 11 is frequently going into a weird status, and will then not download pictures, or allow file downloads, and doesn't display most web pages correctly. Not sure if it is attempting to go into a high security mode, but some pages will give a "javascript needs enabled" error.

    I have found that if I go into IE settings - advanced and do a basic reset, IE will then work normally for a while, until something happens

    I have "protected Mode" enabled through group policy, would this be causing this behavior? and how would I best get this corrected.

    Tuesday, December 3, 2013 5:52 PM

All replies

  • Hi,

    It sounds like your anti-virus product...

    Post consumer questions about IE to http://answers.microsoft.com (Help>Online Support menu from IE).

    or

    Contact your company help desk or System Administrators.

    Regards.


    Rob^_^

    Wednesday, December 4, 2013 12:05 AM
  • Hi,

    For the "javascript needs enabled" error,  Please open IE, click Tools>Internet Options>Secure>Custom level>scroll down to “Scripting", in the "Active Scripting" item select "Enable" refresh the webpage.

    For other problems, pleaes try:

    1. Test IE with no add-ons mode.
    2. As described in the first reply, you can temporarily turn off anti-virus software for a test.
    3. I also suspect that some software installed in your system may conflict with IE, to eliminate this, please test this IE in clean boot mode:

    How to perform a clean boot in Windows 8.1, Windows 8, Windows 7, or Windows Vista

    http://support.microsoft.com/kb/929135/en-us

    Regards,

    Yolanda


    Yolanda
    TechNet Community Support

    Wednesday, December 4, 2013 8:04 AM
    Moderator
  • THanks for the tips,  here is what I have found so far...

    @ IECUstomizer -   I wondered about AV as part of the problem..    so I went and uninstalled the AV (Vipre) for half a day,  still had the same issues.  no change and didn't get worse or better when I re-installed the AV.  it's remotely possible something did not get completely uninstalled, and I do have a ticket open with them on a separate (I think) issue tied to their software firewall.

    @ Yolanda  -  I have tried that directly with mixed results, and I have gone into Group policy and blatantly enabled many of those specific settings.  ie - java scripting etc... however, even if I do go and change it, it gets set back to disabled after a while.

    I am still trying to figure out the WHY of it.   as I mentioned.. if I go IE options /  advanced  / and click the reset button, it makes everything work fine ... for a while, then it seems to randomly break, needs reset, then rinse, and repeat the cycle...

    Right now I'm attempting to see if Win 8.1 and ie11 can be deployed and so far.. win 8.1 rocks.. ie11 fails completely.

    Wednesday, December 4, 2013 2:21 PM
  • another followup. I tried following up on my group policy theory, so I set the default security setting template to just medium. once that took affect I had to "reset" IE one more time, but since then it has worked "mostly" without problem since. I say mostly, as we use a single sign on package with biometrics for handling passwords, and that system is unable to recognize password fields in IE until the "reset" trick is pulled again...

    I have a tech support question in to the biometric software vendor to see if they have any suggestions.

    Thursday, December 5, 2013 2:24 PM
  • Hi,

    From your description, it seems that the biometric Authentication Service might be related with this issue, have you tried to stop the service, then test IE again?(In “Services”, stop “biometric Authentication Service” )

    And have you tried clean boot as I mentioned in my pervious reply? What is the result?  (a clean boot can temporarily stop basic system processes, utility applications, and other software that has been previously installed)

    Since IE can work for a while after resetting, When this issue occurred again, I suggest you run the Task Manager to view the CPU, memory or network, check if there’re some abnormal process.

    You can also use the Process Explorer to analyze the process during the period.

    http://technet.microsoft.com/en-in/sysinternals/bb896653.aspx

    (Close unneeded programs to reduce the workload)

    Regards,

    Yolanda


    Yolanda
    TechNet Community Support

    Monday, December 9, 2013 8:35 AM
    Moderator
  • some pages will give a "javascript needs enabled" error.

    Just this part sounds like a possible User-Agent string problem.  Have you tried to find a compatibility fix?  E.g. use Developer Tools to try to find a better combination of Document mode and User-Agent string that the site would understand better?

    I have found that if I go into IE settings - advanced and do a basic reset, IE will then work normally for a while, until something happens

    This may be what Rob is referring to.  So, what is happening after "a while" that changes your symptom?  Are you testing the same sites that cause the problem symptom first?



    Robert Aldwinckle
    ---

    Monday, December 9, 2013 1:57 PM
    Answerer
  • current status...    Just received a notice from the biometric software company stating that IE11 is currently not fully compatible...   and based on current issues..   I'm thinking that software is a strong contributor to my issues... if not the problem itself...

    So far, I have pushed settings for internet zone to be at medium security via group policy, and stability has improved dramatically.   I'm still getting security warnings, despite clicking the "do not show again" option.. so something is resetting things without telling me, but 90% of problems are calming down.

    I'll try to post back when the biometric vendor becomes fully compatible and let you know if that fixed the remaining issues as well.

    Wednesday, December 11, 2013 4:40 PM
  • I really am still working on this, if anyone even cares.   

    So far, what I have found is it doesn't seem to be an issue with either my Antivirus, or the biometric software, or at least not directly.

    For what it's worth.. I did do a complete machine refresh, brand new upgrade to win 8.1,  without any other software installed during that process, and then slowly added in the GPO I finally came up with..  websites were still a problem requiring reset to work, not as often as before, but still needing it.... so I think I have fairly removed alternate software as a cause.

    What has worked to get and keep most web pages working was to setup a GPO that added websites I need to view to the local or trusted zone (depending on the location of the site).  Then in the applical security setting for that zone, I have turned off protected mode.  I hesitate to turn off protected mode on the internet zone, so some websites still have issues, and require IE to be reset to get them working on occasion, but the sites I have added to the trusted zone and run in non-protected mode have not had any issues since then.

    Hopefully this helps someone else... but be careful what you put in the trusted zone if you do this...

    Tuesday, January 21, 2014 10:34 PM
  • some websites still have issues, and require IE to be reset to get them working on occasion

    If you still want to try to understand this aspect of your symptom, which suggests something is changing the registry relatively long after you do RIES, you could try using ProcMon, e.g. filtering on Operation Is RegSetValue. 

    You also have two cases that you could compare traces for their essential differences, e.g. to compare the different logic flow between Trusted and Protected cases, so hopefully find some specific detail which makes two otherwise identical traces diverge and then look for more detail which led up to that divergence.  This analysis can actually be less daunting than it at first sounds by using a high level (coarse) filter such as just Process and Thread.  E.g. doing that may show that a particular module is only being used in the problem case, so that may give you sufficient clue about what next to try isolating from your problem description.

     

    Good luck



    Robert Aldwinckle
    ---

    Wednesday, January 22, 2014 9:03 PM
    Answerer