locked
Security restrictions deny the ability to click url links in Exel and Outlook (2003) RRS feed

  • Question

  • OS is Vista pre rc1 eval copy bld 5536 with all updates as of today (01sep2006), office is 2003pro with sp2 and all updates as of today

    Case 1:  An email with a link to our university dept. weekly pdf newsletter on our univ webserver

    Case 2: Exel book with cells with links to (relevant) webpages (for the section\data\samples\methods and such used to gather the data on each sheet in the book)

    Error msg for all is "The operation has been canceled due to restrictions in effect on this computer.  Please contatct your system admininstrator"

    Despite checking through all from local policy manager to technet i have been unable to solve this issue, do anyone have any idea how to allow me to actually click these links and open IE or whatever browser\3d party application that is assosiated with the link\url ?

    edit:  Changed Exel to always run with elevated user privileges as admin, but it still will not allow me to click on a http://link.to.whatever and launch IE...

    Friday, September 1, 2006 8:31 PM

Answers

  • Found a solution- I'm having the same issue using RC1 (5600).  The problem occurred AFTER I install FireFox and set it as my default browser.  You have to open the "Default Programs" application from the Start Menu, and then set Internet Explorer as the default browser.  Close IE and Outlook, then try clicking an email link again, it should work now.  If anyone at MS is listening- not everyone uses IE- it seems if you install a non-ie browser several things throughout the sytem go to hell.
    Saturday, September 9, 2006 4:11 PM
  • I think Firefox changes something in the OpenWithList key within HKRC\.htm...possibly something related to DDE.  Does anyone have this problem who has not installed Firefox either before or after Vista?

     

    Tuesday, September 12, 2006 11:02 AM
  • Ok solved the issue, do as follows

    start->settings->control panel->programs->default programs->set program access and computer defaults-> click yes on allow->select custom checkbox\arrow and then under the custom click on the circle for IE and press OK

    I rebooted afterwards but not sure if this is needed, anyhow it now works again and you can click on links in outloog\office programs

    But this is obviously not the best solution, and is an issue that should be checked by the vista team before its released, because you can be sure there are many people that will have other tastes as to what is their default browser

     

    Borge

    MCP\MCSE 

    Tuesday, September 12, 2006 4:46 PM

All replies

  • I have now searched though whatever I thought as possible or impossible solutions and FAQ's, and there is NO hint as to how to change the restrictions and allow me to click on weblinks (in outlook emails or other of the Office 2003 products) and automatically launch a browser.

    Just this single annoyance is enough to make me consider going back to XP, having to copy each url into IE\Firefox is not an option I can live with over time..

    Any help on this issue would be greatly appreciated!  :-)

    best wishes
    borkrist (an almost happy Vista user)
    Thursday, September 7, 2006 1:05 PM
  • Using RC1 and this issue is now resolved and clicking on links within the Office2003 family product launches the appropriate program :-)

    edit and update as of 9th sept:

    ARGH: Ok it's back,..I can not reproduce excactly when or how but a clean rc1 5600 with clean Office2003 pro complete install,...

    I can not remember if I had updated Vista before installing Office, but most likely..

    All contacts\emails\calendars imported from old pst file, and pop3 accounts set up and checked, new email with url link to university newsletter opened IE, asked for adobe reader, got and installed and all worked

    Now,...if this issue reappeared after installing the first 3 major office2003 servicepack updates or after the post sp updates i can not rightly remember but i belive the issue is related to one of the latter security updates to office,..

    Any other have hints as to how to resolve this...?

    Friday, September 8, 2006 1:44 PM
  • Having same issue with RC1 5600

    hum everything was fine for a few days but I'm having the same issues now ...

     

     

    anyone can help ?

    Friday, September 8, 2006 3:15 PM
  • Found a solution- I'm having the same issue using RC1 (5600).  The problem occurred AFTER I install FireFox and set it as my default browser.  You have to open the "Default Programs" application from the Start Menu, and then set Internet Explorer as the default browser.  Close IE and Outlook, then try clicking an email link again, it should work now.  If anyone at MS is listening- not everyone uses IE- it seems if you install a non-ie browser several things throughout the sytem go to hell.
    Saturday, September 9, 2006 4:11 PM
  • Sigh,...you have described JUST the setup I normally use, and yes,  I had installed latest version of Firefox and set it as the default browser..

    "Fortunately" I managed to mess up trying assorted drivers and XP software and now have a clean system again where i can safely update all programs :-)

    Good work!

    borkrist

    MCP/MCSE

    Saturday, September 9, 2006 5:14 PM
  • i'm running office 2007 beta 2 in vista rc1 (5600) x64... and the above fix didn't help. i still can't click on things in outlook. also, onenote is prompting me to download a search update, but gives the same error when i try.

    any other suggestions? TIA
    Monday, September 11, 2006 6:39 PM
  • I think Firefox changes something in the OpenWithList key within HKRC\.htm...possibly something related to DDE.  Does anyone have this problem who has not installed Firefox either before or after Vista?

     

    Tuesday, September 12, 2006 11:02 AM
  • Josh, this is worthy of a bug report. I do not think that Microsoft "listens" to these posts, but part of the beta program is the ability to submit bug reports. The issue you are posting on is important and I encourage you to submit it.

    Tuesday, September 12, 2006 3:01 PM
  • Installed Firefox 1.5.0.6 again, went through and reset IE as default, and also selected the 3 other fileformats that firefox registers and selected IE as default for those, so now firefox has NO default file assosiations listed, and still the darn anoying bug reappeared...sigh

    This is without doubt severly grinding on my nerves :-)

    Anyone able to run firefox and office on vista without this happening?

    Borge

    Tuesday, September 12, 2006 4:35 PM
  •  Matthew Vandergrift wrote:

    I think Firefox changes something in the OpenWithList key within HKRC\.htm...possibly something related to DDE.

    Yes, that appears to be the issue.  I had the same problem.  To resolve it, (in addition to restoring IE as the default) I had to edit the registry keys for HKCR\.htm and HKCR\.html - the default value of each was set to FirefoxHTML.  Changing them to htmlfile did the trick after a restart of IE/Outlook.  I'm sure there are other filetypes that will need a similar tweak.

    Tuesday, September 12, 2006 4:35 PM
  • Ok solved the issue, do as follows

    start->settings->control panel->programs->default programs->set program access and computer defaults-> click yes on allow->select custom checkbox\arrow and then under the custom click on the circle for IE and press OK

    I rebooted afterwards but not sure if this is needed, anyhow it now works again and you can click on links in outloog\office programs

    But this is obviously not the best solution, and is an issue that should be checked by the vista team before its released, because you can be sure there are many people that will have other tastes as to what is their default browser

     

    Borge

    MCP\MCSE 

    Tuesday, September 12, 2006 4:46 PM
  •  ericmatz wrote:
     Matthew Vandergrift wrote:

    I think Firefox changes something in the OpenWithList key within HKRC\.htm...possibly something related to DDE.

    Yes, that appears to be the issue.  I had the same problem.  To resolve it, (in addition to restoring IE as the default) I had to edit the registry keys for HKCR\.htm and HKCR\.html - the default value of each was set to FirefoxHTML.  Changing them to htmlfile did the trick after a restart of IE/Outlook.  I'm sure there are other filetypes that will need a similar tweak.

    Thank you both.  I spent way too much time searching for a solution to this problem.  I, also, am running Vista RC1 and Office 2007 beta 2.  I had installed FireFox, but it was not my default browser.  I removed all the default file types from FireFox and reassigned them to IE7 even though three of the ones listed for FireFox were not listed for IE.  I don't know if this was necessary or not.  I checked HKRC\.htm and HKRC\.html and changed them from FireFoxHTML to htmlfile as suggested above and now my links in Outlook 2007 emails are clickable.

    Thank you again.

    David Megnin, MCP

    Sunday, September 17, 2006 1:33 PM
  •  ericmatz wrote:
     Matthew Vandergrift wrote:

    I think Firefox changes something in the OpenWithList key within HKRC\.htm...possibly something related to DDE.

    Yes, that appears to be the issue.  I had the same problem.  To resolve it, (in addition to restoring IE as the default) I had to edit the registry keys for HKCR\.htm and HKCR\.html - the default value of each was set to FirefoxHTML.  Changing them to htmlfile did the trick after a restart of IE/Outlook.  I'm sure there are other filetypes that will need a similar tweak.

    Thank you both.  I spent way too much time searching for a solution to this problem.  I, also, am running Vista RC1 and Office 2007 beta 2.  I had installed FireFox, but it was not my default browser.  I removed all the default file types from FireFox and reassigned them to IE7 even though three of the ones listed for FireFox were not listed for IE.  I don't know if this was necessary or not.  I checked HKRC\.htm and HKRC\.html and changed them from FireFoxHTML to htmlfile as suggested above and now my links in Outlook 2007 emails are clickable.

    Thank you again.

    David Megnin, MCP

    Sunday, September 17, 2006 1:53 PM
  •  borkrist wrote:

    Ok solved the issue, do as follows

    start->settings->control panel->programs->default programs->set program access and computer defaults-> click yes on allow->select custom checkbox\arrow and then under the custom click on the circle for IE and press OK

    I rebooted afterwards but not sure if this is needed, anyhow it now works again and you can click on links in outloog\office programs

    But this is obviously not the best solution, and is an issue that should be checked by the vista team before its released, because you can be sure there are many people that will have other tastes as to what is their default browser

     

    Borge

    MCP\MCSE 

    I would suggest you file a bug report and include detail steps as far as possible to help MS to identify/reproduce the incident for a possible fix.

    Good luck and thanks for sharing the workaround!

    Sunday, September 17, 2006 8:58 PM
  • Im sure i might be stating the obvious, but the workaround works a treat for both IE and Firefox.
    You dont need to have IE as your default when you click a link in Office 07.

    Sorry if this was obvious, just trying to be helpful.
    Monday, September 18, 2006 9:15 PM
  • Suffering from the same problems with Vista and Outlook 2003 I followed the steps you provided.  It did not work for me.  I also use Firefox (or would like to).  I tried downloading Outlook 2007 (trial version) in hopes it would correct the problem.  It did not.  I would like to mention that there was a period that IE7 did not work for me. Everything else worked fine.  Soon after I got IE7 working again this hyper link problem started.
    Thursday, July 19, 2007 9:30 PM
  • This worked for me, too, though I am using Windows XP Pro.  Thanks so much for this fix, Matthew and ericmatz!

    Monday, September 17, 2007 4:15 PM
  • I encountered this problem with a Vista Home computer which had settings migrated from an XP Pro machine (the XP machine had Firefox installed, but the Vista machine did not).

     

    When looking at the registry, though, the default in .htm and .html was blank.  Putting 'htmlfile' in those values corrected the problem, without doing anything else.

     

    Sunday, March 2, 2008 8:24 PM
  • I installed Firefox Beta 3 and then I started having the problem with accessing links from Outlook 2003.  I've uninstalled Firefox Beta 3, and reset by default as Internet Explorer using the default programs feature in Vista.  Those things didn't work. 

     

     I searched the directory but could not find HKRC\.htm.  Can someone tell me where or how to find it.

     

    I operate on Vista Ultimate. 

     

    Can anybody help.

     

    Thanks.

     

    Tuesday, May 6, 2008 8:57 PM
  • I installed Firefox Beta 3 and then I started having the problem with accessing links from Outlook 2003.  I've uninstalled Firefox Beta 3, and reset by default as Internet Explorer using the default programs feature in Vista.  Those things didn't work. 

     

     I searched the directory but could not find HKRC\.htm.  Can someone tell me where or how to find it.

     

    I operate on Vista Ultimate. 

     

    Can anybody help.

     

    Thanks.

    Tuesday, May 6, 2008 10:27 PM