locked
Cisco Amp Protect deployment error RRS feed

  • Question

  • I tried to Cisco Amp Protect EXE file to workstations through SCCM console, but I keep getting error said "Another version of this product is already installed. Installation of version can't continue. To configure or remove the existing version of this product, use Add/Remove programs on the Control Panel. 

    I already tried to delete Cisco Amp Protect application and deployment, and removed the software. After that I recreated new Cisco Amp Protect application, and then deployed to another different collection, but I still got the same error. 

    Any idea what I should do for next? Thanks in advance!

    Friday, February 8, 2019 4:40 PM

Answers

All replies

  • What happens when you manually install the product? Really this is a Cisco problem as such you should review the Cisco logs and/or ask the question within a Cisco forum 

    Garth Jones

    Blog: https://www.enhansoft.com/blog Old Blog: https://sccmug.ca/

    Twitter: @GarthMJ Book: System Center Configuration Manager Reporting Unleashed

    • Proposed as answer by Richard.Knight Friday, February 8, 2019 6:41 PM
    • Marked as answer by sju2402 Tuesday, February 12, 2019 4:45 PM
    Friday, February 8, 2019 4:58 PM
  • According sccm log, that application deployed to my workstation, and I can manual installed without problem.

    I also can see it from Programs and Features under Control Panel, which means it did installed, but my SCCM console still shows the same error when I checked Deployment status. 

    It looks like the software installed, but SCCM didn't know and try to install again. Then SCCM found out it installed so gave me that another version already exists error. 

    When I checked AppEnforce log on workstation, it says " Unmatched exit code (1638) is considered an execution failure" I guess SCCM didn't see exit code 0 so it considers that installation failed. Does it make sense? 

    • Edited by sju2402 Friday, February 8, 2019 10:41 PM updated info
    Friday, February 8, 2019 10:28 PM
  • Error 1638 = 

    Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.

    So.... this is coming from the AMP install and not from SCCM you need to look at the AMP logs. 


    Garth Jones

    Blog: https://www.enhansoft.com/blog Old Blog: https://sccmug.ca/

    Twitter: @GarthMJ Book: System Center Configuration Manager Reporting Unleashed

    Friday, February 8, 2019 10:55 PM
  • Dear Sir,

    Just checking in to see if there are any updates. Has this issue been solved?

    Please feel free to feedback and if the reply is helpful, please kindly click “Mark as answer”. It would make the reply to the top and easier to be found for other people who has the similar question.


    Best regards,
    Larry

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 11, 2019 8:10 AM