none
VSS Timing Out When Production Checkpoint Ran RRS feed

  • Question

  • When taking a production checkpoint in Hyper-V it looks like it completes, but if I pull up vssadmin it shows the VSS writers as timed out. However Hyper-V looks like it completed the production checkpoint. I need to understand why VSS is timing out on 4-5 VMs but not others. 

    Here is a screenshot:

    Friday, July 19, 2019 9:10 PM

All replies

  • Hi,

    >> However Hyper-V looks like it completed the production checkpoint.

    Can you upload the screenshot of your checkpoint?

    Please check if there is any error message in Event viewer.

    Path:Microsoft-Windows-Hyper-V-Worker

    Do you have any other backup tasks when you created production checkpoint?

    >> I need to understand why VSS is timing out on 4-5 VMs but not others.

    Do you mean that VSS writers only time out in  4-5 VMs, not all the VMs? Please install the latest update for your issue VMs.

    Regards,

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 22, 2019 7:10 AM
    Moderator
  • Mark, 
    This is the checkpoint message:

    We use Veeam to backup but since it was failing due to these VSS messages, I needed to go further back a layer before Veeam to troubleshoot what is causing the VSS time-out messages. If I can figure out why VSS is timing out then that should correct the other issues. 

    I do not see any error messages in the "Path:Microsoft-Windows-Hyper-V-Worker" event logs.

    All of the VMs already have their most current updates. That is why this is weird, there is nothing really different between them. They all vary between W2K12R2, W2K16 and W2K19

    Monday, July 22, 2019 4:57 PM
  • Try to merge all the checkpoints first and stop the all Veeam backup task. Then try to create production checkpoint again in Hyper-V settings.

    Cheers,

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 23, 2019 1:25 AM
    Moderator
  • As stated, I have done this. That is what the previous post was. No checkpoints and no Veeam tasks running. Any other suggestions?
    Tuesday, July 23, 2019 1:54 PM
  • try to uninstall Veeam first and try to create checkpoint again.

    In the meanwhile, please involve the Veeam supporter to your issue.

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 24, 2019 1:15 AM
    Moderator
  • Veeam is not installed. You are missing the point here. Forget I even mentioned Veeam. I need to understand why when a Checkpoint is ran the VSS writers say time out. 

    Veeam support is already involved, they are the ones that said I need to contact Microsoft since this is a VSS issue during a checkpoint. 

    Wednesday, July 24, 2019 4:27 PM