locked
fully updated capture image - how to? RRS feed

  • Question

  • Hi all

    I am using 1 task sequence to build & capture my reference image. What I want is to deploy win7, ie9 & office 2013 with my ref. image for sccm 2012.

    also.. I want the image to be fully updated when it is captured.

    When I run the TS I have 1 step for pre application win Update and 1 for post-application .

    but after the capture and when I use the wim file.. it still finds a lot more updates.. 

    can I somehow make sure it updates the reference image completely? 

    So I use MDT to build the reference image on a VDI and then deploy the wim with SCCM.

    In SCCM I can do multiple steps of windows update by using the command:

    WMIC /namespace:\\root\ccm path sms_client CALL TriggerSchedule "{00000000-0000-0000-0000-000000000113}" /NOINTERACTIVE

    Which resets the windows update "cache" or whatever you want to call it.. it clears the update-list from the local machine and then searches again.

    but how can I do something similar in MDT? 


    Kindest regards, Martin

    Thursday, September 25, 2014 12:32 PM

Answers

  • I may have caught a break..

    in my cs.ini file I had:

    WSUSServer=http://wsus1.site.dk:8530

    I tried changing to:

    WSUSServer=http://wsus1.site.dk

    this seems to have done the trick.. Maybe..


    Kindest regards, Martin

    • Marked as answer by Martin Rask Friday, September 26, 2014 10:41 AM
    Friday, September 26, 2014 8:31 AM

All replies

  • It's possible that if your WSUS sources are not up to date between your LiteTouch envornment and your SCCM environment, you might get some differences. It's also expected that if the image is more than a week old, you should see newer updates made available from Microsoft.

    Each time when ZTIWindowsUpdate.wsf is done running, it will re-run again until Windows Update or WSUS returns no more updates. So I'm not sure what updates you are referring to that the Windows Update Agent would not install.

    What specifically is not getting installed here?


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    • Proposed as answer by Keith GarnerMVP Thursday, September 25, 2014 6:45 PM
    • Unproposed as answer by Martin Rask Friday, September 26, 2014 7:22 AM
    Thursday, September 25, 2014 6:45 PM
  • Hi Keith.

    Thank you for your response. 

    I created the image yesterday and tested today.. and it is adding lots & lots of updates.. I seriously don't believe that wsus just happened to find 1Gb worth of updates from yesterday till today. 

    It is updating windows 7 & office 2013 mainly. 

    as I understand win update will run and keep a list/cache which it then uses the next time.. 

    I am referring to what I read here:

    http://www.david-obrien.net/2013/01/23/trigger-software-updates-rescan-in-configuration-manager-2012-sp1/

    during the Task Sequence I run several updates/reboot/clear cache and during the first 3 update runs it finds new updates..


    Kindest regards, Martin

    Friday, September 26, 2014 7:26 AM
  • I may have caught a break..

    in my cs.ini file I had:

    WSUSServer=http://wsus1.site.dk:8530

    I tried changing to:

    WSUSServer=http://wsus1.site.dk

    this seems to have done the trick.. Maybe..


    Kindest regards, Martin

    • Marked as answer by Martin Rask Friday, September 26, 2014 10:41 AM
    Friday, September 26, 2014 8:31 AM