none
How to build custom attributes to enabling exchange 2007 provisioning RRS feed

  • Question

  • Hi,

    Since I'm newbie with this product  , would someone kindly explain to me step-by-step how to setup e.g. mailDatabase extended attribute. I'd really like to enable exchange 2007 provisioning to FIM RC1, but I can't find any detailed instructions.



    I'll try to follow this thread: http://www.wapshere.com/missmiis/ilm2-rc0-provisioning-exchange-2007-users


    I've been managed to create attributes and bind them, but after creation, but custom attributes bolded below are still not available.

    and I'm stuck with this attribute flow:

    homeMDB “CN=”
    + mailDatabase
    + “,CN=”
    + mailStorageGroup
    + “,CN=InformationStore,CN=”
    + mailServer
    + “,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,
    CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=mydomain,DC=



    Some kind of "for-dummies" -instructions would be appreciated.

    Friday, October 16, 2009 10:40 AM

Answers

  • Did you add the attributes in the metaverse? When you create those sync rules it's actually listing attributes from the metaverse, not from the FIM portal schema.

    Carol

    http://www.wapshere.com/missmiis
    Tuesday, October 27, 2009 9:15 AM
  • Also, when you created new attributes in ILM, please make sure to do iisreset and then a refresh schema in Sync. IISReset will make the FIM attribute shown in UI if it is not showing. Refresh schema will bring these attribute to Sync Engine. You may still need to add these attributes in MV, if you don't see them in MV. That is a separate process.

    Elisa Zhang
    Monday, November 9, 2009 8:58 PM

All replies

  • Hello,

    as I'm guily of that post....

    You are supposed to replace those values with ones relevant to your site, or create custom attributes and populate them with the relevant names (see the FIM document on changing the schema). 

    If you are just trying to do a test then the simplest thing is to create a user in your AD with a mailbox, and then copy the entire homeMDB value using ADSIedit. Then just use that exact string for homeMDB here.

    I haven't checked through that post yet for RC1, though I think it is still much the same.

    Carol

    http://www.wapshere.com/missmiis
    Friday, October 16, 2009 12:23 PM
  • I saw saw your question on my blog which made me come back and read this properly. You said you created the custom attributes and bound them - was that to the User object type? You say they are not available - if you open a user's properties, and then click on Advanced View, can you see the new attributes that you bound?

    In RC1 you need to modify the default MPRs so that new attributes are usable.  I gave both Administrators and the Synchronization account access to All Attributes in the following MPRs:

    Administration: Administrators can read and update users
    Synchronization: Synchronization account controls users it synchronizes

    Carol

    http://www.wapshere.com/missmiis
    • Marked as answer by Snendis Tuesday, October 20, 2009 8:12 AM
    • Unmarked as answer by Snendis Tuesday, October 20, 2009 10:38 AM
    Friday, October 16, 2009 12:56 PM
  • Hello and thanks for your help so far, but I have one issue.

    I have created and bound those attributes (bound as UserObjectType) but I'm not able to see them when I'm creating a new synchronization rule. In user's profile->Extended attributes-tab attributes are visible

    Any ideas?
    Tuesday, October 20, 2009 8:12 AM
  • Did you add the attributes in the metaverse? When you create those sync rules it's actually listing attributes from the metaverse, not from the FIM portal schema.

    Carol

    http://www.wapshere.com/missmiis
    Tuesday, October 27, 2009 9:15 AM
  • Also, when you created new attributes in ILM, please make sure to do iisreset and then a refresh schema in Sync. IISReset will make the FIM attribute shown in UI if it is not showing. Refresh schema will bring these attribute to Sync Engine. You may still need to add these attributes in MV, if you don't see them in MV. That is a separate process.

    Elisa Zhang
    Monday, November 9, 2009 8:58 PM