none
can not create FIM MA RRS feed

  • Question

  • I am trying to create FIM MA but get an error

    ---------------------------
    Synchronization Service Manager
    ---------------------------
    Failed to connect to the specified database.

     

    Failed to connect to the specified database or Forefront Identity Management Service. Please check the specified database location, service host address, and account information.
    ---------------------------
    OK  
    ---------------------------

    - Settings used for creating the MA are correct as i have just verified them , like the service base address , sql name and fim ma account.

    - FIM portal is working fine

    - User is member of administrator set

    -Checked the FIM MA account it is also correct , it has logon locally rights on FIM service , FIM sync servers

    -Using the Fim ma account i can connect to SQL (used SQL management console)

    -I tried with making fim ma account domain admin as well

    Any suggestions ?

    Is there any logging which i can enable ?


    AdiKumar

    Monday, July 9, 2012 10:54 AM

All replies

  • Are FIM Sync, FIM Service and FIM Portal running on the same box?

    Make sure Kerberos, especially the SPN for the FIMService service are correctly configured and matches the service base address you use when configuring the FIM Service MA..

    The FIMMA account should NOT be in the Administrator Set!

    Did you indeed configure the correct FIMMA account when installing the FIM Service?

    When installing the FIM Service the FIMMA account specified will be assigned to the built-in synchronization in FIM Service. This is then the account you must use when creating the FIM Service MA in FIM Sync.

    Monday, July 9, 2012 11:20 AM
  • FIM syn , Fim service , FIM portal are on different boxes. FIM service is on 2 nodes with NLB and 2 portal nodes with NLB.

    Yes , the SPNs are registered correctly for fim service.

    Not the FIM ma account is in administrator set , MY account is in administrator set.

    Yes I even ran the script to check if iam using the correct fim ma account.(http://social.technet.microsoft.com/wiki/contents/articles/2090.how-to-use-powershell-to-do-a-fim-ma-account-configuration-quick-test-en-us.aspx)

    I am using the same fim ma account while creating the MA.


    AdiKumar

    Monday, July 9, 2012 11:30 AM
  • I have seen this when there are differences in versions.

    Have you checked that FIM Sync and FIM Service run the same version?

    Check Firewall settings on SQL and FIM Service. I have seen cases where inbound traffic was limited to specific client IPs

    Monday, July 9, 2012 1:52 PM
  • What SQL Server version and FIM patch level - with SQL 2008 R2 there is adjustment needed in FIM Synch Service config file:

    http://social.technet.microsoft.com/Forums/eu/ilm2/thread/57fb3e73-71dc-4edd-aee0-e6827650ab45

    Also - does your FIM MA account has log on locally right on a servers? 

    Monday, July 9, 2012 2:13 PM
  • SQL is 2008 R2 SP1 and FIM patch level is fim service and portal hotfix KB 2520954

    FIM sync server has .net 2 so i can not make suggestions provided in the link.

    Also FIM MA account has locally logon rights on the servers (fim sync , fim service , SQL)


    AdiKumar

    Monday, July 9, 2012 3:16 PM
  • Yes FIM sync and FIM service run the same version.

    I need to check Firewall settings.


    AdiKumar

    Monday, July 9, 2012 3:17 PM
  • Hello Everyone,

    We are also facing problem.

    Anyone please help

    Tuesday, July 17, 2012 1:33 PM
  • You ca refer the below link

    http://www.tectuto.com/Forum.php?question=65&ques=Configuring%20FIM%20MA%20for%20portal%20issue.

    Thursday, July 11, 2013 11:12 AM
  • Have you tried everything listed in this article (or the 2 links within it)?  If so, and you have something to add to this article once you have a resolution, then please add a comment to this page.

    Bob Bradley (FIMBob @ TheFIMTeam.com) ... now using Event Broker 3.0 for just-in-time delivery of FIM 2010 policy via the sync engine, and continuous compliance for FIM

    Monday, July 15, 2013 2:27 PM