locked
Column headers do not appear in Windows Explorer RRS feed

  • Question

  • Hi all,
    As the title says, under the Windows Explorer of my Windows 7 64-bit installation on a Lenovo Thinkpad T61 notebook, ONLY FOR SOME FOLDERS, NOT ALL, the top bar with the column headers does not appear; hence I can't sort the files of that folder by clicking on the headers, or resize the width of the columns. Of course, I always made sure that I'm under "details" folder view.
    This is only the case of some folders, including personal "Documents" folder. I attached a picture of how it looks like at

    http://www.show-room.org/pics/window...titles_bug.jpg .

    As you can see, I'm indeed under "details" view. I use the german version of Windows, so don't wonder what it all means.

    This is very annyoing and this problem persists for at least 3 months now.

    How can I get the column titles for the affected folders back?

    I've googled the web, asked at experts-exchange.com, to no avail. I hope that maybe someone on this forum could help me out.

    Best regards,
    Steve
    Wednesday, April 7, 2010 11:19 PM

Answers

  • Hi Steve,

     

    I also think the issue should be related to certain software or service. Let's see if the issue can be resolved by accessing Clean Boot to check the issue. If the issue disappears in the Clean Boot environment, we continue to narrow down which entry is causing the issue.

     

    Also, check the issue using ShellExView by the steps below:

     

    1. Download ShellExView v1.41 from the following link http://www.nirsoft.net/utils/shexview.zip

     

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    2. Right-click the "shexview.zip" file, select "Extract All", the Extraction Wizard will prompt.

    3. Click Next, input "C:\ShellExView" (without the quotation marks) in the "Files will be extracted to this directory" textbox.

    4. Click Next and click Finnish.

    5. Open the "C:\ShellExView" folder and double-click the "shexview.exe" file. It will scan the registry for all the shell extensions.

    6. Select all the non-Microsoft extensions in pink by press "Ctrl" in the keyboard.

    7. Click the "Disable Selected Items" on the toolbar and click Yes.

    8. Restart your computer and check if the issue is resolved.

     

    What is the result?

     

    If the issue persists, you can check if it occurs in other user accounts or in a newly created user account.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Wednesday, April 14, 2010 1:59 AM
    Friday, April 9, 2010 6:30 AM
  • Hi Steve,

     

    It's glad to hear the issue does not occur in other accounts. According to the current situation, this issue should be caused by corrupted user account. Please create a new user account and then transfer the user files to the new account to resolve the issue.

     

    For the detailed steps, please refer to: Fix a corrupted user profile

     

    Regards,

    Linda

     

     

    • Marked as answer by Steve06 Sunday, April 25, 2010 12:50 PM
    Tuesday, April 13, 2010 5:43 AM

All replies

  • Hi Steve,

     

    You can first try perform a System Restore to restore the system to the date before the issue first occurred. If the issue persists, please move on to try the following suggestions:

     

    Reset the folder view settings

    =====

    1.     Navigate to the folder you would like to reset.

    2.     Click Organize -> Folder and search options.

    3.     Click View tab.

    4.     Click on the Reset Folders button.

     

    NOTE: If the Reset Folders button is grayed out, then please see the WARNING box at the top of the tutorial for why.

     

    5.     Click on Yes to confirm.

     

    If the issue persists, check the registry key by the steps below:

     

    Check registry key

    =====

     

    1.     Click the Start button, type "regedit" (without quotation marks) in the "Search" bar, right click on the "regedit.exe" found in the list and then click "Run as administrator".

    2.     Navigate to the following key:

     

    HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell

     

    3.     Right click the Shell entry on the left pane, choose "Export", select "Desktop" in the "Save in" box and type "backup" (without quotation marks) in "File Name". Click "Save".

     

    Please Note: The backup file is on the Desktop and named "backup.reg". We can simply restore the registry by double-clicking the "backup.reg" file.

     

    4.     On the left pane, right click on the BagMRU key, and click on Delete.

    5.     Click on Yes to delete.

    6.     On the left pane, right click on the Bags key, and click on Delete.

    7.     Click on Yes to delete.

    8.     Repeat step 1 to 3 to back up the following key:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell

     

    9.     On the left pane, right click on the BagMRU key, and click on Delete.

    10.  Click on Yes to delete.

    11.  On the left pane, right click on the Bags key, and click on Delete.

    12.  Click on Yes to delete.

    13.  Exit Registry Editor.

    14.  Log off and log on, or restart the computer to apply.

     

    Hope this helps.

     

    Regards,

    Linda

     

    Thursday, April 8, 2010 8:57 AM
  • Linda,

    thank you for your suggestion. Unfortunately the registry hack you mention hasn't resolved my issue (and neither has resetting the folder's settings).

    Interestingly, after rebooting the machine, the documents folder showed the column headers! After closing and reopening the folder, they were gone again!

    So there must be some active process or the like that causes this mess.

    I look forward to  more suggestions.

    Steve

    Thursday, April 8, 2010 4:52 PM
  • Hi Steve,

     

    I also think the issue should be related to certain software or service. Let's see if the issue can be resolved by accessing Clean Boot to check the issue. If the issue disappears in the Clean Boot environment, we continue to narrow down which entry is causing the issue.

     

    Also, check the issue using ShellExView by the steps below:

     

    1. Download ShellExView v1.41 from the following link http://www.nirsoft.net/utils/shexview.zip

     

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    2. Right-click the "shexview.zip" file, select "Extract All", the Extraction Wizard will prompt.

    3. Click Next, input "C:\ShellExView" (without the quotation marks) in the "Files will be extracted to this directory" textbox.

    4. Click Next and click Finnish.

    5. Open the "C:\ShellExView" folder and double-click the "shexview.exe" file. It will scan the registry for all the shell extensions.

    6. Select all the non-Microsoft extensions in pink by press "Ctrl" in the keyboard.

    7. Click the "Disable Selected Items" on the toolbar and click Yes.

    8. Restart your computer and check if the issue is resolved.

     

    What is the result?

     

    If the issue persists, you can check if it occurs in other user accounts or in a newly created user account.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Wednesday, April 14, 2010 1:59 AM
    Friday, April 9, 2010 6:30 AM
  • Dear Linda,

    thanks for your continuous support.

     

    I disabled ALL non-Microsoft services using shellexview, and rebooted the system afterwards - the issue still persists!

    Then I logged onto the same computer with another non-admin account - all column headers show up correctly. They do not vanish after some time either.

    So thinking about it again, I don't think any non-Microsoft extension is responsible for this undesirable behaviour.

    I can't believe Microsoft hasn't addressed this error with some patch - I'm certainly not the first one to discover it.

    Best regards,

    Steve

    Friday, April 9, 2010 9:54 PM
  • Hi Steve,

     

    It's glad to hear the issue does not occur in other accounts. According to the current situation, this issue should be caused by corrupted user account. Please create a new user account and then transfer the user files to the new account to resolve the issue.

     

    For the detailed steps, please refer to: Fix a corrupted user profile

     

    Regards,

    Linda

     

     

    • Marked as answer by Steve06 Sunday, April 25, 2010 12:50 PM
    Tuesday, April 13, 2010 5:43 AM
  • Linda,

    Ran into a very similar problem this past week.  Have been, over the last few days, searching for a solution.  Your solution did the trick.  I logged is as Adminstrator first to confirm this was a profile related problem.  Indeed it was.  I then logged in using Safe Mode with Network options, executed your steps, logged off, logged back in, and presto all was good.

    Thanks for this fix.  Rather annoying problem.  Would be good to know what causes this.

    Saturday, May 8, 2010 12:10 PM