none
Granfeldt's PSMA - Error on export (ma-extension-error, 0x80230703) RRS feed

  • Question

  • I'm running in to a error using Granfeldt's PSMA. I'm trying to export objects to Exchange, everything goes just fine, the new mailboxes are indeed provisioned, but PSMA hits error everytime I run the export;

    Error: ma-extension-error, Connected data source error: unexpected-error, Connected data source error code: 0x80230703.

    I enabled PSMA's logging feature and it shows that my export.ps1 script indeed starts (It logs it's stuff to other file where I can see that everything goes just like planed) and after that it throws "System.NullReferenceException: Object reference not set to an instance of an object."

    In the event viewer I see another error after the export:

    "Microsoft.MetadirectoryServices.EntryExportExeception: Object reference not set to an instance of an object. at Granfeldt.PowerShell.ManagementAgent.Microsoft.MetadirectoryServices.IMAExtensible2CallExport.PutExportEntrie(IList`1 csentries) Forefront Identity Manager 4.1.3508.0"

    I'm a bit confused because my export script works just fine.. is there something I should look after my Sync Rule from the portal or something else? Error messages don't help much... Thanks in advance!

    Tuesday, July 15, 2014 12:56 PM

Answers

  • Got it sorted, it was an error (or the MA thinks it's an error) in my script...

    Apparantely if I pass $aduser.setinfo() inside my export script, the failure occurs, but if I pass it like this: $dummy = $aduser.setinfo() then it works.

    • Marked as answer by Narcoticoo Friday, July 25, 2014 3:20 PM
    Friday, July 18, 2014 12:18 PM

All replies

  • Could you post your export script and output from the log for the PSMA? Also, please post which version of the MA you're using

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt


    Friday, July 18, 2014 7:32 AM
  • Got it sorted, it was an error (or the MA thinks it's an error) in my script...

    Apparantely if I pass $aduser.setinfo() inside my export script, the failure occurs, but if I pass it like this: $dummy = $aduser.setinfo() then it works.

    • Marked as answer by Narcoticoo Friday, July 25, 2014 3:20 PM
    Friday, July 18, 2014 12:18 PM
  • Could you please mark as answered if you feel it has been answered?

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Friday, July 25, 2014 6:47 AM
  • Sorry about that :)
    Friday, July 25, 2014 3:21 PM