none
Exchange Server 2007 not receiving mails from outside RRS feed

  • Question

  • Hello i am using Exchange 2007 , My exchange server is not receiving mails from other domains say xyz.com, or abc.com

    but i am receiving mails from  known domains like hotmail, yahoo, rediff,etc

    i use mcafee group shield for exchange , and i have whitelisted the domain say xyz.com but still i am not receiving  the mails from xyz.com but i can send them mail.

    please guide me.

     

     

    Sunday, October 16, 2011 7:20 AM

Answers

  • Hi,

    Besides, you can check the following:

    1. Check whether all users cannot receive emails from the specified domain

    2. Check whether some transport rules block the emails as shown in KB947662

    3. Please run ExBPA against Exchange servers for health check

    Wait for your reply.

    Thanks


    Sophia Xu
    • Marked as answer by Risingflight Saturday, December 28, 2019 7:06 PM
    Tuesday, October 18, 2011 1:41 AM

All replies

  • Hi Risingflight,

    Hello i am using Exchange 2007 , My exchange server is not receiving mails from other domains say xyz.com, or abc.com

    but i am receiving mails from  known domains like hotmail, yahoo, rediff,etc

    Enable the SMTP logging at the receive connector and check the log for errors:
    http://exchangepedia.com/2007/05/exchange-server-2007-logging-smtp-protocol-activity.html

    Do you know the error message external contacts get when they try to send you something?

    Furthermore enable the diagnostic logging at the server and check the event logs for errors too.

    i use mcafee group shield for exchange , and i have whitelisted the domain say xyz.com but still i am not receiving  the mails from xyz.com but i can send them mail.

    Post get-transportagents and temporally disable the mcafee agent or stop the full service. Are you able to receive mails from all domains then?


    __________________
    Viele Grüße
    Christian

    Sunday, October 16, 2011 9:36 AM
  • Could well be an issue with the sender domain as you say you get emails from other external domains fine. 

    Up the logging as above and check message tracking and protocol logs to see if the message is even hitting you Exch servers.

    There may be some sort of filtering going on, so see if the message get to Exch 1st.


    Sukh
    Sunday, October 16, 2011 4:38 PM
  • Hello i am using Exchange 2007 , my clients are not able to send email to my exchange server but i am able to send to them.i am facing this issue with other domains say a.com, b.com  , within in my domain no issues.

    They tell me they r getting this message when they send mail.

    Your message wasn't delivered because of security policies. please guide me 

    say my exchange server name is mail  domain is abc.com  so its mail.abc.com

    internal ip: 192.168.1.3  

    external ip  say 140.140.140.140

    my domain i have checked it is not black listed and also i use McAfee groupshiled i have stopped its service.

     


    Monday, October 17, 2011 4:11 PM
  • outside users tell  they r getting this message when they send mail.

    Your message wasn't delivered because of security policies. please guide me 

    say my exchange server name is mail  domain is abc.com  so its mail.abc.com

    internal ip: 192.168.1.3  

    external ip  say 140.140.140.140

    my domain i have checked it is not black listed and also i use McAfee groupshiled i have stopped its service.

    Monday, October 17, 2011 4:12 PM
  • outside users tell  they r getting this message when they send mail.

    Your message wasn't delivered because of security policies. please guide me 

    say my exchange server name is mail  domain is abc.com  so its mail.abc.com

    internal ip: 192.168.1.3  

    external ip  say 140.140.140.140

    my domain i have checked it is not black listed and also i use McAfee groupshiled i have stopped its service.

    Monday, October 17, 2011 4:13 PM
  • Have you set the connector logging and then tried to reproduce the issue and checked the logs?
    Sukh
    Monday, October 17, 2011 5:20 PM
  • guide me how to set the connector logging
    Monday, October 17, 2011 7:25 PM
  • Above, posted by Christian
    Sukh
    Monday, October 17, 2011 7:52 PM
  • Does mail from the internet go directly to the Exchange Server or through another gateway?

     

    Monday, October 17, 2011 7:56 PM
    Moderator
  • Hi,

    Besides, you can check the following:

    1. Check whether all users cannot receive emails from the specified domain

    2. Check whether some transport rules block the emails as shown in KB947662

    3. Please run ExBPA against Exchange servers for health check

    Wait for your reply.

    Thanks


    Sophia Xu
    • Marked as answer by Risingflight Saturday, December 28, 2019 7:06 PM
    Tuesday, October 18, 2011 1:41 AM
  • Dear Mr Weihs,

     

    i have tried the article u have mentioned but it did not work ,

    check the below article

    http://www.howexchangeworks.com/2009/06/email-from-external-user-to.html

    Open the Exchange Management Console
        Expand Recipient Configuration
        Click Distribution Group
        Double click the distribution group
        Select the Mail Flow Settings Tab
        Double click Message Delivery Restrictions
        Uncheck “Require that all senders are authenticated “
        Click OK

    When i see my EMC , when i double click Distribution group i cannot see anything wht mentioned above

    but when i check any user properties i can see the Require that all senders are authenticated is unchecked

    please guide me unable to trace out the problem.

    how to change AD group scope of the account with the email address from global to a universal group

     

     

     

    Tuesday, October 18, 2011 4:19 AM
  • i have tried the article u have mentioned but it did not work  wht christian mentioned but did not work

    check the below article

    http://www.howexchangeworks.com/2009/06/email-from-external-user-to.html

    Open the Exchange Management Console
        Expand Recipient Configuration
        Click Distribution Group
        Double click the distribution group
        Select the Mail Flow Settings Tab
        Double click Message Delivery Restrictions
        Uncheck “Require that all senders are authenticated “
        Click OK

    When i see my EMC , when i double click Distribution group i cannot see anything wht mentioned above.

    can i create a new distribution group, will it work.

    but when i check any user properties i can see the Require that all senders are authenticated is unchecked

    please guide me unable to trace out the problem.

     

    how to change AD group scope of the account with the email address from global to a universal group

     

     

     

    Tuesday, October 18, 2011 4:21 AM
  • Can you post the message the outside users are getting (NDR I assume).
    Sukh
    Tuesday, October 18, 2011 12:18 PM