locked
USB ports not working RRS feed

  • Question

  •  

    None of my usb ports are working after i re-intalled vista home premium (EN), meaning that they used to work. I have tried with various usb items such mouse, keyboard, memory stick, and other devices. They all work fine on my laptop, which is running on XP.

     

    I have searched the web for various problem solutions, but none of them has worked.

     

    I have msi 975x as mainboard, and have disconnected the front panel usb ports, which were suggested in a msi tech thread. - not working.

     

    I have uninstalled all usb controllers in device manager, and when vista restarts it seems that it does detect and installs new drivers for the ports. - not working.

     

    I tried to install various updates for vista regarding usb problems such as Update for Windows Vista (KB940199), but none of them can be installed, as im getting "the update does not support your system" message - so dont know if this would have worked.

     

    I have checked bios and enabled the usb settings - not working.

     

    The power in my ports is working, as there is power coming to my devices such as memory stick.

     

    Im not a hardcore techie so any answers to my problem, is appreaciated to be very easy to understand.

     

    Thx

     

    Sunday, September 14, 2008 12:05 PM

Answers

  • Hi,

     

    Based on my experience, this issue can be caused by corrupt INF files. At this time, let’s troubleshoot this issue by copying these files from another computer.

     

    1. Please copy usbstor.inf and usbstor.PNF (c:\windows\inf) from another known computer to problem computer. (You also can upload them from another known computer to your email and download them to problem computer)

    2. Reboot the computer and connect the USB device and Check if it gets detected and works fine.

     

    Does it work?

     

    Hope it helps.

     

     

    Wednesday, September 17, 2008 7:18 AM
    Moderator