none
Microsoft Authenticator crashes on Huawei P9 RRS feed

  • Question

  • Hello,

    I installed Microsoft Authenticator. After adding an account for school and work, finish the authorization. Everything went well. But A few days after, when I relaunch the application. It keeps crashing and I'm no more accessible to my account anymore.

    I have to reinstall again and activate the account again to use it.

    This is very annoying for the usage. Can you please tell me if you would spend time to look at this crashing issue?

    Thanks.

    Wednesday, January 2, 2019 9:48 AM

All replies

  • My Huawei Mate 20 pro has the same issue, the only difference is the crash will happen 10-30mins after Authenticator installed and configured. not sure what causes this incompatibility issue.  pretty annoying.
    Sunday, January 20, 2019 8:58 AM
  • same problem in here. i am using huawei P9, can't even go to teamspace...it is a very serious issue. Please solve it ASAP. 

    • Proposed as answer by SierraSue Thursday, February 21, 2019 5:16 PM
    • Unproposed as answer by SierraSue Thursday, February 21, 2019 5:16 PM
    Tuesday, January 22, 2019 9:10 AM
  • The same here on Huawei Honor 9. Authenticator chrashes upon launch. It has been working before. Authenticator reports version 6.2.28. Android version 8.0.0. 
    Friday, February 22, 2019 10:00 AM
  • The same problem with my P10. It worked for 2-10 days each time after I have reset it. Resetting it is inconvenient as I have to ask our local IT to re-generate a QR code. 
    Thursday, April 11, 2019 2:51 AM
  • A Google search showed that the iOS community is experiencing exactly the same problem for a number of years. My colleagues have the same problem with various brands of the Android devices. It sounds that MicroSoft is the genuine brand of this problem. It is independent of the operating systems, the brands of the phone or model. 
    Thursday, April 11, 2019 3:07 AM
  • Same with my Honor 10, and our school require it.
    Thursday, October 3, 2019 9:35 AM
  • I found the issue being Huawei AppGallery keeps 'upgrade' your current version to its 6.2.28 version which is actually older. I ignored the update and so far it works fine
    • Proposed as answer by Hao Xu (HAX) Thursday, October 17, 2019 7:45 AM
    Thursday, October 17, 2019 7:43 AM