locked
Can't Install AD DS - the specified server requires a restart RRS feed

  • Question

  • I have installed some features successfully but when I try to install the Active Directory Domain Service, the installation doesn't complete with the following message:

    the specified server requires a restart

    I've been trying for days to install this feature, and none of the solutions I found in internet helped me.

    Restarting doesn't work

    Adding "NT SERVICE\ALL SERVICES" to the "log on as a service" also doesn't work.

    Please answer with details as I am a begginner user, just trying to set-up a shared workfolder to my enterprise in the recently bought server.

    Tuesday, July 21, 2015 8:42 PM

All replies

  • Hi

     Please share more details??Could you check the error logs on event viewer and paste here the error code,so we can help more...

    Tuesday, July 21, 2015 8:49 PM
  • Might be obvious, but have you restarted your server and tried again?
     
    As Burak requested, any related event logs would be extremely helpful here.
     
    I didn’t find too much info about this issue via search, the only approach that reportedly works for one person is to assign the Log on as a service user right to NT SERVICE\ALL SERVICES, but you already failed it.
     
    Also, which operation system are you using? Is it a new installed OS? This could also be due to some corruption errors in Windows, as an initial troubleshooting steps, you can try to fix Windows corruption errors by following the steps in this article: https://support.microsoft.com/en-us/kb/947821
     
    Please feel free to post back with any findings.
     
    Hope this helps.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, July 22, 2015 8:43 AM
  • I have bought a server with windows server 2012 RC2 to use the simples function of workfolder, share files with computers in network.

    We have done nothing but to install some features, and when it came to install the AD DS, this error is happening.

    I'm sorry, I have little experience with Windows Server, I've tried to reach the error log in Event Viewer but I haven't found it specifically, as there is so much information.

    If someone can tell me how to find the error log to this operation specifically, or send me some guide on how to use the event viewer, I think I could research it better and solve the problem.

    Thanks in advance,

    Paulo

    Friday, July 24, 2015 5:38 PM
  • Hi

     Server Manager->Tools->Event viewer check the logs for errors..

    Friday, July 24, 2015 6:14 PM
  • These are the two relevant errors I found in the event viewer. Note that my Windows Server is not in english so the translation might not be exact.

    Fail to activate the update DirectoryServices-AdministrativeCenter from package DirectoryServices-AdministrativeCenter-Package. Status: 0x80070bc9.

    Fail to activate the update ActiveDirectory-PowerShell from package ActiveDirectory-PowerShell-Package. Status: 0x80070bc9.

    The other events are "starting the installation of the package..." of several components of ActiveDirectory, and then only these two errors.


    Monday, July 27, 2015 1:35 PM