locked
Problem with Folder Redirection RRS feed

  • Question

  • Hi

    We have a GPO that redirects My Documents to a network share and I have recently changed the location of this network share by modifying the server path of the GPO.  The GPO is set to leave the contents behind and it has been set (historically and now) to grant exclusive rights to the user.

     

    The functional level of the domain/forest is 2008R2 and the users log on to predominantly a mix of 2008R2 RDS Servers and occasionally a 2003 TS and 2012 RDS Server.

    This has so far gone very for all users but there is one user who is not able to access their Documents on all servers.  The Documents appear to have been moved from the old location to the new, but the following has happened:

    • The NTFS permissions on the old folder appear to have become corrupted.  Even after taking ownership of the folder I get an "Access Denied" error message and cannot view the contents of the folder at all.
    • When logging onto one 2008R2 RDS Server (which happens to be our remote access server) the user can see their documents OK
    • When logging onto other 2008R2 RDS Servers (including those part of a Farm and standalone) the user does not see any Documents in their Document folder.  When running an RSOP on these servers we have the error as below (this shows as "Success" on the remote access server):

    • When the user logs onto our 2012 RDS Server the get the below error and cannot see their documents.  Clicking no then brings up the same error but for Pictures, Music & My Documents:

    At the moment I have the user logging on to our remote access server internally.  How can I permanently resolve the problem of the user not being able to see their Documents everywhere?

    Many thanks

    Tuesday, May 19, 2015 12:49 PM

Answers

  • Hi,

    The NTFS permission issue is caused by the setting of "exclusive rights". And we cannot cancel this option unless create a new policy.

    Here are 2 threads which provided solutions to move Folder Redirection to a new server:

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/89cec7c5-3254-40e1-92ae-19ba1b1e8813/

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/dcf5fd74-6e89-41e4-8e41-c161b7cbb695/

    As it is already done, instead of redo the movement, you can can to check the registry key listed below. Change it to the new path and see if it will work.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

    If still not, as only 1 user was affected, go to the redirected folder on server, backup all content and reset the user profile. Restore content to newly created profile to workaround this issue. 


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 20, 2015 7:10 AM