locked
Slow App-v package installation from SCCM RRS feed

  • General discussion

  • Hello in our environment we use SCCM 2012 CB 1806 for our Windows 10 environment and we also have App-V packages who are streamed from this SCCM server to endpoint.

    At the moment we have a performance problem when a user installs some (not all) App-V packages form Software Center on the endpoint. The installation can take 1 – 2 minutes and sometimes it will display an error 0x870128F. When I click to try the installation again it will end successfully.

    We also have 1 package that will install successfully but when I start it immediately after it installs successfully I got the error 0x35E501405-00090001 (only once). When I wait for 30-60 seconds I can start the without any error.

    We also have SCCM 2012 R2 Sp1 for our Windows 8.1 environment. When installing the same packages mentioned above we neve see this errors or slow installation. The package will install within a few seconds.

    So what is causing this delay and error?

    Regards,

    Ron

    Tuesday, February 5, 2019 8:14 AM

All replies

  • Hello

    Is there not anyone who can help me with this problem.

    On another forum I found something about the anti virus exclusions of App-V.

    So I added these exclusions  to our mallware policy on the SCCM server. This action did not resolve the issue.

    As another task I used powershell to do the same actions as SCCM wil do.

    And the command which is very slow is Add-AppvClientPackage

    So if anyone can help me, please.

    Regards,

    Ron

    Wednesday, February 6, 2019 1:38 PM
  • Hi to all

    Today I did some further testing and I monitored the AppEnforce.log during the installation of a App-V package installed within Software Center. The total time of package installation is 4,5 minutes.

    And there are only 3 commands that are executed during the installation of the package:

    "C:\\WINDOWS\\system32\\WindowsPowerShell\\v1.0\\PowerShell.exe" -ExecutionPolicy Bypass if((Get-ItemProperty 'HKLM:\SOFTWARE\Microsoft\AppV\Client' 'Enabled' -ErrorAction SilentlyContinue) -eq $null) {import-module 'C:\Windows\System32\AppvClient\AppvClient.psd1'};  Add-AppvClientPackage -Path 'http://sccmdp01.wml.nl:80/SMS_DP_SMSPKG$/Content_bd129e2b-63b9-4afd-88b9-3e25826fac7c.1/CTI Toolkit_Cisco_10.5.2042_x86_EN_1.appv'  -DynamicDeploymentConfiguration 'C:\WINDOWS\ccmcache\f\CTI Toolkit_Cisco_10.5.2042_x86_EN_1_DeploymentConfig.xml' with system context

    "C:\\WINDOWS\\system32\\WindowsPowerShell\\v1.0\\PowerShell.exe" -ExecutionPolicy Bypass if((Get-ItemProperty 'HKLM:\SOFTWARE\Microsoft\AppV\Client' 'Enabled' -ErrorAction SilentlyContinue) -eq $null) {import-module 'C:\Windows\System32\AppvClient\AppvClient.psd1'};  Set-AppvClientPackage -PackageID f29f9e47-e65d-4b1d-96e6-062944ea6e5b -VersionID dc54718d-b981-4746-917d-e0dfbfa2a352  -DynamicDeploymentConfiguration 'C:\WINDOWS\CCM\SystemTemp\AppVTempData\f29f9e47-e65d-4b1d-96e6-062944ea6e5b_DeployConfig.xml' with system context

    "C:\\WINDOWS\\system32\\WindowsPowerShell\\v1.0\\PowerShell.exe" -ExecutionPolicy Bypass if((Get-ItemProperty 'HKLM:\SOFTWARE\Microsoft\AppV\Client' 'Enabled' -ErrorAction SilentlyContinue) -eq $null) {import-module 'C:\Windows\System32\AppvClient\AppvClient.psd1'};  Publish-AppvClientPackage -PackageID f29f9e47-e65d-4b1d-96e6-062944ea6e5b -VersionID dc54718d-b981-4746-917d-e0dfbfa2a352 -Global -ev err; if(($err -ne $null) -and ($error[0].Exception.AppvWarningCode -eq 8589935887)) {$host.SetShouldExit(4736)} with system

    The only command which has a fast execution is the Publish-AppvClientPackage

    When I run the these commands in a dos box I don't have any delay's. All commands run and end within a second.

    So I think the problem has to be in SCCM or software Center.

    Still no one with an idea?

    Regards,

    Ron.

    Thursday, February 7, 2019 10:43 AM
  • We found the solution.

    In SCCM 1806 CB there is a new feature you can adjust.

    Go to Administration  - Hierarchy Configuration - Boundary Groups

    Open a boundary group and go to the tab Options

    We unchecked the "allow peer......." checkbox

    After this all App-v packages streamed very fast.


    The explination of this is that we use the App-V packages in stream mode.

    But when you enable this option a workspace will look for all other workspaces who installed the package. So it tries to install the package form another workspace instead of the SCCM DP.

    Because we stream a App-v package there is no packages at de local cache to install. So there the waiting begins. 

    When you monitor the VirtualApp.log on the workspace you can see alle the other workspaces it tries to communicate with. I think this is a bug because if you are using App-v in streaming mode this option should be unmarked by default.

    Thursday, April 18, 2019 1:57 PM
  • This sounds like a bug... .pearcache is a great feature, especially for branch offices.
    Did you allready report this to MS?


    Roy Essers

    Wednesday, April 24, 2019 12:26 PM
  • No because I'm not 100% sure its a bug.

    Maybe we configured SCCM not as by design.

    Thursday, April 25, 2019 6:27 AM
  • Installation time is dependent a subset of the following factors:

    •  Size of the Package.
    •  How the streaming blocks were configured in the package.
    •  Whether "Bits" or HTTP streaming is being used.
    •  Speed of the access to the DP (ie: DP with a slow disk and lots of competing disk activity)

    Your notes below seem to indicate HTTP streaming.  Having the App-V packages built with a launch only publishing block is recommended over a full primary block.


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)


    Tuesday, May 14, 2019 10:24 PM
    Moderator