locked
Bitlocker Malfunction Halfway Through Encrypting Drive RRS feed

  • Question

  • Need help with a 2tb external hd that I was encrypting when half-way through I accidentally bumped it and made it disconnect from the pc. When it connected again it tried to keep on encrypting from where it left off, at 39.5% but now it's just stuck here, and it won't allow me to access the files like you normally can when it's encrypting.

    Please help! So far, I've tried using the repair-bde tools to try and decrypt it and allow me access. I used the following code:

    repair-bde H: F: -rp (recovery password) 

    The H: is the damaged drive and F: is another 2tb hd I have. Basically it started decrypting but got to 39% and then it stalled with a lot of errors like this: LOG ERROR 0x000002b, Failed to read sector at offset 791759691776 (0x000000017)

    I did that but doesn't give me access back to the hd. I disconnect/reconnect the hd, windows ask for the bitlocker password, I enter it, and it goes back to 39.5% again. And momentarily it shows me the folders, as you can see below in the picture. But then it freezes up and I can't access anything.

    Which makes me think if I was able to stop bitlocker trying to keep encrypting the drive I might be to copy the files over to the new drive. Please help! 

    UPDATE 16/3/18: I've had repair-bde running now all through the night and it's finally got through the log errors and is continuing to decrypt from 45% onwards, now 46% so it seems to be going again and hopefully it will show some results soon. So, looks like I just needed to let it do its thing and not interrupt! =)

    And it's up to 60% now, so looking good! =)




    • Edited by MatthewPyle Thursday, March 15, 2018 10:29 PM
    Thursday, March 15, 2018 3:25 AM

All replies

  • Sorry, can't post the picture, as I'm not a verified user yet, but basically just shows that I can see the folders on the hd in a froze state, can't click on anything.

    Thursday, March 15, 2018 5:07 AM
  • Unfortunately, sounds like the external drive is hosed.

    If you don't have a backup you can try a business that specializes in recovery, but I'd bet it will be very costly and there's no guarantee you'll get any of the data back.


    http://www.wwiivehicles.com

    Thursday, March 15, 2018 4:02 PM
  • Do you think there would be a way of pausing bitlocker? At the moment I've done the repair-bde again and have been allowing it just to go through those log errors. I'll see if it stops eventually! =) 
    Thursday, March 15, 2018 6:02 PM
  • life lesson; don't encrypt volumes of production equipment without backups.
    Thursday, March 15, 2018 6:06 PM
  • I know, I've learned the hard way that's for sure! Just started bitlocking everything recently, other drives and so forth and just got a bit too casual, not realizing how dangerous it is if you mess it up
    Thursday, March 15, 2018 7:49 PM