locked
Uninstall WSS 3.0 SP2 and re-install WSS 3.0 SP1 RRS feed

  • Question

  • My workflows is working not properly after the WSS 3.0 SP2 was installed on the server, I tried to uninstall and re-install with WSS 3.0 SP1 which is working fine but I can’t. I got an error below while the configuration wizard was working.

     

    I tried to re-create the workflow loop as advised in a website below but it is still working incorrect.

     

    How should I clean all configurations of WSS 3.0 SP2 from the server?

    Thank you in advance for your kind assistance

     

     

    http://blogs.msdn.com/b/sharepointdesigner/archive/2009/07/13/service-pack-2-prevents-an-on-change-workflow-from-starting-itself.aspx?PageIndex=2

     

     

    10/17/2011 20:37:33  6  ERR                       
    Failed to install the application content files.
    An exception of type Microsoft.SharePoint.Upgrade.SPUpgradeException was thrown. 
    Additional exception information: The specified Microsoft.SharePoint.Administration.SPIisWebSite has been upgraded to a newer version of SharePoint.
    Please upgrade this SharePoint application server before attempting to access this object.
    Microsoft.SharePoint.Upgrade.SPUpgradeException: The specified Microsoft.SharePoint.Administration.SPIisWebSite has been upgraded to a newer version of SharePoint.
    Please upgrade this SharePoint application server before attempting to access this object.
       at Microsoft.SharePoint.Upgrade.SPSequence.get_CanUpgrade()
       at Microsoft.SharePoint.Upgrade.SPManager.CanUpgrade(Object o)
       at Microsoft.SharePoint.Upgrade.SPManager.ReflexiveCanUpgrade(Object o)
       at Microsoft.SharePoint.Upgrade.SPManager.NeedsUpgrade(Object o, Boolean bRecurse)
       at Microsoft.SharePoint.Administration.SPWebService.ApplyApplicationContentToLocalServer()
       at Microsoft.SharePoint.PostSetupConfiguration.ApplicationContentTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    Tuesday, October 18, 2011 3:32 AM

Answers

  • Yes, as SP1 now falls outside of the Product support life cycle.

    The SPDN blog does provide two alternatives though.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Tuesday, October 18, 2011 9:14 AM
    Answerer

All replies

  • Hi,

    This is a normal error when you downgrades the version. The backward compatibility is not supported.

    Do you have DB backups taken while you initially migrated from SP1 to SP2?

    If yes then restore thema nad then execute psconfig.

    I hope this will help you out.

     


    Thanks, Rahul Rashu
    Tuesday, October 18, 2011 4:04 AM
  • Hi Rahul,

    Thank you very much for that information, I can't believe the backward compatibility is not supported.

    I have the configuration database backup file before migrated to SP2, what I tried are:

    • Uninstalled SP2
    • Restore the config db (before migrated)
    • Re-install SP1
    • Ran the sharepoint config wizard but I got error messages as above (last step)

    Is there a way to fix the problem? I want my workflows which is working fine back. :=

    Tuesday, October 18, 2011 4:38 AM
  • Hi,

    Do you have backup of config db only or other DBs as well?

    I would suggest you to restore all and then try again.


    Thanks, Rahul Rashu
    Tuesday, October 18, 2011 4:57 AM
  • Hi,

    Thank you again for the suggestion.

    I have backup of config db and central administration's content db as well.

    I'll try to restore all tonight.

    If the result is still the same, that means it is impossible to roll back to SP1????

    Tuesday, October 18, 2011 6:15 AM
  • Yes, as SP1 now falls outside of the Product support life cycle.

    The SPDN blog does provide two alternatives though.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Tuesday, October 18, 2011 9:14 AM
    Answerer
  • Thank you Steven.

    May I have an address of the SPDN blog please?

    Thank you.

    Tuesday, October 18, 2011 9:52 AM
  • It was the post that you linked, read through to the end.
    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Tuesday, October 18, 2011 10:05 AM
    Answerer