locked
Co Existence of Exchange server 2010 and Exchange server 2013 RRS feed

  • Question

  • Hi Guys,

    I have a confusion with my Current set up and I hoping someone can help me solving this Issue. so I have running exchange server 2010 Environment and I have also smart Host for exchange server for the outbound Mail flow and For In bound mail flow we are using a Virtual web server (Sophos) which is routing the Traffic to internal Exchange client access server.

    and Recently I have introduced Multi role Exchange server 2013 to my Environment.

    steps which i have already Done

    • Configure the Auto Discover
    • Configure the Certificate and services with Correct Namespaces.
    • Configure all the Internal and external Client access name Spaces.
    • Configured the New Mailbox Databases.
    • Testing the server Configuration.
    •  Create new Exchange mailbox on the Exchange server 2013.
    • I have checked the Send and receive connector set up and they are automatically Set us they Should be.
    • Made auto-discover test and as well as the sent and receive emails.
    • All seems to be working with New exchange 2013 mailbox

    I have question about how is this Working , my Interface Facing server is still the Exchange 2010 server and what should i do to make sure that Exchange 2013 Works as Internet facing server and then it can down Proxy to Exchange 2010.

    I hope I have made my Self clear , please guys any tip will be useful.

    Thanks in advance.

    Thursday, August 4, 2016 2:11 PM

Answers

  • You wont have any issues accessing exchange 2013 mailbox internally as Internal client query AD for getting the autodiscover information and When we install new exchange server it creates its own SCP record.

    Further to move exchange 2013 as the internet facing site:-

    Move external DNS record to exchange 2013 client access URL.

    Make sure you have correct certificate and name space setup for exchange 2013.

    This is all required to move CAS traffic to exchange 2013.

    For moving the email flow:- make sure to add exchange 2013 mailbox server in existing send connector.

    Change the internal SMTP routing to exchange 2013 servers and setup the receive connector same as setup in exchange 2010.

    upgrade the default address list policy.

    And thats It you need to do for setting up exchange 2013 as internet facing server.

    • Proposed as answer by Jason.Chao Friday, August 5, 2016 8:07 AM
    • Marked as answer by Jason.Chao Friday, August 19, 2016 1:45 AM
    Thursday, August 4, 2016 3:20 PM

All replies

  • You wont have any issues accessing exchange 2013 mailbox internally as Internal client query AD for getting the autodiscover information and When we install new exchange server it creates its own SCP record.

    Further to move exchange 2013 as the internet facing site:-

    Move external DNS record to exchange 2013 client access URL.

    Make sure you have correct certificate and name space setup for exchange 2013.

    This is all required to move CAS traffic to exchange 2013.

    For moving the email flow:- make sure to add exchange 2013 mailbox server in existing send connector.

    Change the internal SMTP routing to exchange 2013 servers and setup the receive connector same as setup in exchange 2010.

    upgrade the default address list policy.

    And thats It you need to do for setting up exchange 2013 as internet facing server.

    • Proposed as answer by Jason.Chao Friday, August 5, 2016 8:07 AM
    • Marked as answer by Jason.Chao Friday, August 19, 2016 1:45 AM
    Thursday, August 4, 2016 3:20 PM
  • Hi

    If you coming from the same public ip then just point to your 2013 server. Ensure that external dns is set to your new box. If a mailbox is on a 2010 server then it will proxy down. a newer version of exchange will handle your mailflow.


    Edward van Biljon - Exchange MVP

    Thursday, August 4, 2016 3:26 PM
  • Hi,

    Everything you configured, but double check the send connector, I think you need to add the new exchange 2013 server to the server list. Plus if you are using common names like mail.domain.com for autodiscoverserviceinternaluri (SCP) and all client access settings (OWA, OAB, ECP, OA, EWS), then it is just matter of change the IP address in your internal DNS point to the new exchange server. 

    Once you tested all fine internally, just check how your exchange server published to outside. If using reverse proxy or NAT on a firewall. Just you need to change the exchange server IP only with the new server IP. On a reverse proxy setup, double check the SSL certificate and update it if required.

    Thanks

    Prabodha

    -------------------------------------

    Please mark as answer if found useful :)

    Thursday, August 4, 2016 4:11 PM
  • Also, do not forget following Exchange deployment assistant.

    This guide is available from Microsoft team and provides step-wise instructions by checking all the necessary prerequisites. Here you go - https://technet.microsoft.com/en-us/office/dn756393.aspx

    Here's another informative article which covers some glitches to evade while migrating from Exchange 2010 to Exchange 2013 - http://www.exchangemigrationtool.com/blog/2013/migrating-from-exchange-2007-2010-to-exchange-2013/

    Friday, August 5, 2016 5:38 AM
  • Hi,

    Everything you configured, but double check the send connector, I think you need to add the new exchange 2013 server to the server list. Plus if you are using common names like mail.domain.com for autodiscoverserviceinternaluri (SCP) and all client access settings (OWA, OAB, ECP, OA, EWS), then it is just matter of change the IP address in your internal DNS point to the new exchange server. 

    Once you tested all fine internally, just check how your exchange server published to outside. If using reverse proxy or NAT on a firewall. Just you need to change the exchange server IP only with the new server IP. On a reverse proxy setup, double check the SSL certificate and update it if required.

    Thanks

    Prabodha

    -------------------------------------

    Please mark as answer if found useful :)

    Thanks for your Reply, I have Already Added the New Exchange 2013 Server to the Send Connector Server List, But i am having some Confusions about the Receive Connector and SMTP Internal Relay and External Relay Computer.

    Receive Connector (Exchange 2010)

    I Have One SMTP Proxy Connector. which is defined like this.

    SMTP-Proxy Role: Hub Transport
    Security : Anonymous Users.
    Scoping: *Remote network settings:
    Receive mail from servers that have these remote IP 
    
    addresses.X.X.X.X/24 Internal Ip of the SMTP Proxy

    *Network adapter bindings: Specify the IP addresses and port of the network adapter to bind to the receive connector.
    ALL Avaliable IPV4 

    I am just confussed to create this Connecotr in the Exchnage 2013 Server , there are few more Option which making me confussed.

    Thank you so much



    Friday, August 5, 2016 10:22 AM
  • Hi all ,

    I really Appricaite your Time which you have Invested in Thread, I am having some confussion regarding to the Recieve connector.

    At the Moment , my Exchange 2010 server is internet Facing and i have Alredy move one test mailbox to the Exchange 2013 Server and everything is Working , I can send and receive the emails in the Mailbox which is on the Exchange 2013 server, so i guess, its being proxied somehow.

    Can someone please explain it why is this happening.

    and Some ideads about the Receive connector.

    when i try to create a new receive connector for SMTP Proxy,

    and at the end I get this Error

    error
    The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SVV-EX13\Default Frontend SVV-EX13". Receive connectors assigned to different Transport roles on a single server must listen on unique local IP address & port bindings.
    button. There is 1 message in the pop-up window. 1: Error,The values that you specified for the Bindings and RemoteIPRanges parameters conflict with the settings on Receive connector "SVV-EX13\Default Frontend SVV-EX13". Receive connectors assigned to different Transport roles on a single server must listen on unique local IP address & port bindings. 

    I am not quite Sure which Connector is necessary to have in the List of Connectors On the Exchange 2013

    thank you so much.


    • Edited by SJ04 Friday, August 5, 2016 10:40 AM Added some more
    Friday, August 5, 2016 10:29 AM
  • Hi,

    The proxy connector is Frontend transport for the mail flow between exchange 2013 and 2010, no need to worry about it. The default receive connectors are enough for mail receive from outside and mail flow between these exchange servers. 

    If you have any special requirements like any 3rd party application or server want to send/receive mails using your exchange, you may create a separate receive connector. Just read this URL, to know how to create new receive connector: http://www.msexchange.org/kbase/ExchangeServerTips/ExchangeServer2013/SetupDeployment/creating-custom-receive-connector-exchange-2013.html

    Thanks

    Prabodha 

    Saturday, August 6, 2016 12:07 PM
  • Hi Guys,

    I am Having error in the co -existence environments between exchange 2010 and 2013 .

    All the mail clients are keep disconnecting the Connection with the server.

    can somebody explain me about it please , its urgent.

    thanks

    Tuesday, August 9, 2016 4:32 PM
  • Hi SJ04

    There may be multiple reasons for disconnecting and reconnecting. First, might be Exchange 2013 database point to default public folder is deleted in ADSI edit. Just verify with command: Get-MailboxDatabase | FL name, PublicFolderDatabase

    You may follow this article if this is the fault: https://support.microsoft.com/en-us/kb/2962915

    ---------

    There may be another reason, the Autodiscover service point settings if different in both exchange servers, check with command: Get-ClientAccessServer -Identity CASServer -AutoDiscoverServiceInternalUri

    By default the SCP configured with this URL- https://serverFQDN/Autodiscover/Autodiscover.xml, you can change it to a common name like https://mail.domain.com/Autodiscover/Autodiscover.xml and the SSL certificate should be this 'mail.domain.com SAN name exist.

    You also use this common name mail.domain.com for all your client access settings. Follow this article for details: http://www.shudnow.net/?s=autodiscoverserviceinternaluri

    --------

    Thanks

    Prabodha

    (mark as answer if found useful)

    Tuesday, August 9, 2016 5:35 PM
  • Hi SJ04

    There may be multiple reasons for disconnecting and reconnecting. First, might be Exchange 2013 database point to default public folder is deleted in ADSI edit. Just verify with command: Get-MailboxDatabase | FL name, PublicFolderDatabase

    You may follow this article if this is the fault: https://support.microsoft.com/en-us/kb/2962915

    ---------

    There may be another reason, the Autodiscover service point settings if different in both exchange servers, check with command: Get-ClientAccessServer -Identity CASServer -AutoDiscoverServiceInternalUri

    By default the SCP configured with this URL- https://serverFQDN/Autodiscover/Autodiscover.xml, you can change it to a common name like https://mail.domain.com/Autodiscover/Autodiscover.xml and the SSL certificate should be this 'mail.domain.com SAN name exist.

    You also use this common name mail.domain.com for all your client access settings. Follow this article for details: http://www.shudnow.net/?s=autodiscoverserviceinternaluri

    --------

    Thanks

    Prabodha

    (mark as answer if found useful)

    I have question, this is only happening with MAC Clients. Any Thoughts ? and where i can Check the Logs about it ?
    Tuesday, August 9, 2016 6:38 PM
  • Hi,

    Please check the IIS log, please refer to the following article:

    https://msdn.microsoft.com/en-us/library/ms525410(v=vs.90).aspx

    https://blogs.msdn.microsoft.com/friis/2014/02/06/how-to-analyse-iis-logs-using-logparser-logparser-studio/

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jason Chao
    TechNet Community Support

    Monday, August 15, 2016 3:21 AM